Results 1 to 5 of 5

Thread: No sound from CD on Dell1525

  1. #1

    Default No sound from CD on Dell1525

    I had a problem with my sound last week and I
    was greatly helped by oldcpu. Now after fiddling
    for another week I discover that everything
    related to sound seems to work EXCEPT that
    I can't play a CD. I've tried KsCD and banshee.
    Both show an increasing timer as each track
    appears to play but I hear nothing via the
    speakers or headphones. I can play .wav files
    with no problems as well as all the other
    sound functions I can think of. Just no CDs.
    I note that it is not a hardware problem. I
    have a second disk for the computer with Vista
    and I can play CDs just fine if Vista is running.
    I'm running KDE4, Suse 11.0.

  2. #2

    Default Re: No sound from CD on Dell1525

    Well, 85 people read this message but nobody responded. However,
    after MUCH rummaging around on the web, I found the problem and
    the fix. I'm posting it here in case anyone else runs into this.

    It seems that on desktop PCs and on some laptops, the CD audio is
    being run through the IDE cable as a digital signal rather than
    via the "usual" audio cable. In fact, on some PCs, they don't
    even bother putting in the audio cable. Windows handles this
    properly, but most Linux CD players do not. Turns out the only
    player that I'm aware of that handles this is xmms. You need
    to go to options, then preferences and click on Audio I/O
    plugins. Then select the CD Audio Player and then
    Configure. You then get an analog/digital option. Choose
    digital.

    My CD now works fine, but I must use xmms.

  3. #3
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: No sound from CD on Dell1525

    Larry1019 wrote:

    >
    > Well, 85 people read this message but nobody responded. However,
    > after MUCH rummaging around on the web, I found the problem and
    > the fix. I'm posting it here in case anyone else runs into this.
    >
    > It seems that on desktop PCs and on some laptops, the CD audio is
    > being run through the IDE cable as a digital signal rather than
    > via the "usual" audio cable. In fact, on some PCs, they don't
    > even bother putting in the audio cable. Windows handles this
    > properly, but most Linux CD players do not. Turns out the only
    > player that I'm aware of that handles this is xmms. You need
    > to go to options, then preferences and click on Audio I/O
    > plugins. Then select the CD Audio Player and then
    > Configure. You then get an analog/digital option. Choose
    > digital.
    >
    > My CD now works fine, but I must use xmms.
    >
    >


    Kscd supports digital audio from cd's too, but xmms is much better and nicer
    in my opinion.

    Interesting to note that there are about 20-30 packages involving ripping
    cd's in the suse repos, and *maybe* 3 for playing cd's. Shows how we've
    changed over the years huh?

    Of course, I'm one of those too... since any audio cd I own has been ripped
    and stashed in my archives as mp3 and I play them with amarok.

    Congratulations on figuring it out.

    Loni
    --
    L R Nix
    lornix@lornix.com

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: No sound from CD on Dell1525

    Quote Originally Posted by Larry1019 View Post
    Well, 85 people read this message but nobody responded. However,
    after MUCH rummaging around on the web, I found the problem and
    the fix. I'm posting it here in case anyone else runs into this.
    Lornix beat me to the punch in replying.

    The reason I did not reply earlier, is you noted you had tried KsCD. Like many of us (I suspect) I knew that KsCD had the digital option, and since you stated you had tried KsCD, that lead me to believe you had already tried the digital option, and hence lead me to believe your problem was in an area that I did not understand (and hence no reply from me).

    Congratulations on sorting this, and thank you for sharing your solution.

  5. #5

    Default Re: No sound from CD on Dell1525

    I'm sorry. When I said I "tried" KsCD, I literally meant
    that -- I popped in the CD, brought up KsCD and watched
    the time counter increment without any sound. At the
    time, I didn't realize that it even _has_ a digital option.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •