Results 1 to 10 of 10

Thread: Cannot access files on my suse desktop from xp home

  1. #1

    Question Cannot access files on my suse desktop from xp home


    Hi I'm a total to noob to Linux, spent all day trying to find an answer and hate having to give in and ask for help, the good news I have seemed to get Samba working on opensuse 11. Not sure how I did it just got lucky.

    I can see the XP home machine from my suse desktop and access the shared files on there.

    I can see the shared files on my suse machine from my xp home machine but when I click on them xp is asking me for a user name and password.

    Everything combination of everything I've ever used on XP gets knocked back. Have even tried my suse uname and pword

    I've looked through these forums and can't see any answers. Having looked around the net I've seen a site for Asus Eee users has a thread saying the same.

    EeeUser ASUS Eee PC Forum / linux to Xp p : how to create a new user/which user+pass+domain to use

    Unfortunately they say this is an XP home problem and an upgrade to XP pro is only fix.

    Is anybody aware of a work around in opensuse?

    Sorry not posted any info cos I dont even know what info would be useful.

    Thanks


  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City, MO
    Posts
    570

    Default Re: Cannot access files on my suse desktop from xp home


  3. #3
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Cannot access files on my suse desktop from xp home

    Sounds to me like you need to add a user to the Samba user database and supply those credentials to Suse from xp when you try to enter the Suse shares (if asked). There would be something on that in the link Havoc65 supplied
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  4. #4

    Default Re: Cannot access files on my suse desktop from xp home

    If its on your home network and security is not a big concern, i would forget about passwords completely:

    Global portion of /etc/samba/smb.conf

    Code:
    [global]
            workgroup = WORKGROUP
            printing = cups
            printcap name = cups
            printcap cache time = 750
            cups options = raw
            map to guest = Bad User
            include = /etc/samba/dhcp.conf
            logon path = \\%L\profiles\.msprofile
            logon home = \\%L\%U\.9xprofile
            logon drive = P:
            usershare allow guests = Yes
            security = share
            netbios name = YOUR_MACHINE_NAME
            server string = Server Description
    example share in /etc/samba/smb.conf

    Code:
    [share name]
            comment = Description of your share
            path = Path to your shared folder (for example: /srv/samba)
            read only = no
            writable = yes
            browseable = yes
            guest ok = yes
    If youre not sure what youre doing remember to backup smb.conf before you mess with (cp /etc/samba/smb.conf /etc/samba/smb.conf_backup). And remember to restart samba after you edited the config file (/etc/init.d/smb restart)

    If you want writable (ability to copy files to that share and delete stuff from it) just chmod 777 /shared/folder

    Just remember that its not secure way to do this. It gets the job done easily if you just want to throw simple samba server on your local network and get files shared.

    If other people see your samba server, forget this post completely

  5. #5

    Default Re: Cannot access files on my suse desktop from xp home

    Thanks guys, yeah adding user to samba database is all I needed to do. Should have read a little bit further through swerdnas tutorial. Too much coffee and too little patience scuppered me yesterday.

  6. #6

    Default Re: Cannot access files on my suse desktop from xp home

    If anybody else has the same problem. I've stumbled on another way to fix it, or shall we say not cause it in the first place.

    It was my noobness that created it when I set the share permissions on the file on my linuxpc.

    Make sure you enable guest accounts access if you wish for Xp home access without requesting a password. Guessing this'll work for pro aswell.

  7. #7
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Cannot access files on my suse desktop from xp home

    Quote Originally Posted by RioSteel View Post
    If anybody else has the same problem. I've stumbled on another way to fix it, or shall we say not cause it in the first place.

    It was my noobness that created it when I set the share permissions on the file on my linuxpc.

    Make sure you enable guest accounts access if you wish for Xp home access without requesting a password. Guessing this'll work for pro aswell.
    That's correct. Would you elaborate on how you enabled "guest access" for those who find this thread?
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  8. #8

    Default Re: Cannot access files on my suse desktop from xp home

    Yeah no problem.

    To enable guest access. Do the following.

    Say the folder you were attempting to access from windows was called testshare.

    Goto the folder containing testshare on the linuxpc.

    Right click the folder and scroll down to sharing options.

    When the folder sharing window opens you should see that there are three check boxes. At present only Share this folder and possibly Allow other people to write in this folder are ticked.

    All you need do is tick the third box Guest access (for people without a user account) and click on create share.

    If your using Nautilus you will be asked about adding permissions, do so. You may be asked if browsing some other way, I dont know this is my second day on Linux. Hence really long-winded explaination.

    The windows machine that was being asked for uname and pword should now let you access with no fuss.

    If it don't work log out and back in again on both machines (typical tech support answer I know) failing that scream and shout at your network again and keep searching the forums.

    Thinking on this may be the case for even a linux only network. If so the above will still work. But use the link to swerdnas site in one of the above posts and you can find out how to set up access to shares by setting up username and passwords.

    My network is at home and all pcs are used by me only so password protected network access isn't a priority. Using swerdnas method to create user accounts is secure and was really easy to do also.

    Rio

  9. #9

    Default Re: Cannot access files on my suse desktop from xp home

    Btw don't quote me on.....

    "Thinking on and going on what swerdna suggested, this may be the case for even a linux only network. If so the above will still work."

    Cos this is from a noob to noobs. But as always we learn the most about a system by breaking it.

  10. #10
    Join Date
    Jun 2008
    Location
    Kansas City, MO
    Posts
    570

    Default Re: Cannot access files on my suse desktop from xp home

    Quote Originally Posted by RioSteel View Post
    But as always we learn the most about a system by breaking it.
    that is so true

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •