Results 1 to 9 of 9

Thread: Evolution: cannot define newsgroup subscriptions

  1. #1
    Join Date
    Jun 2008
    Location
    UK; deep south, far below Watford.
    Posts
    275

    Default Evolution: cannot define newsgroup subscriptions

    I have defined a news account to Evolution and specified a USET News server. But I cannot see or selct any newsgroups to subscribe to. When I attempt a refresh after selecting a news server in Folder Subscriptions for the News account, I get an error message: "Error while performing operation" - which is a bit like an error message which says "This is an error message".

    No newsgroups are listed so it is not possible to make any subscriptions. Is this caused by a set-up error?.
    They said I wasn't fit to live with a pig; my brother stood up for me and said I was.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,488
    Blog Entries
    15

    Default Re: Evolution: cannot define newsgroup subscriptions

    Quote Originally Posted by XEyedBear
    I have defined a news account to Evolution and specified a USET News
    server. But I cannot see or selct any newsgroups to subscribe to. When
    I attempt a refresh after selecting a news server in Folder
    Subscriptions for the News account, I get an error message: "Error
    while performing operation" - which is a bit like an error message
    which says "This is an error message".

    No newsgroups are listed so it is not possible to make any
    subscriptions. Is this caused by a set-up error?.
    Hi
    Just tested here and added forums.opensuse.org, worked fine for me.

    How did you setup the news account?

    --
    Cheers Malcolm (Linux Counter #276890)
    SLED 10 SP2 i586 Kernel 2.6.16.60-0.25-default
    up 10:05, 1 user, load average: 0.08, 0.09, 0.15
    GPU GeForce Go 6600 TE/6200 TE Version: 173.14.09


  3. #3
    Join Date
    Jun 2008
    Location
    UK; deep south, far below Watford.
    Posts
    275

    Default Re: Evolution: cannot define newsgroup subscriptions

    Quote Originally Posted by malcolmlewis View Post
    How did you setup the news account?
    Hi, thanks for confirming that Evolution works OK - but not the way I have set things up ;(

    I followed your instructions:
    Edit->Preferences->Mail Accounts->Add
    added an account which I called Linux News; selected 'USENET News' as a server type and defined my ISP's news server address for 'server' on the 'Receiving Email' tab. List of accounts shows 'nntp' as the protocol for this account.

    I have confirmed with my ISP's tech support that I am using the correct server name and I have the correct spellings too! (always important and rarely achieved in my experience)

    I'm still getter the 'you have an error and you have to guess what it is' error message.
    They said I wasn't fit to live with a pig; my brother stood up for me and said I was.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,488
    Blog Entries
    15

    Default Re: Evolution: cannot define newsgroup subscriptions

    Quote Originally Posted by XEyedBear
    malcolmlewis;1846671 Wrote:
    > How did you setup the news account?
    >


    Hi, thanks for confirming that Evolution works OK - but not the way I
    have set things up ;(

    I followed your instructions:
    Edit->Preferences->Mail Accounts->Add
    added an account which I called Linux News; selected 'USENET News' as a
    server type and defined my ISP's news server address for 'server' on the
    'Receiving Email' tab. List of accounts shows 'nntp' as the protocol for
    this account.

    I have confirmed with my ISP's tech support that I am using the
    correct server name and I have the correct spellings too! (always
    important and rarely achieved in my experience)

    I'm still getter the 'you have an error and you have to guess what it
    is' error message.
    Hi
    Can you try adding forums.opensuse.org as news server and see if that
    works. If it does, it may be an authentication issue with your isp?

    --
    Cheers Malcolm (Linux Counter #276890)
    SLED 10 SP2 i586 Kernel 2.6.16.60-0.25-default
    up 0:33, 1 user, load average: 0.55, 0.19, 0.24
    GPU GeForce Go 6600 TE/6200 TE Version: 173.14.09


  5. #5
    Join Date
    Jun 2008
    Location
    UK; deep south, far below Watford.
    Posts
    275

    Default Re: Evolution: cannot define newsgroup subscriptions

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Can you try adding forums.opensuse.org as news server and see if that
    works. If it does, it may be an authentication issue with your isp?
    Wise suggestion - that works just fine, once I get the correct user name for my opensuse forum login - otherwise I get an authentication error, but with a very clear error message, telling my I have an authentication error.

    For my ISP news server, I don't get a clear error message. I think I'm using an identical account configuration to that which currently works with Thunderbird on Windows. So I am a bit baffled as to which parameter or argument that I have set incorrectly.
    They said I wasn't fit to live with a pig; my brother stood up for me and said I was.

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,488
    Blog Entries
    15

    Default Re: Evolution: cannot define newsgroup subscriptions

    Quote Originally Posted by XEyedBear
    malcolmlewis;1846905 Wrote:
    > Hi
    > Can you try adding forums.opensuse.org as news server and see if that
    > works. If it does, it may be an authentication issue with your isp?


    Wise suggestion - that works just fine, once I get the correct user
    name for my opensuse forum login - otherwise I get an authentication
    error, but with a very clear error message, telling my I have an
    authentication error.

    For my ISP news server, I don't get a clear error message. I think I'm
    using an identical account configuration to that which currently works
    with Thunderbird on Windows. So I am a bit baffled as to which
    parameter or argument that I have set incorrectly.
    Hi
    Well I don't use any authentication here for logging in to opensuse
    forums, just set my email address.

    Do you use a proxy, encryption? Did you try with the firewall off?

    --
    Cheers Malcolm (Linux Counter #276890)
    SLED 10 SP2 i586 Kernel 2.6.16.60-0.25-default
    up 1:20, 1 user, load average: 0.13, 0.16, 0.14
    GPU GeForce Go 6600 TE/6200 TE Version: 173.14.09


  7. #7
    Join Date
    Jun 2008
    Location
    UK; deep south, far below Watford.
    Posts
    275

    Default Re: Evolution: cannot define newsgroup subscriptions

    OK, the problem is pretty much as you guessed, so many thanks for that. Cause: incorrect settings of various different renderings of the terms 'name', 'account name', 'user name', 'user' and so on. Once I stopped using names that people would use and used only 'system' type names (e.g "Tsortean.not@home.com" things worked OK - I was able to see the news groups of my ISP's news server.

    There is one usability issue though: there seems to be no way to 'filter' or select the newsgroup subscriptions when you have none currently selected: the total list of newsgroups (what, about 35,000 I guess ?) is presented. Paging through this lot is not practical. There is a selection mechanism within every other news client I have used.

    Moreover, I'm not sure how the system is going to distinguish between subscriptions selections you have made and other newsgroups (up to the 35K limit) that you still could make.

    The Evolution help file infers that this is the way you have to do it. It's not usable, in practice.

    Is this really the subject of another thread?
    They said I wasn't fit to live with a pig; my brother stood up for me and said I was.

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,488
    Blog Entries
    15

    Default Re: Evolution: cannot define newsgroup subscriptions

    Quote Originally Posted by XEyedBear
    OK, the problem is pretty much as you guessed, so many thanks for that.
    Cause: incorrect settings of various different renderings of the terms
    'name', 'account name', 'user name', 'user' and so on. Once I stopped
    using names that people would use and used only 'system' type names
    (e.g "Tsortean.not@home.com" things worked OK - I was able to see the
    news groups of my ISP's news server.

    There is one usability issue though: there seems to be no way to
    'filter' or select the newsgroup subscriptions when you have none
    currently selected: the total list of newsgroups (what, about 35,000 I
    guess ?) is presented. Paging through this lot is not practical. There
    is a selection mechanism within every other news client I have used.

    Moreover, I'm not sure how the system is going to distinguish between
    subscriptions selections you have made and other newsgroups (up to the
    35K limit) that you still could make.

    The Evolution help file infers that this is the way you have to do it.
    It's not usable, in practice.

    Is this really the subject of another thread?
    Hi
    That's why I find claws a good choice for me, lots of different
    filtering capabilities processing rules, spell checking, spam
    filtering, plugins, scripting etc.

    I have no experience really in Evolution except as a mail client....

    I prefer to compile from source, but claws is in the pacman repository
    I think. Give it a whirl and see how it goes

    --
    Cheers Malcolm (Linux Counter #276890)
    SLED 10 SP2 i586 Kernel 2.6.16.60-0.25-default
    up 6:27, 1 user, load average: 3.68, 3.21, 2.99
    GPU GeForce Go 6600 TE/6200 TE Version: 173.14.09


  9. #9
    Join Date
    Jun 2008
    Location
    UK; deep south, far below Watford.
    Posts
    275

    Default Re: Evolution: cannot define newsgroup subscriptions

    I think I spoke too soon. It's been my experience in everything Linux that what works 'today' will not necessarily work 'tomorrow', after a reboot.

    Evolution news service is a case in point. I now find that there is no option I can set, anywhere, after some 10's of attempts, which will get me past the 502 'authentication failed' message when attempting to access the news groups and am being asked to supply an NNTP password.

    In the meantime I have installed Claws Mail and tried it out on the newsgroups. I can make subscriptions OK, but I cannot see or save any jpgs from any of the binary newsgroups. All I see instead is the binary image data, not the image itself. I remember this used to be a common problem about 20 years ago but haven't experienced it since, except with Claws Mail. I cannot seem to find the configuration parameter that will correct this. Where is it?
    They said I wasn't fit to live with a pig; my brother stood up for me and said I was.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •