Results 1 to 3 of 3

Thread: Bad SATA disk shutdown in SUSE 10.3?

  1. #1

    Default Bad SATA disk shutdown in SUSE 10.3?

    I bought a new computer about 6 months ago to run openSUSE 10,3, 64 bit. Whenever I shut the machine down, the two SATA hard disks make a loud clacking noise. Not having used Samsung disks before, I thought that was probably normal for them.

    However, I've recently installed an old IDE disk (it shows up as /dev/sdc for some reason I don't quite understand) and this too is making the same noise. Since it was perfectly quiet in the computer I took it from, I suspect something is wrong.

    Something else I've noticed is that the noise seems a lot louder recently, possibly since upgrading to the 2.6.22.18-0.2 kernel.

    A bit of Googling found several references to a problem with disk shutdown, whereby this type of noise could be caused by the power being cut to the disks before the disk had been told to shut down. For example:

    Serial ATA (SATA) shutdown info

    and

    Disk might not be spun down properly. Update shutdown utility - LinuxQuestions.org

    The implication is that this could be harming my disks, so I'd like to get it sorted out. It sounds very much like the problem I have, but it is meant to be fixed in 2.6.22 kernels. However, it seems to depend on the distro and whether the "shutdown" command is right for the kernel. Neither of the above pages mentions SUSE.

    So my question is: can anyone shed any light on whether this problem is present in openSUSE 10.3/64 bit with the 2.6.22.18-0.2 kernel. Also, how can I be sure this is the problem and how can I fix it?


    Many thanks.

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Bad SATA disk shutdown in SUSE 10.3?

    * goofup,

    set /etc/sysconfig/shutdown to HALT_DISKS="no" and see if that fixes it.

    Uwe

  3. #3

    Default Re: Bad SATA disk shutdown in SUSE 10.3?

    Quote Originally Posted by buckesfeld View Post
    * goofup,

    set /etc/sysconfig/shutdown to HALT_DISKS="no" and see if that fixes it.

    Uwe
    I tried that and it didn't seem to make any difference.

    Reading through /etc/init.d/halt it appears that disks are not halted if software RAID is in use (I have two RAID arrays). That explains why setting HALT_DISKS="no" makes no difference.

    So now I'm a bit puzzled. Why would you not want to halt disks if software RAID is in use? Isn't that going to punish your disk drives? Or is there somewhere else where RAID arrays are shut down?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •