Results 1 to 8 of 8

Thread: snd_hda_intel and volume level

  1. #1
    oliolicat NNTP User

    Default snd_hda_intel and volume level

    Hi all,
    my laptop has an audio card which lspci shows as
    Code:
     Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
    i've tried playing with alsamixer and the pulse audio settings, but the volume level is still extremely low.
    does anybody have any experience with this chip? i've found occurrences of people with similar problems, but nothing to fix it.

    thanks for reading.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,337
    Blog Entries
    15

    Default Re: snd_hda_intel and volume level

    Quote Originally Posted by oliolicat
    Hi all,
    my laptop has an audio card which lspci shows as

    Code:
    Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio
    Controller (rev 03)
    i've tried playing with alsamixer and the pulse audio settings, but the
    volume level is still extremely low.
    does anybody have any experience with this chip? i've found occurrences
    of people with similar problems, but nothing to fix it.

    thanks for reading.
    Hi
    Have you changed the settings in YaST? Hardware->sound and then
    press the button called 'other' and select 'Volume' Set both sliders
    to 100% and hit test.

    --
    Cheers Malcolm (Linux Counter #276890)
    SLED 10 SP2 i586 Kernel 2.6.16.60-0.25-default
    up 0:35, 1 user, load average: 1.11, 0.54, 0.45
    GPU GeForce Go 6600 TE/6200 TE Version: 173.14.09


  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: snd_hda_intel and volume level

    Quote Originally Posted by oliolicat View Post
    i've found occurrences of people with similar problems, but nothing to fix it.
    I'm trying to understand this last comment. Do you mean the fixes that worked for other people, didn't work for you? Or do you mean the people with similar problems never had it fixed? If the later, please provide the links, as I would like to help those people. I've searched, and can't find threads where users were abandoned with low volume levels on their PC.

    .... Typically low volume level is due to a misconfiguration, often in YaST > Hardware > Sound, or in one's mixer (typically master volume or PCM volume too low).

  4. #4

    Default Re: snd_hda_intel and volume level

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Have you changed the settings in YaST? Hardware->sound and then
    press the button called 'other' and select 'Volume' Set both sliders
    to 100% and hit test.

    --
    Cheers Malcolm (Linux Counter #276890)
    SLED 10 SP2 i586 Kernel 2.6.16.60-0.25-default
    up 0:35, 1 user, load average: 1.11, 0.54, 0.45
    GPU GeForce Go 6600 TE/6200 TE Version: 173.14.09
    AFAICT, the Yast settings invoke the same mixer interface that alsamixer invokes. So if he says he's already set alsamixer to 100%, running Yast isn't going to help.

  5. #5

    Default Re: snd_hda_intel and volume level

    Quote Originally Posted by oldcpu View Post
    I'm trying to understand this last comment. Do you mean the fixes that worked for other people, didn't work for you? Or do you mean the people with similar problems never had it fixed? If the later, please provide the links, as I would like to help those people. I've searched, and can't find threads where users were abandoned with low volume levels on their PC.

    .... Typically low volume level is due to a misconfiguration, often in YaST > Hardware > Sound, or in one's mixer (typically master volume or PCM volume too low).
    I think he means that lots of people have similar problems, but nobody has posted anything that would fix it for him. Or for me.

    I'm now on my second Dell laptop that has absurdly low volumes. When I go to YouTube, I have to set my volume sliders to almost 100% to be able to hear at all. My desktop, in sharp contrast, plays YouTube audibly at 30% or so.

    Maybe it's just an artifact of laptop speaker systems; when I plug my laptop into headphones or an amplifier, I can get reasonable levels (of course, in the latter case I've got a bit of outside electronics helping me...). But I'd like to think that a volume setting of around 50% would be audible on my laptop, with 100% being in the "would you PLEASE turn that down!" range.

    Most of the suggested fixes I've seen so far are either (1) use various tools to set the mixer levels (duh) or (2) change modules.conf to specify a driver that works only on a particular machine that's not mine.

    So yeah, there's still a problem here.

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,337
    Blog Entries
    15

    Default Re: snd_hda_intel and volume level

    Quote Originally Posted by gkuenning
    malcolmlewis;1846465 Wrote:
    > Hi
    > Have you changed the settings in YaST? Hardware->sound and then
    > press the button called 'other' and select 'Volume' Set both sliders
    > to 100% and hit test.


    AFAICT, the Yast settings invoke the same mixer interface that
    alsamixer invokes. So if he says he's already set alsamixer to 100%,
    running Yast isn't going to help.
    Hi
    I suggest you create a new thread rather than tacking onto an almost 2
    year old post

    Have you read through the sticky?
    http://forums.opensuse.org/applicati...-sub-area.html

    I suggest you do that and start a new thread in the multimedia area.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.2 (i586) Kernel 2.6.31.12-0.1-default
    up 2:36, 3 users, load average: 0.10, 0.04, 0.10
    GPU GeForce 6600 TE/6200 TE - Driver Version: 190.53


  7. #7
    Join Date
    Aug 2008
    Location
    Europe
    Posts
    61

    Default Re: snd_hda_intel and volume level

    The issue with snd_hda_intel and volume level on Asus netbook is fixed for me by adding the "options snd-hda-intel model=quanta" into /etc/modprobe.d/99-local.conf file - the sound becomes as expected :-)

    So it may be the driver issue as well, and may be all you need is to find the right option for your model :-)

    Rgds,
    -Dimitri

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: snd_hda_intel and volume level

    Quote Originally Posted by dim7 View Post
    The issue with snd_hda_intel and volume level on Asus netbook is fixed for me by adding the "options snd-hda-intel model=quanta" into /etc/modprobe.d/99-local.conf file - the sound becomes as expected :-)

    So it may be the driver issue as well, and may be all you need is to find the right option for your model :-)
    Thanks for sharing your solution.

    Some comments on it ....

    "quanta" is a specific model option associated with an "ALC269" hardware codec, and is specific to that codec. I note the prefered openSUSE place to put the line "options snd-hda-intel model=quanta" is at the start of the /etc/modprobe.d/50-sound.conf file, and not a 99-local.conf file.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •