I installed tomcat6 from the official opensuse11 repository(v 6.0.16-5.1) and updated from the official update repository to version 6.0.16-6.2
It works with normal "/etc/init.d/tomcat 6 start" but when i tried configure with eclipse got following errors:

Firstly eclipse could not create new tomcat6 server because
lib/servlet-api.jar didnt exist, instead it had lib/tomcat6-servlet-2.5-api-6.0.16.jar
I just copied servlet-2.5-api-6.0.16.jar to servlet-api.jar and got this solved.

Secondly when starting the server from eclipse i got the following error:

Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/juli/logging/LogFactory
	at org.apache.catalina.startup.Bootstrap.<clinit>(Bootstrap.java:54)
Caused by: java.lang.ClassNotFoundException: org.apache.juli.logging.LogFactory
	at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:276)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
	at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
	... 1 more
Then I googled a bit and found that fedora had somewhat similar problem: FedoraForum.org - Fedora 9: NoClassDefFoundError (LogFactory) starting Tomcat from Fedora Eclipse
I tried their workaround by adding
Class-Path:  bootstrap.jar tomcat-juli.jar
to bin/bootstrap.jar manifest but with no luck.

Any ideas?