Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: kde programs stop working (on gnome)

  1. #1

    Default kde programs stop working (on gnome)

    Hi,

    I have the following setup: SUSE 11.4 with Gnome desktop, on a Dell e4200 laptop.

    I installed the KILE program, which is a KDE program (for processing LaTex), and it comes packaged with OKULAR, KONQUEROR and more.

    A few weeks after this installation, suddenly and at once all these KDE programs stop working.

    This happened to me before (about three times during the past year), and the only remedy I found was to reinstall SUSE (!!!). Just uninstalling and reinstalling the separate programs had no effect.

    The previous times this problem happened I had the following symptom: the Gnome system monitor showed the program I was trying to run (say okular) as being in "futex-do-wait". This time around even this doesn't happen: there is no sign in the system monitor.

    Any ideas?

    Thanks!

  2. #2
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: kde programs stop working (on gnome)

    Is there any error message given when you try to start - let's say - okular from a terminal window?

    You could also check if there's something in the log files.

    This problem needs to be debugged, not overwritten by a fresh install. So stay tuned.
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  3. #3

    Default Re: kde programs stop working (on gnome)

    Quote Originally Posted by vodoo View Post
    Is there any error message given when you try to start - let's say - okular from a terminal window?

    You could also check if there's something in the log files.

    This problem needs to be debugged, not overwritten by a fresh install. So stay tuned.

    Here is the output from the terminal:
    Code:
    amyekut@linux-g4aj:~/Desktop> okular
    okular: error while loading shared libraries: libQtCore.so.4: cannot open shared object file: Input/output error
    amyekut@linux-g4aj:~/Desktop>
    I don't know which log files are relevant.

  4. #4

    Default Re: kde programs stop working (on gnome)

    Pursuing the error message quoted above, I tried to reinstall libqt4. It failed, with this message:

    Code:
    Installation of package libqt4 failed.
    
    Subprocess failed. Error: RPM failed: error: unpacking of archive failed on file /usr/lib64/libQtCore.so.4.7.3: cpio: rename failed - Input/output error

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,587
    Blog Entries
    14

    Default Re: kde programs stop working (on gnome)

    1. Can we see your repos?
    Code:
    zypper lr -d
    2. Did you try to get it working by logging in as root on the desktop?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6

    Default Re: kde programs stop working (on gnome)

    Here's the output:

    Code:
    amyekut@linux-g4aj:~/Desktop> zypper lr -d
    #  | Alias                            | Name                             | Enabled | Refresh | Priority | Type   | URI                                                                            | Service
    ---+----------------------------------+----------------------------------+---------+---------+----------+--------+--------------------------------------------------------------------------------+--------
     1 | 11.4 - VideoLan                  | 11.4 - VideoLan                  | Yes     | Yes     |   99     | rpm-md | http://download.videolan.org/pub/videolan/vlc/SuSE/11.4/                       |        
     2 | KDE:KDE3                         | KDE:KDE3                         | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE3/openSUSE_11.4/             |        
     3 | KDE:Release:46                   | KDE:Release:46                   | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Release:/46/openSUSE_11.4/      |        
     4 | Updates-for-openSUSE-11.4-11.4-0 | Updates for openSUSE 11.4 11.4-0 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.4/                                      |        
     5 | openSUSE-11.4-11.4-0             | openSUSE-11.4-11.4-0             | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-PLDS_DVD+_-RW_DU-8A2S_809130270436,/dev/sr0 |        
     6 | openSUSE:11.4:Contrib            | openSUSE:11.4:Contrib            | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/11.4:/Contrib/standard/    |        
     7 | repo-debug                       | openSUSE-11.4-Debug              | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/11.4/repo/oss/                 |        
     8 | repo-debug-update                | openSUSE-11.4-Update-Debug       | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/11.4/                                |        
     9 | repo-non-oss                     | openSUSE-11.4-Non-Oss            | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss/                   |        
    10 | repo-oss                         | openSUSE-11.4-Oss                | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss/                       |        
    11 | repo-source                      | openSUSE-11.4-Source             | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/11.4/repo/oss/                |        
    amyekut@linux-g4aj:~/Desktop>
    When you ask
    Did you try to get it working by logging in as root on the desktop?
    do you mean installation of libqt4? I did this from the YAST GUI.

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,587
    Blog Entries
    14

    Default Re: kde programs stop working (on gnome)

    Start Yast - Software Manager, select the repo view, select the KDE:Release 46 repo. On the right half of the screen you will see a link at the top saying: "Switch system packages ....". Click that and accept. Let the Software Manager do it's thing, logout, login and let us know if there's any improvement.

    With logging in as root I meant using the GNOME or KDE desktop environment as user root, i.e. from the login screen.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8

    Default Re: kde programs stop working (on gnome)

    I did as proposed:

    Start Yast - Software Manager, select the repo view, select the KDE:Release 46 repo. On the right half of the screen you will see a link at the top saying: "Switch system packages ....". Click that and accept. Let the Software Manager do it's thing,
    Many packages were installed. However installation of the package libqt4 failed! Will try to logout & login and report again.

  9. #9

    Default Re: kde programs stop working (on gnome)

    rebooted, and tried again to install libqt4 from KDE:Release 46. Doesn't work -- I get
    Code:
    Installation of package libqt4 failed

  10. #10

    Default Re: kde programs stop working (on gnome)

    Today I rebooted, and suddenly the KDE programs (okular, kile) started working again.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •