Results 1 to 7 of 7

Thread: error*with*parameters*-*opensuse*11

  1. #1
    karlijos NNTP User

    Default error*with*parameters*-*opensuse*11

    Hi,
    have anybody error after ssh conection to some server ? 
    It seems like it don't accept line parameters:

    chose@prdola:~> ssh celer -l root -X
    ssh: Could not resolve hostname celer\302\240-l\302\240root\302\240-X: Name or service not known

    or:

    chose@prdola:~> su root
    bash: su root: command not found

    Any*ideas?

    Thank*you*for*your*help.
    Last edited by karlijos; 26-Jul-2008 at 09:04. Reason: spaces was replaced by "*" :-/

  2. #2
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: error*with*parameters*-*opensuse*11

    karlijos wrote:

    >
    > Hi,
    >

    have anybody error after ssh conection to some server ? 
    >

    It seems like it don't accept line parameters:
    >
    > chose@prdola:~> ssh celer -l root -X
    > ssh: Could not resolve hostname celer\302\240-l\302\240root\302\240-X:
    > Name or service not known
    >
    > or:
    >
    > chose@prdola:~> su root
    > bash: su root: command not found
    >
    > Any*ideas?
    >
    > Thank*you*for*your*help.
    >
    >


    Generally, the options come first, with the hostname last. A simpler method
    for what you're looking for is:

    ssh -X root@celer


    --
    L R Nix
    lornix@lornix.com

  3. #3
    karlijos NNTP User

    Unhappy Re: error*with*parameters*-*opensuse*11

    Hi,
    yeah*you're*right.*But*I*logged*in*that*my*way*thousands*times.
    I'tried*log*by*your*recomendation:

    chose@prdola:~> su*root@celer
    bash: su*root@celer: command not found
    chose@prdola:~> su*root@192.168.12.5
    bash: su*root@192.168.12.5: command not found
    chose@prdola:~>

    Interesting*is,*that*after*reboot*is*that*ok.*Remote*machine
    is*suse*10.0*and*suse*10.3...

    Grrr, why are there "*" ????

  4. #4
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: error*with*parameters*-*opensuse*11

    karlijos wrote:

    >
    > Hi,
    > yeah*you're*right.*But*I*logged*in*that*my*way*thousands*times.
    > I'tried*log*by*your*recomendation:
    >
    > chose@prdola:~> su*root@celer
    > bash: su*root@celer: command not found
    > chose@prdola:~> su*root@192.168.12.5
    > bash: su*root@192.168.12.5: command not found
    > chose@prdola:~>
    >
    > Interesting*is,*that*after*reboot*is*that*ok.*Remote*machine
    > is*suse*10.0*and*suse*10.3...
    >
    > Grrr, why are there "*" ????
    >
    >


    It's likely to be something involving your charset. You're in Slovokia, and
    likely have a different one set as default for your browser and shell.

    you can see where bash is seeing your 'su root@celer' entry as a single
    word, instead of breaking it at the space and parsing the arguments given
    (root@celer)

    can you narrow it down? you say it works after a reboot, but then stops
    working later? The question then would be, what has changed.

    --
    L R Nix
    lornix@lornix.com

  5. #5
    karlijos NNTP User

    Default Re: error*with*parameters*-*opensuse*11 - SOLVED

    Huh, you don't believe - error was with KDE keyboard layout switcher - US keyb. With CZ no problem. I removed US, replace it by UK, all OK. Maybe bug ??? Smeg knows ...

  6. #6
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: error*with*parameters*-*opensuse*11

    karlijos wrote:

    >
    > Huh, you don't believe - error was with KDE keyboard layout switcher -
    > US keyb. With CZ no problem. I removed US, replace it by UK, all OK.
    > Maybe bug ??? Smeg knows ...
    >
    >

    Hurrah!!

    I'm glad you got it fixed! AND, you told all of us here how you fixed it
    too! Sharing is good!

    Ok, now you get to be the savior to help the next person with "*"'s in their
    typing... {Smile}

    congratulations.


    --
    L R Nix
    lornix@lornix.com

  7. #7
    karlijos NNTP User

    Default Re: error*with*parameters*-*opensuse*11

    Thx, but interesting is what that caused. Differend characters mapping ? That caused that spaces in prompt wasn't spaces ??? Like here in the forum in my posts ?
    Now prompt:

    prdola:/home/chose # ssh -l root celer
    Password:
    Last login: Tue Jul 22 22:50:53 2008 from prdola.ajetaci.cz
    Have a lot of fun...
    celer:~ #




    By.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •