Results 1 to 4 of 4

Thread: duel boot not booting.

  1. #1

    Default duel boot not booting.

    still learning the diff's with opensuse and other distro's, but having a boot issue. Have the following partitions;
    sda1 - linux / boot
    sda2 - linux / swap
    sda3 - ntfs - windows
    sda4 - linux /

    Already had opensuse installed, had some windows issues so re-installed. With other distro's such as fedora, after the install, I would just re-run the grub-install and be done. Having a problem now, I changed the boot flag back to sda1 and on boot getting a missing operating system. I booted off the livecd, tried to run the grub install but got an error saying something about the partitions, but before I go nuts reading, etc. is that the propper way? I am not even sure that the default installer for openSuse uses grub, I thought I saw the conf file, but need to get home to the laptop to check.

    Just please verify it does use grub, and confirm the correct syntax of the drive, should be sda0,3 I believe, but again, I won't have access to the laptop for another few hours, but wanted to be ready.

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    316

    Default Re: duel boot not booting.

    Using LIlO ore GRub is up to you
    I prefer GRUB
    About the drives what is install first.
    If windows than normally windows is on sda1
    So check the drives again

    dobby9

  3. #3
    Join Date
    Jul 2008
    Location
    Athens
    Posts
    106

    Default Re: duel boot not booting.

    In general,if u re-install windows,it overwites the MBR and hence it overwites GRUB.
    U just need to reinstall GRUB.
    On the instalation DVD after choosing repair "installed system" there should be an option to repair/install GRUB.Make sure GRUB is installed in the right palce.
    Yes the ways u do it is the proper way.That's how i do it.
    U say GRUB gives an error.
    Can u post the number of error?Like GRUB error 210 bla bla bla.It could help us search for info for your problem.
    Also should boot flag be in the partition u choose or not?
    And yes if u havent done anything at installation,opensuse installs GRUB as default boot loader

    Silly mode ON:If your operating systems actually having a duel,maybe one of them is dead and not be able to function,causing all these problems
    "Keyboard not found. Press any key to continue"

  4. #4

    Default Re: duel boot not booting.

    [solved]
    Finally after playing with more options on the live cd grub-installer hit one of the options that moved the installer over. Now it's just a matter of getting the windows option to display which should be a no problem one.

    Thanks for the prompt replies.
    Last edited by xlancealotx; 26-Jul-2008 at 12:33. Reason: solved

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •