Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Problem when WIFI is password protected

  1. #1

    Default Problem when WIFI is password protected

    I am using Suse 10.3. I have installed Wifi Radar and KInternet. Both applications are working when I am connected to public WIFI network.

    I have problem when I am trying to connect with password protected network. Both applications are able to find my home network but unable to connect. I am using Vista to connect the network, therefore my password is correct and network is working. Probably I am missing something in the settings. What may be the reason?

    Thanks in advance.

  2. #2
    Join Date
    Jul 2008
    Location
    Athens
    Posts
    106

    Default Re: Problem when WIFI is password protected

    Check if the package wpa_suplicant is installed.If not that is more likely to be the problem.Just install it
    "Keyboard not found. Press any key to continue"

  3. #3
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Problem when WIFI is password protected

    * plamenpenchev,

    which security (WEP, WPA...) are you using on the access point? The settings on the access point and those on the nic must match.

    Uwe

  4. #4

    Default Re: Problem when WIFI is password protected

    Quote Originally Posted by plamenpenchev View Post
    I am using Suse 10.3. I have installed Wifi Radar and KInternet. Both applications are working when I am connected to public WIFI network.

    I have problem when I am trying to connect with password protected network. Both applications are able to find my home network but unable to connect. I am using Vista to connect the network, therefore my password is correct and network is working. Probably I am missing something in the settings. What may be the reason?

    Thanks in advance.
    I have a similar problem to this, has anyone managed to work it out. I am totally new to suse and linux in general. I'm using suse 11.
    Currently I'm able to pick up wireless networks but I'm not able to connect to them. I'm not really sure about the correct settings. Last time I tried to get the settings right I got a crash report from KNetworkManager. The details from the two tabs in this manager are attached below. Any help will be much welcome. I will also try to send a bug report when I work out how to do so.
    ==Attachment==
    General Tab in KNetworkManager - The KDE Crach Handler
    This handler shows up when I click on expert settings while setting up the network!
    ------------
    Short Description
    The application KNetworkManager (knetworkmanager)crashed and caused the signal 11 (SIGSEGV).

    What is this?
    An appkication mostly receives the SIGSEGV signal due to a bug in the application. The application was asked to save its documents.
    ====================

    Backtrace Tab
    Below are the contents of this tab, also saved in knetworkmanager.kcrash
    ------------
    System configuration startup check disabled.

    [?1034h(no debugging symbols found)
    (no debugging symbols found)
    ...
    (no debugging symbols found)
    [Thread debugging using libthread_db enabled]
    [New Thread 0xb6890a50 (LWP 3029)]
    (no debugging symbols found)
    ...
    (no debugging symbols found)
    [KCrash handler]
    #6 0xb6615a1a in ConnectionSettings::WirelessSecurityWidgetImpl::slotExtraSettingsToggled () from /opt/kde3/lib/libkdeinit_knetworkmanager.so
    #7 0xb661941b in ConnectionSettings::WirelessSecurityWidgetImpl::qt_invoke ()
    from /opt/kde3/lib/libkdeinit_knetworkmanager.so
    #8 0xb745d79a in QObject::activate_signal ()
    from /usr/lib/qt3/lib/libqt-mt.so.3
    #9 0xb745fa21 in QObject::activate_signal_bool ()
    from /usr/lib/qt3/lib/libqt-mt.so.3
    #10 0xb77c87ae in QButton::toggled () from /usr/lib/qt3/lib/libqt-mt.so.3
    #11 0xb74f792c in QButton::nextState () from /usr/lib/qt3/lib/libqt-mt.so.3
    #12 0xb74f8920 in QButton::mouseReleaseEvent ()
    from /usr/lib/qt3/lib/libqt-mt.so.3
    #13 0xb7498337 in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
    #14 0xb73f83cd in QApplication::internalNotify ()
    from /usr/lib/qt3/lib/libqt-mt.so.3
    #15 0xb73f95d6 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
    #16 0xb7ab0892 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
    #17 0xb7392a9e in QApplication::sendSpontaneousEvent ()
    from /usr/lib/qt3/lib/libqt-mt.so.3
    #18 0xb738f8c0 in QETWidget::translateMouseEvent ()
    from /usr/lib/qt3/lib/libqt-mt.so.3
    #19 0xb738eb5d in QApplication::x11ProcessEvent ()
    from /usr/lib/qt3/lib/libqt-mt.so.3
    #20 0xb73a2d04 in QEventLoop:rocessEvents ()
    from /usr/lib/qt3/lib/libqt-mt.so.3
    #21 0xb7410d10 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
    #22 0xb7410ba6 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
    #23 0xb73f8a5f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
    #24 0xb65c2861 in kdemain () from /opt/kde3/lib/libkdeinit_knetworkmanager.so
    #25 0xb7f04474 in kdeinitmain () from /opt/kde3/lib/kde3/knetworkmanager.so
    #26 0x0804f329 in ?? ()
    #27 0x0804faca in ?? ()
    #28 0x08050105 in ?? ()
    #29 0x08050b12 in ?? ()
    #30 0xb6e655f5 in __libc_start_main () from /lib/libc.so.6
    #31 0x0804b971 in ?? ()

  5. #5
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: Problem when WIFI is password protected

    @lukomwa
    the network manager on the cd/dvd has a bug, there is an update for it on the repo's,so, if you have a wired connection, download the update then try again

    Andy

  6. #6

    Default Re: Problem when WIFI is password protected

    Thanks, Andy. I have been through the repositories and updated all the packages that have to do with the knetwork manager but I'm still not able to connect. I think the real issue is that I can't work out the right settings in order to enter the network password etc. Here is some of what I have tried so far.

    From the icon in the taskbar bottom right:
    Edit Connections
    New connection > wireless
    I choose from the list that is currently available and my Essid is filled in automatically
    Click next
    Check "Use wireless security"

    There are 3 security options.

    For "WPA personal" the only option is "shared key" which doesn't make sense to me.

    For "WEP" there are plenty of "key" options which also doesn't make sense, since this network has only one and its type is unknown to me. I'm also not sure whether to choose "Opens system" or "Shared key" for authentication. None has worked so far.

    For "IEEE 802.1 X" There are plenty of fields including a "password" field. In this case the expert settings option is disabled. For the encryption option in this area I have tried both "none" and "dynamic WEP"

    I have entered the password here and clicked "connect & save" but still I'm not online!

    Rob

  7. #7
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: Problem when WIFI is password protected

    hmm, your methodolgy is correct. have you tried putting the settings in via YaST - network devices - network settings ? a few other things to check:
    1 ) firewall, is it set correctly to allow outward transmission ?
    2 ) is the access point using MAC address filtering as well ?

    Andy

  8. #8

    Default Re: Problem when WIFI is password protected

    I have tried the settings via YaST, the help buttons have been useful there for informing the decisions being made but still connection is not achieved even after rebooting.

    I have left the firewall set to "External zone" which seems to be the default.

    /sbin/ifconfig returns a HWaddr (which is the same as the MAC address displayed in the overview tab in YaST network settings.) It seems MAC address filtering is thus in use, as is the case for the ethernet connection I'm currently using to write this.

    Rob

  9. #9
    Join Date
    Jun 2008
    Location
    Central Pa. , USA
    Posts
    94

    Default Re: Problem when WIFI is password protected

    Using WEP...did you try entering the pass in hex decimal?
    And let us know what you come up with.
    Inquiring minds want to know?

  10. #10

    Default Re: Problem when WIFI is password protected

    It is not possible to enter the password in hexadecimal. It is basically a word with alphabetical letters and numbers.

    I now think the problem is not just the password but something else. I'm currently writing from a wireless network which I'm accessing via my MS Windows partition. Using it requires that first my computer picks it up and connects, then I have to run vpn before I can actually browse the web. SuSE picks it up but fails to connect to it because when I run vpnc (as root) after entering my username and password, it claims that the host is unknown, which implies that the wireless is simply not connected.

    I wonder if this might have to do with the way my kernel was compiled because I'm also having issues with displaying 3D graphics from remote machines (abaqus cae to be specific) despite having all the mesa3D-related packages. Someone hinted that I might have to recompile my kernel -I have no idea at the moment how to go about that!

    But wonder why it does not affect Ethernet connections!

    Rob

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •