Page 1 of 4 123 ... LastLast
Results 1 to 10 of 32

Thread: Another N00B fails to connect to internet

  1. #1

    Default Another N00B fails to connect to internet

    Hello Everyone!
    I am complete newbie with OpenSuse. Previously I used Ubuntu and loved it. I thought I should give OpenSUSE a try. And after installing I don't regret my decision.
    But unfortunately, i can't connect to internet. I have a pppoe connection and an ADSL modem. In ubuntu i used to configure the connection with "sudo pppoeconf". Here in SUSE, things look much better since it has a GUI based configuration manager.
    I set up the network settings and it could detect my modem. And configured the dsl settings. But don't know why I still can't connect. I am adding some screenshots. Please take a look.
    I also tried this one: Bryan 手* 生活記趣 How to connect to internet by PPPOE (KDE or Gnome) on Opensuse But my right-click isn't working (yes, i will buy a new one)
    Also ifconfig gives me: "bash: No such command" which is surprising.
    Regards




    http://i110.photobucket.com/albums/n...eters-YaST.png

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Another N00B fails to connect to internet

    * cyberbuff,

    other than Ubuntu, "normal" distributions allow you to become root on a console. So open a console and type
    su
    The prompt should become red after that. Now try
    ifup dsl0
    to check if your connection is working.

    Uwe

  3. #3

    Default Re: Another N00B fails to connect to internet

    OK, a long shot ...

    On the Hostname|DNS tab
    uncheck Update DNS data via DHCP
    under Name Servers enter the (DNS) name servers that your ISP uses
    (in plain language, you're telling it some numbers it ought to be able to work out for itself but can't)

    On my router, DNS is a tad flaky, so I've got into the habit of hard-coding the name servers on openSUSE (and Windows XP) - the trick seems to work.

    As belt-and-braces, under Routing (or wherever it's hiding) confirm that your Default Gateway is set to 192.168.1.1

  4. #4

    Default Re: Another N00B fails to connect to internet

    thanks for your reply. I will try unchecking that option. but about the name server, I really can't figure out what it would be. Can you help me a bit

  5. #5

    Default Re: Another N00B fails to connect to internet

    As for ifconfig not found, I suspect it's 'cos /sbin isn't on your path.

    Here's how I set mine up in .bashrc

    export PATH=${HOME}/scripts
    export PATH=${PATH}:/usr/local/bin:/usr/bin:/bin
    export PATH=${PATH}:/usr/local/sbin:/usr/sbin:/sbin
    export PATH=${PATH}:/usr/X11R6/bin
    export PATH=${PATH}:/opt/kde3/bin


    PS You may say you're a noob, but it's a pleasure to see someone documenting their problem(s) so well.

  6. #6

    Default Re: Another N00B fails to connect to internet

    I thought you might not know your name servers. Sharing mine isn't fair to my ISP so I can't say for sure if this will work:-

    OpenDNS | Providing A Safer And Faster Internet

    Try those two numbers at bottom right.

    https://www.opendns.com/start

    Before you do that, maybe the name server numbers you need are listed on your router? Also, you're presumably posting from another machine, rummage around in there for them.

  7. #7

    Default Re: Another N00B fails to connect to internet


  8. #8

    Default Re: Another N00B fails to connect to internet

    thanks again...i will try with the opendns numbers...I am currently on Windows, on the same machine...is there any chaance to get the name servers on windows?
    Anyway, here are some results:
    linux-6dsv:/home/dutta # ifconfig
    dsl0 Link encapoint-to-Point Protocol
    inet addr:59.93.216.132 P-t-P:59.93.192.1 Mask:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
    RX packets:14 errors:0 dropped:0 overruns:0 frame:0
    TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3
    RX bytes:594 (594.0 b) TX bytes:494 (494.0 b)

    eth0 Link encap:Ethernet HWaddr 00:16:76:46:4F:54
    inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::216:76ff:fe46:4f54/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:1355 errors:0 dropped:0 overruns:0 frame:0
    TX packets:236 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:128039 (125.0 Kb) TX bytes:29770 (29.0 Kb)
    Interrupt:21 Base address:0x2000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:56 errors:0 dropped:0 overruns:0 frame:0
    TX packets:56 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:3464 (3.3 Kb) TX bytes:3464 (3.3 Kb)
    linux-6dsv:/home/dutta # ifup dsl0
    dsl0
    interface dsl0 is up
    Checking for network time protocol daemon (NTPD): unused

  9. #9

    Default Re: Another N00B fails to connect to internet

    Here's how to set the openDNS ones on Windows XP - don't break Windows though - I'm saying so 'cos the ones your ISP gave you might be in there already

    https://www.opendns.com/start?device=windows-xp

    PS I'm out of my depth setting up a DSL modem - the DNS is a long shot - but it's what worked for me on two openSUSE 11.0 boxes.

    PPS can you ping from Linux? - that would strongly suggest it's DNS related.

  10. #10

    Default Re: Another N00B fails to connect to internet

    thanks kj44. I tried with the opendns thingy. and here is my network information:

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •