Results 1 to 5 of 5

Thread: No umlauts w. automounted vfat file systems, openSUSE/64bit

  1. #1
    markweinem NNTP User

    Default No umlauts w. automounted vfat file systems, openSUSE/64bit

    Hi,

    This is on openSUSE/64bit 11.0
    I have no german umlauts in file names on automounted vfat file systems on USB flash drives. I cannot change the files names because the system reports: "file ... does not exist"

    Code:
    # mount
    /dev/sdb1 on /media/NO_NAME type vfat (rw,nosuid,nodev,uid=1000)

    Greetings, Mark

  2. #2
    Join Date
    Mar 2008
    Location
    Kentucky
    Posts
    1,126

    Default Re: No umlauts w. automounted vfat file systems, openSUSE/64

    Quote Originally Posted by markweinem View Post
    Hi,

    This is on openSUSE/64bit 11.0
    I have no german umlauts in file names on automounted vfat file systems on USB flash drives. I cannot change the files names because the system reports: "file ... does not exist"

    Code:
    # mount
    /dev/sdb1 on /media/NO_NAME type vfat (rw,nosuid,nodev,uid=1000)

    Greetings, Mark
    I'd start looking here:
    Search the openSUSE Mailinglist Archive
    and
    umlauts - Google Search
    Desktop Asus X-99 Viper. uefi & secure Boot, Win10, Leap 15.1; Laptop: ASUS GL752VW Optimus, uefi+Secure Boot, Win10, Leap 15.1 & T-weed and IMac

  3. #3
    markweinem NNTP User

    Default Re: No umlauts w. automounted vfat file systems, openSUSE/64

    Quote Originally Posted by snakedriver View Post
    I'd start looking here:
    Thanks, nice tips ;-)

    But this is not a general problem with umlauts. The problem is that only vfat file systems are (auto-)mounted without support of special characters. How can I change this?

  4. #4
    Join Date
    Mar 2008
    Location
    Kentucky
    Posts
    1,126

    Default Re: No umlauts w. automounted vfat file systems, openSUSE/64

    Quote Originally Posted by markweinem View Post
    Thanks, nice tips ;-)

    But this is not a general problem with umlauts. The problem is that only vfat file systems are (auto-)mounted without support of special characters. How can I change this?
    Try "utf8" in your fstab line entry (or mount command)
    fstab change will require a reboot
    Desktop Asus X-99 Viper. uefi & secure Boot, Win10, Leap 15.1; Laptop: ASUS GL752VW Optimus, uefi+Secure Boot, Win10, Leap 15.1 & T-weed and IMac

  5. #5
    markweinem NNTP User

    Default Re: No umlauts w. automounted vfat file systems, openSUSE/64

    Hmm, is fstab the optimal place to change mount options for hotplug devices? What if I plug in a second and a third usb drive with vfat file systems?

    Currently at least, the (wrong) mount options are configured elsewhere, not in /etc/fstab. But where? And I'm not sure if this an issue with udev or with HAL?

    Thanks & best regards
    Mark Weinem

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •