Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: RTL8187 and openSUSE 11

  1. #1
    osmano807 NNTP User

    Exclamation RTL8187 and openSUSE 11

    Hello, I installed the opensuse 11 in my laptop, but the problem is that he see the wireless network but not connect, is trying to connect, but it seems that falls. I already tried with fixed IP and DHCP, once the dhcp worked, but stopped working.

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: RTL8187 and openSUSE 11

    osmano807 wrote:
    > Hello, I installed the opensuse 11 in my laptop, but the problem is that
    > he see the wireless network but not connect, is trying to connect, but
    > it seems that falls. I already tried with fixed IP and DHCP, once the
    > dhcp worked, but stopped working.


    Is there anything in the output of dmesg regarding the rtl8187? AFAIK, the
    8187's work with kernel 2.6.25; however, the 8187B's do not.

  3. #3
    osmano807 NNTP User

    Default Re: RTL8187 and openSUSE 11

    Code:
    dmesg | grep 8187
    usb 2-7: New USB device found, idVendor=0bda, idProduct=8187
    usb 2-7: Product: RTL8187_Wireless
    usb 2-7: Manufacturer: Manufacturer_Realtek_RTL8187_
    phy0: hwaddr 00:10:af:1f:9e:ea, rtl8187 V1 + rtl8225
    usbcore: registered new interface driver rtl8187

    From what I see, it was everything to be normal.

  4. #4
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: RTL8187 and openSUSE 11

    Did you configure the device with YaST? Are you using traditional ifup or NetworkManager to control it?

  5. #5
    osmano807 NNTP User

    Default Re: RTL8187 and openSUSE 11

    I set with the YaST and use the NetworkManager.

    Code:
    Ordering a network address of the wireless network "wired".
    What is this, it can not put ip fixed?

  6. #6
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: RTL8187 and openSUSE 11

    osmano807 wrote:
    > I set with the YaST and use the NetworkManager.
    >
    >
    > Code:
    > --------------------
    > Ordering a network address of the wireless network "wired".
    > --------------------
    >
    >
    > What is this, it can not put ip fixed?


    If you want a fixed IP, it is best to use ifup. Be careful to get the route and
    DNS info correct.

    The is a way to get NM to supply a fixed IP, but I don't know how. Send a
    request on how to do it to networkmanager-list@gnome.org.

    Larry

  7. #7
    osmano807 NNTP User

    Default Re: RTL8187 and openSUSE 11

    I tried to use the ifup method and still not connecting. The bad is that with the windows xp operating normally the connection.

  8. #8
    obildesheim NNTP User

    Default Re: RTL8187 and openSUSE 11

    Hi!

    I'm having a very similar problem.

    I am using a 'standard installation" of openSuse 11 and i am trying to connect to my wlan using an usb wlan stick with a rtl8187 chipset.

    The wlan0 device is up, but the dhcp client on wlan0 can't get an IP address and is "backgrounding".

    Following things i've already checked:

    1.) lsusb - the command lists the usb stick and its chipset correctly
    2.) iwconfig wlan0 - output contains the correct configuration data (ESSID, Access Point MAC address etc.)
    3.) successfully tested, that my wlan adapter is receiving any broadcasts from my access point by using the command 'iwlist scan' (ESSID, mode, chanell, ... were correctly reported in the commands output)

    What's going wrong?

    Thanks and best regards,
    Oliver Bildesheim

  9. #9

    Default Re: RTL8187 and openSUSE 11

    I'm not sure if this helps at all as I'm using RTL8185. However, here are the steps for configuring.

    Computer->Network->Global Options.

    Disable IPv6.
    Traditional ifup. ( if I use netmanager it doesn't connect )

    Computer->Network->Overview.

    Select card, edit.

    Dynamic Address DHCP.

    Under the "Hardware" tab my module is rtl8180, I assume it should be the same for RTL8187.

    Hit Next.

    Managed mode, enter your SSID and key(if any).

    Hit Next, Hit Finish.

    Reboot.

    If the RTL8187 is anything like the RTL8185 after the reboot it should be working( albeit slowly ).

    If it is up and running, open terminal.

    Code:
    su
    iwconfig wlan0 rate 54MB
    I've read in places that setting the rate like that can improve the speed issues.

    If that doesn't work. Try ndiswrapper, download it and WinXP drivers, then.

    Code:
    su
    unzip XPDrivers.zip
    cd XPDrivers
    ndiswrapper -i net8187.inf
    Then to check:

    Code:
    ndiswrapper -l
    Which after running on my system reports:

    Code:
    ndiswrapper -l
    net8185 : driver installed
    	device (10EC:8185) present (alternate driver: rtl8180)
    Then, back in the network settings, replace the module with "ndiswrapper".

    I dunno if any of this is useful, but thought it was worth mentioning.

  10. #10
    obildesheim NNTP User

    Default Re: RTL8187 and openSUSE 11

    Okay. Thanks for your hints. Will try it and give you feedback. Bye and best regards, Oliver

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •