Results 1 to 10 of 10

Thread: Mac Mini Intel Suse 11 Sound trouble (very soft)

  1. #1

    Default Mac Mini Intel Suse 11 Sound trouble (very soft)

    I installed OpenSUSE 11.0 on an Intel MacMini a few days ago. So far so good short of Wifi (got a cable) and sound. The installation resulted in the following audio devices (in the sound preferences):
    - PulseAudio Sound Server
    - STAC92xx Analog
    - STAC92xx Digital
    - ALSA
    - ESD
    - OSS
    I played with all settings and ended keeping it to autodetect.
    In devices I have:
    - HDA Intel (Alsa mixer)
    - USB2.0 Camera (Alsa mixer)
    - AK5370 (Alsa mixer) [that's a Plantronics USB Microphone)
    - Playback: ALSA PCM on fron:0 (STAC92xx Analog)via DMA (PulseAudioMixer)
    ... and 4 capture entries.

    The hardware information identifies Sound as 82801G (ICH7 Family) High Definition Audio Controller)

    I have 2 problems:
    a) the sound is very faint. I set it to max e.g. in Rhytmbox and barley can hear. When I plug my speakers into a MP3 player on 20% it is already 4 times louder. Where can I tweak the settings?

    b)Skype tells me "Problem with Audio playback" when I try to place a call. Help is very much appreciated.

  2. #2

    Default Skype isn't an issue any more

    Aaargs...
    To fast. In skype I set the devices from (default) to pulse for sound out and my mic for sound in and now it works. Remains the faint sound.
    I tried to play with the pulse mixer and set the input or output levels to more than 100%. At about 120% the sound starts to get garbled up (scratch sounds).

    :-) stw

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Mac Mini Intel Suse 11 Sound trouble (very soft)

    Quote Originally Posted by stwissel View Post
    I have 2 problems:
    a) the sound is very faint. I set it to max e.g. in Rhytmbox and barley can hear. When I plug my speakers into a MP3 player on 20% it is already 4 times louder. Where can I tweak the settings?

    b)Skype tells me "Problem with Audio playback" when I try to place a call. Help is very much appreciated.
    Is near as I can tell, you fixed problem #2, but you still are experiencing problem #1.

    For testing your sound, I recommend you copy and paste the following into an xterm/konsole (note it is case sensitive).
    speaker-test -Dplug:front -c2 -l5 -twav
    Note the "l5" controls the number of "left/right" iterations. "l2" would be 2 iterations and "l10" would be 10 interations.

    I recommend you backup /etc/modprobe.d/sound, as to fix this weak sound problem, its possible that file will get changed, and you may need to get back to the original configuration. So with that file backed up, did you try: YaST > Hardware > Sound > Other > Volume and move the slider bars to the right. .... Did that help? Also go into your mixer and move up both the Master Volume and the PCM to 70% or 80%. Note if you put them too high you will get distortion.

    I also read somewhere that a STAC9200 user (on a Dell 820) discovered with pulse audio applications, one must use plug:front (instead of plughw:0,0) for the PCM mixer to work, but darned if I can find the reference for that, so take that with a lot of salt. ... Its not clear to me where they did that edit (possible somewhere in YaST).

    Can you provide more info on your setup. Please with your mini mac connected to the internet, open an xterm/konsole and copy and paste the following script command into the xterm/konsole and run it:
    Code:
    wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa'
    when it asks for a password enter the root password. It will give you a URL when it is complete. Please post that URL here.

  4. #4

    Default Re: Mac Mini Intel Suse 11 Sound trouble (very soft)

    Hi OldCPU,

    thx for the help.
    The ALSA stuff is here: tsalsa.txt - nopaste.com (beta)

    I got more sound now, the Yast - Hardware - Sound - Other - Volume did the trick. It looks like the Mac uses digital sound (which I have no clue what output device to connect to. So when you click on "Test" for Master Volume nothing happens.
    However there are other channels, (Headset, front, surround) that do the trick. I slided the Headset to max and got much better volume (not good enough for a party, but I don't party in my study room). Strange that it doesn't show up in the regular mixer.
    Thx a again and have a great day!
    :-) stw

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Mac Mini Intel Suse 11 Sound trouble (very soft)

    Quote Originally Posted by stwissel View Post
    The ALSA stuff is here: tsalsa.txt - nopaste.com (beta)

    I got more sound now, the Yast - Hardware - Sound - Other - Volume did the trick. It looks like the Mac uses digital sound (which I have no clue what output device to connect to. So when you click on "Test" for Master Volume nothing happens.
    However there are other channels, (Headset, front, surround) that do the trick. I slided the Headset to max and got much better volume (not good enough for a party, but I don't party in my study room).
    Glad to read its "sort of working".

    Reading the script output, I see you have a stac9221. Checking the stac9221 in the ALSA-Configuration.txt file, I note a number of entries for Macs, including the Mac mini. Hence it "might" be possible to improve more with an edit to your /etc/modprobe.d/sound file.

    If you want to try that, then post the output of
    cat /etc/modprobe.d/sound
    and I'll post a recommended change to the /etc/modprobe.d/sound file.

  6. #6

    Default Re: Mac Mini Intel Suse 11 Sound trouble (very soft)

    Here you go:

    options snd slots=snd-hda-intel
    # u1Nb.FM5qfmnQDA7:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Mac Mini Intel Suse 11 Sound trouble (very soft)

    Quote Originally Posted by stwissel View Post
    Here you go:

    options snd slots=snd-hda-intel
    # u1Nb.FM5qfmnQDA7:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel
    Try changing that to:

    options snd slots=snd-hda-intel
    options snd-hda-intel=macmini
    # u1Nb.FM5qfmnQDA7:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel


    Note the line that I added. Then restart alsa from an xterm/konsole with root permissions with: rcalsasound restart and test your audio audio. (or reboot). If it makes no difference, you can remove that line.

    My reference for proposing the above line is the content of the ALSA-Configuration.txt file for the STAC9221.

  8. #8

    Default Re: Mac Mini Intel Suse 11 Sound trouble (very soft)

    Thx for helping.
    Didn't get the effect. Altering the file resulted in:
    WARNING: /etc/modprobe.d/sound line 6: ignoring bad line starting with 'options'
    I moved the line and the error number moved too.
    Nevermind sound's good so far.
    :-) stw

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Mac Mini Intel Suse 11 Sound trouble (very soft)

    Quote Originally Posted by stwissel View Post
    Thx for helping.
    Didn't get the effect. Altering the file resulted in:
    WARNING: /etc/modprobe.d/sound line 6: ignoring bad line starting with 'options'
    I moved the line and the error number moved too.
    Nevermind sound's good so far.
    :-) stw
    My apologies!! The line I gave you is wrong. ... (I don't know whats with me, ... its the second such mistake I have made in 2 days). Anyway, please try this instead:

    options snd slots=snd-hda-intel
    options snd-hda-intel
    model=macmini
    # u1Nb.FM5qfmnQDA7:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel


    and then restart alsa with rcalsasound restart and test your audio

  10. #10

    Default Re: Mac Mini Intel Suse 11 Sound trouble (very soft)

    I tried the setting.
    It mutes the whole thing. I guess the challenge here is:
    The MacMini use a single jack for both headset and an optical connection for full sound experience. Since I use the headset jack to connect to my speakers, I guess the sound is limited (probably to protect your ear in case you really would use a headset). So to enjoy full sound quality I guess I need some of this advanced audio gear.
    :-) stw

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •