Results 1 to 6 of 6

Thread: Strange printer driver error

  1. #1

    Question Strange printer driver error

    Have a Canon ip4300 connected via USB to laptop running opensuse 11. Trying to install the cnijfilter-ip4300-2.70-2.i386.rpm and cnijfilter-common-2.70-2.src.rpm.

    As root
    3000N200:/home/ben/Desktop # rpm -Uvh cnijfilter-common-2.70-2.src.rpm
    1:cnijfilter-common warning: user adminv270 does not exist - using root
    warning: group adminv270 does not exist - using root
    ########################################### [100%]
    warning: user adminv270 does not exist - using root
    warning: group adminv270 does not exist - using root

    and the other file fails because of the above
    3000N200:/home/ben/Desktop # rpm -Uvh cnijfilter-ip4300-2.70-2.i386.rpm
    error: Failed dependencies:
    cnijfilter-common >= 2.70 is needed by cnijfilter-ip4300-2.70-2.i386

    Any ideas please?

    Thanks

  2. #2

    Default Re: Strange printer driver error

    Did you try this one?
    ftp://download.canon.jp/pub/driver/b....70-1.i386.rpm


    You might want to wait for one of the forum admins or older members to answer, but maybe you have to try the --nodeps option. I've used that when there are circular dependencies, when a certain package provides a file, but also requires it before it can be installed. Sort of the chicken and the egg problem.

  3. #3
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: Strange printer driver error

    yeleek wrote:

    >
    > Have a Canon ip4300 connected via USB to laptop running opensuse 11.
    > Trying to install the cnijfilter-ip4300-2.70-2.i386.rpm and
    > cnijfilter-common-2.70-2.src.rpm.
    >
    > As root
    > 3000N200:/home/ben/Desktop # rpm -Uvh cnijfilter-common-2.70-2.src.rpm
    > 1:cnijfilter-common warning: user adminv270 does not exist -
    > using root
    > warning: group adminv270 does not exist - using root
    > ########################################### [100%]
    > warning: user adminv270 does not exist - using root
    > warning: group adminv270 does not exist - using root
    >
    > and the other file fails because of the above
    > 3000N200:/home/ben/Desktop # rpm -Uvh
    > cnijfilter-ip4300-2.70-2.i386.rpm
    > error: Failed dependencies:
    > cnijfilter-common >= 2.70 is needed by cnijfilter-ip4300-2.70-2.i386
    >
    > Any ideas please?
    >
    > Thanks
    >
    >


    The 'cnijfilter-common' is a *source code* package, and will not be usable
    in it's current state.

    The cnijfilter-ip4300 package is correct, go back and download the i386
    version of the cnijfilter-common' rpm and try again.

    The 'user adminv270' and 'group adminv270' warnings are just that, warnings
    that the user/group indicated in the rpm are non-existant on your system,
    so the system did the proper thing and installed them with root as owner.
    Not a problem there at all. Ignore those.

    Hope that helps.

    --
    L R Nix
    lornix@lornix.com

  4. #4

    Default Re: Strange printer driver error

    Thats great - many thanks to you both.

  5. #5
    Join Date
    Sep 2009
    Location
    East Lothian, Scotland
    Posts
    48

    Default Re: Strange printer driver error

    Hi,

    Sorry to resurrect an old (well lets face it, ancient thread!)

    I am trying to install a Canon Pixma iP4300. I am using the 'common' driver recommended earlier in this thread but am getting an error screen



    any idea how to resolve?

  6. #6

    Default Re: Strange printer driver error

    are you using a 64bit system?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •