Results 1 to 6 of 6

Thread: Internal speakers in laptop don't turn off.

  1. #1
    porzog NNTP User

    Default Internal speakers in laptop don't turn off.

    I use Asus X88SV laptop. When I plug headphones ( or external speakers ) internal speakers don't turn off. In Windows everything is OK. What is more, after fresh installation of
    OpenSuse 11.0 I didn't have this problem - internal speakers were turning off. Unfortunately, the sound was low-quality so I ran alsaconf - now the sound is OK, but I have this
    problem. I tried editing /etc/modprobe.d/sound file but I can't see any difference - even if I type model = ( random letters ).

    Outputs of diagnostic script:
    general pastebin - rydberg - post number 1082468
    tsalsa.txt - nopaste.com (beta)

    Code:
    rydberg@linux-4pnp:~/Desktop> uname -a
    Linux linux-4pnp 2.6.25.9-0.2-pae #1 SMP 2008-06-28 00:00:07 +0200 i686 i686 i386 GNU/Linux
    
    rydberg@linux-4pnp:~/Desktop> rpm -qa | grep alsa
    alsa-tools-1.0.16-47.1
    alsa-utils-1.0.16-35.1
    alsa-1.0.16-39.1
    alsa-plugins-pulse-1.0.16-57.1
    alsa-plugins-1.0.16-57.1
    alsa-oss-1.0.15-48.1
    alsa-devel-1.0.16-39.1
    alsa-firmware-1.0.16-24.1
    
    rydberg@linux-4pnp:~/Desktop> cat /etc/modprobe.d/sound
    
    options snd slots=snd-hda-intel
    # u1Nb.kM0PZji6MH3:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Internal speakers in laptop don't turn off.

    Quote Originally Posted by porzog View Post
    I use Asus X88SV laptop. When I plug headphones ( or external speakers ) internal speakers don't turn off. In Windows everything is OK. What is more, after fresh installation of OpenSuse 11.0 I didn't have this problem - internal speakers were turning off. Unfortunately, the sound was low-quality so I ran alsaconf - now the sound is OK, but I have this problem.
    That IS strange. You say with a fresh install of OpenSUSE-11.0, you could plug in your headphones and your speaker sound stopped, and your headphones worked? And running alsaconf broke that? I confess I am skeptical here.

    From what I know, alsaconf will modify one's /etc/modprobe.d/sound file, and then restart alsa. So why don't you simply rename the /etc/modprobe.d/sound file, and restart alsa with "rcalsasound restart". See what characteristics your audio has? (The idea behind renaming the file is you can always restore it). DON'T run alsaconf (at least not yet). If that doesn't work well, go to YaST > Hardware > Sound and setup your audio there. That will also create a new /etc/modprobe.d/sound file (different from the one created by alsaconf). See what characteristics your audio has after trying YaST.

    Quote Originally Posted by porzog View Post
    I tried editing /etc/modprobe.d/sound file but I can't see any difference - even if I type model = ( random letters ).
    Please, what do you mean by "random letters". The letters are not random, but rather dictated by the Linux Kernel Documentation :: sound : alsa : ALSA-Configuration.txt file, which has this section for the ALC888 (which is what your ASUS X55SV happens to have - and you need to find ONE of these that works for you):
    Code:
    857		ALC883/888
    858		  3stack-dig	3-jack with SPDIF I/O
    859		  6stack-dig	6-jack digital with SPDIF I/O
    860		  3stack-6ch    3-jack 6-channel
    861		  3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
    862		  6stack-dig-demo  6-jack digital for Intel demo board
    863		  acer		Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
    864		  acer-aspire	Acer Aspire 9810
    865		  medion	Medion Laptops
    866		  medion-md2	Medion MD2
    867		  targa-dig	Targa/MSI
    868		  targa-2ch-dig	Targs/MSI with 2-channel
    869		  laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
    870		  lenovo-101e	Lenovo 101E
    871		  lenovo-nb0763	Lenovo NB0763
    872		  lenovo-ms7195-dig Lenovo MS7195
    873		  haier-w66	Haier W66
    874		  6stack-hp	HP machines with 6stack (Nettle boards)
    875		  3stack-hp	HP machines with 3stack (Lucknow, Samba boards)
    876		  6stack-dell	Dell machines with 6stack (Inspiron 530)
    877		  mitac		Mitac 8252D
    878		  auto		auto-config reading BIOS (default)
    ie try an /etc/modprobe.d/sound file that looks like this:
    Code:
    options snd slots=snd-hda-intel
    options snd-hda-intel model=auto
    # u1Nb.kM0PZji6MH3:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    And restart your alsa with rcalsasound restart and then test ....

    And if "auto" doesn't work, you have MANY other options you can try, ... just remember to save the file, and restart alsa after each edit to the file.

    Quote Originally Posted by porzog View Post
    Thanks for that, but I am puzzling over those scripts, as they don't seem to be consistent with the /etc/modprobe.d/sound file you provided. I note the option "position_fix=1" in the alsainfo.sh script (which is supported by similar information in the tsalsa script output), but there is no mention of the "position_fix=1" in your /etc/modprobe.d/sound file. That's inconsistent to me, and hence it suggests you tried different configurations, and then randomly dumped some ???? of your output in your post. I could be wrong, but if your configuration changed in the middle of your post, that makes it difficult for me to help. You should have a consistent configuration when providing information.

    You could also consider updating your alsa. There are pre-packaged rpms that can bring your alsa up to v. 1.0.17. I can point you to the web site for those, ... although checking out the alsa site, the update in 1.0.17 for alsa does not appear to be specific to your Asus laptop ... Search results ALC888 - AlsaProject

    Also I note an ALC888 user here who had the same problem: Headphones fail to cut speaker sound - openSUSE Forums
    I could not solve their problem, and I ended up recommending they write a bug report. As near as I can determine, they did not, which if so is unfortunate. .... so you may wish to consider writing a bug report as well.

  3. #3
    porzog NNTP User

    Default Re: Internal speakers in laptop don't turn off.

    That IS strange. You say with a fresh install of OpenSUSE-11.0, you could plug in your headphones and your speaker sound stopped, and your headphones worked? And running alsaconf broke that? I confess I am skeptical here.
    I am not 100% sure - what I know is that before running alsaconf speaker sound stopped, and some time after alsaconf I've noticed that speaker sound dosen't stop.

    From what I know, alsaconf will modify one's /etc/modprobe.d/sound file, and then restart alsa. So why don't you simply rename the /etc/modprobe.d/sound file, and restart alsa with "rcalsasound restart". See what characteristics your audio has? (The idea behind renaming the file is you can always restore it). DON'T run alsaconf (at least not yet). If that doesn't work well, go to YaST > Hardware > Sound and setup your audio there. That will also create a new /etc/modprobe.d/sound file (different from the one created by alsaconf). See what characteristics your audio has after trying YaST.
    I've deleted /etc/modprobe.d/sound file.
    After "rcalsasound restart", the sound was the same like before and there was no sound file.
    After Yast, the sound was the same and new sound file was created - with:
    Code:
    options snd slots=snd-hda-intel
    # u1Nb.kM0PZji6MH3:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel

    Please, what do you mean by "random letters"
    I've tried every option you have listed, but there wasn't any difference - so I've just typed sth. like "model = dasdasdas" and there wasn't any difference in sound as well.

    That's inconsistent to me, and hence it suggests you tried different configurations, and then randomly dumped some ???? of your output in your post.
    Yes, a I tried different configurations to fix my problem.

  4. #4
    alcazoid NNTP User

    Default Re: Internal speakers in laptop don't turn off.

    Code:
    n0ne@darkstar:~> cat /etc/modprobe.conf.local 
    #
    # please add local extensions to this file
    #
    options snd-hda-intel position_fix=1 model=lenovo
    I have Asus F3Ka laptop and sound is working properly with this options. Try it.

  5. #5
    Join Date
    Sep 2008
    Location
    Helsinki
    Posts
    88

    Default Re: Internal speakers in laptop don't turn off.

    Hi,

    Thanks for code alcazoid. I have F3Ka laptop also, I had the broblem also,
    but "options snd-hda-intel position_fix=1 model=lenovo" helped, although with some traid off. My kmix volume ajustment bar sais: "Off-hook", and
    i can't adjust sound form it anymore. If i go to mixer settings adjustments works just fine. Do you have the same experience ? is there
    a way out for this trade off ?

  6. #6
    Join Date
    Sep 2008
    Location
    Helsinki
    Posts
    88

    Default Re: Internal speakers in laptop don't turn off.

    I appologize for posting previous question. For it apears "oof-hook" is
    not any problem, i just got master channel mixed up after modified /etc/modeprobe.conf.local. So things run happpy now here.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •