Results 1 to 5 of 5

Thread: Installing Flash Player for a Mac G4 PPC

  1. #1

    Default Installing Flash Player for a Mac G4 PPC

    Any idea where I can get the flash player for Firefox 3.0. I dop have nspluginwrapper installed and enabled in the Firefox.
    What do I need to do to install the Flash player.
    I haave tried installing it and the Yast gives me an error.
    Error
    Package /tmp/flash-plugin-0.0.124.0-release.i386.rpm could not be installed
    Details:
    Subprocess failed. Error: RPM Failed: package flash-plugin-0.0.124.0-release is intended for a i386 architecture.
    I thought with the nspluginwrapper active it should work.
    Is there another way to install this flash player with out using the YAST2.
    Thank you

  2. #2

    Default Re: Installing Flash Player for a Mac G4 PPC

    I forgot the version of Suse 11.0 Firefox 3.0.0.2

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: Installing Flash Player for a Mac G4 PPC

    Quote Originally Posted by dmatharu View Post
    Any idea where I can get the flash player for Firefox 3.0. I dop have nspluginwrapper installed and enabled in the Firefox.
    What do I need to do to install the Flash player. I haave tried installing it and the Yast gives me an error.
    Error
    Package /tmp/flash-plugin-0.0.124.0-release.i386.rpm could not be installed
    Details:
    Subprocess failed. Error: RPM Failed: package flash-plugin-0.0.124.0-release is intended for a i386 architecture.
    I thought with the nspluginwrapper active it should work. Is there another way to install this flash player with out using the YAST2.
    I have i386 architecture, and I don't know the first thing about PPCs.

    ... I do recall reading a post in the SF archives noting to install flash player in to ppc-machine you have to have this qemu and "x86 subsytem" installed:
    Ppc And Flash - openSUSE Forums

    ... maybe a real PPC user knows an easier way ?

  4. #4
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: Installing Flash Player for a Mac G4 PPC

    I think the realistic options are pretty much limited to either using one of the alternatives (gnash/swfdec) or simply living without it.

    The QEmu+Flash solution that oldcpu suggested (and rightly so because it's possible) is also extremely slow and would only be suitable for the very last PowerPC Macs (Dual CPU systems for example) if my memory serves me right.

    There is no native Linux PPC Flash binary.

  5. #5

    Default Re: Installing Flash Player for a Mac G4 PPC

    Thanks for the information. Looking deeply into it I think I can loive without the flash player as i have a laptop where i do some of the work. This linux machine is going to be a server come desktop so i will live with out the flash player.
    I just wanted to use my old mac to learn Linux administration and stuff. Create a mail server and web server as well.
    Being a newbie I will take the easy route of not installing the qume and slow the system down.
    Thanks again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •