Results 1 to 8 of 8

Thread: GRUB doesn't shew my Windows partitions

  1. #1
    Lord_Nuk NNTP User

    Default GRUB doesn't shew my Windows partitions

    Howdy all,

    I have a PC with Windows 98 and XP on the first HDD, and I installed openSUSE 11 on the second HDD, and now I can't boot to Windows. GRUB doesn't shew the Windows partition as an option. I tried adding it in the Boot section of the YAST but no luck. I tried making a Windows option and used the sd1 first as the boot device and then the sd2, but it didn't work.

    The only way I can access the Windows partition and get the Windows boot menu is by insterting the installation DVD. Of course, if I don't tend to it immediately it then boots to the SUSE installation program. I'm a total ignoramus when it comes to Linux; how can I get GRUB to give me an option to boot into my Windows OSes?

    Thanks in advance.

  2. #2

    Default Re: GRUB doesn't shew my Windows partitions

    Open in /boot/grub/menu.lst and copy this at the end...

    title Windows Xp
    rootnoverify (hd0,3)
    chainloader (hd0,0)+1

    Change the part hd0,3 and hd0,0 because is where my sistem exist.

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: GRUB doesn't shew my Windows partitions

    I think in your case then it should read

    title WIN XP
    map (hd0) (hd1)
    map (hd1) (hd0)
    rootnoverify (hd1,0)
    chainloader +1

    you need to use super user file manager to open /boot/grub/menu.lst
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    Lord_Nuk NNTP User

    Default Re: GRUB doesn't shew my Windows partitions

    Hmm, when I tried that I got this right after boot:

    "Error 13: Invalid or unsupported executable format."

    I'm clueless.

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: GRUB doesn't shew my Windows partitions

    did you try both the comments above?


    edit

    I just realized.
    Did you install grub to your windows mbr? (not so good)
    or to your suse hd? (better)

    what boot order are your hd's in?
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    Lord_Nuk NNTP User

    Default Re: GRUB doesn't shew my Windows partitions

    Hi,

    I think it must have been installed to the partition that contains the Windows mbr.

    I was thinking of maybe using FDISK /mbr to restore the Windows mbr and then using the repair installation option in the SUSE DVD to correct this problem, but I'm not sure if this is a good idea. Is there any other way I can get this working without reinstalling any of the three OSes?

    Thanks.

    PS: BTW, I tried only the second suggestion.

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: GRUB doesn't shew my Windows partitions

    you can use your xp disc to restore mbr with the fixmbr
    but this will mean you loose suse - at least until you get grub installed correctly

    once you have you xp mbr back and you can boot xp fine (you need to set the xp hd first to boot - which it seems it is)

    but now change your hd boot to have the suse hd first

    use the suse install dvd to boot up and use the repair feature to re-install grub.

    * You need to be sure you know which hd is which, at least as suse recognises them. If you are unsure. Use the suse installer first to see how it reads the drives. Probably sda, sdb. Then start again with the repair feature and install grub to the mbr of the suse hd. Leave suse hd as first boot device. and we can look again at the booting of windows when you have that sorted

    though you can always boot windows even if grub does not work, by temp switching hd back to xp first
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: GRUB doesn't shew my Windows partitions

    I recommend that you do this:
    sda contains windows 98 and xp. It's bootloader codes reside on the first partition, sda1. Those codes display a dual microsoft boot to 98/xp. They should be accessed/activated as an item in the grub menu. Grub should lay its code in the mbr of sda. Here's the repair steps in brief:
    1. Use "repair" on Suse's install DVD to generate a new Grub in the mbr of sda. That will get you into Suse from the boot process, but not windows. The Grub menu will be attenuated to boot only to Suse. Not to worry.
    2. Once in Suse, regenerate the full Grub menu that will contain windows entries pointing to sda1 and probably sda2 as well -- sda2 is useless ignore it because the bootloader codes for windows 98/xp are on sda1.
    3. Suse gets the grub entry for xp wrong, often portraying it like this:
      title windows1
      rootnoverify (hd1,x)
      chainloader (hd0,0)+1
      "x" denotes the partition on drive 2 (sdb) where Suse is. That's wrong. You have to edit the entry and make it into this:
      title Win 98 and XP
      rootnoverify (hd0,0)
      chainloader (hd0,0)+1


    The full details are here:
    GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader.

    All this is only correct if the first drive is the drive where the bios goes for the boot code in the MBR. If that was the configuration when Suse was installed. On the other hand, if the configuration was as implied by caf4926, that the bios has switched to seek the mbr of drive 2, and then Suse was installed, then you should stay with caf4926's approach.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •