Results 1 to 7 of 7

Thread: make command is not working

  1. #1
    slavox NNTP User

    Unhappy make command is not working

    Hi im fresh user of linux i have instaled opensuse 11, my atheros wifi is not working so i tried to instal madwifi from tar gz source, but commands make and make instal is not working. In madwifi guide is written make sure if you have installed kernel-source and the C++ compiler but i dont know how to check that. Here some other version to download "http://madwifi.org/suse/11.0/" but it is not working too anyway i need to use command make to instal other soft.
    Every guides and suse by it self is counting i have connection to internet but i dont, because i cant use my wifi please help

  2. #2
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: make command is not working

    open YaST & click on software management, then, in the search field,type :make & press enter. put a checkmark in the required box.then,type kernel sources in the search field & do the same with the checkmark.do this for gcc/gcc++ then,when finished,click the accept button on the bottom-right of the screen. be prepared for a bit of a wait whilst the software installs.as for madwifi, if you add the repository,you won't have to worry about this kerfuffle

    Andy

  3. #3
    slavox NNTP User

    Default Re: make command is not working

    Thank u Andy you really helped me, make and make install is now working but im doing this guide :

    1. Make sure you have installed the kernel-source and the C++ compiler. If not, please install them using YaST.
    2. Download the current drivers from this location [1].
    3. Unpack the archive in a temporary folder.
    4. Open up a terminal window.
    4. Switch to the temporary folder, and type in:
    make
    5. Now compile it:
    make install
    6. You can load the kernel modules using:
    modprobe ath_pci

    and the last command modprobe ath_pci is not working
    "modprobe command not found"

  4. #4
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: make command is not working

    the command needs to be run as root,so, in your terminal/console,type su & press enter,then type root's password & press enter. you won't see anything as you type root's password, this is for security.then, type in the command. if it returns to the prompt,it worked. if it didn't work,you will get an error message

    Andy

  5. #5

    Default Re: make command is not working

    Try installing madwifi first from the repositories

    Atheros madwifi - openSUSE

    It is less work then going through and compiling, plus to upgrade later you will just do it through yast or the repositories

  6. #6
    slavox NNTP User

    Default Re: make command is not working

    i did it and it wrote "module ath_pci not found" , i tried ndiswrapper and it's not working too, i can see my atheros card in system information and in yast network settings but i writes :
    "unable to configure the network card because the kernel device (eth0, wlan)is not present.This is the mostly caused by missing firmware (for lan devices)
    See dmesg output for deatils"

  7. #7

    Default Re: make command is not working

    did you get to this part after it was installed

    In the command prompt enter

    modprobe ath_pci

    That should load the driver for your wifi. I don't know if that needs to be root to do that command or not, off hand. You can try it as a regular user and see if it works, but something like wifi may need root privileges to get that loaded

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •