Results 1 to 5 of 5

Thread: TrueCrypt fails

  1. #1

    Default TrueCrypt fails

    I just installed TrueCrypt from the security repo this morning but can't get it started. I'm getting a "relocation error":

    Code:
    > truecrypt
    truecrypt: relocation error: truecrypt: symbol _ZTV13wxStackWalker, version WXU_2.8 not defined in file libwx_baseu-2.8.so.0 with link time reference
    WxWidgets is installed. I can't find much about this on google, is someone here familiar with this?

  2. #2

    Default Re: TrueCrypt fails

    Has anyone succeeded in installing TrueCrypt 6 in openSUSE 11? What version of wxWidgets do you have?

  3. #3
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: TrueCrypt fails

    Unfortunately it seems the Truecrypt6 in the security repository does not work with the Packmans WxWidgets.

    If you want to use it you need to remove the Packman's wxW libraries and install wxGTK from the base install. Alternatively you could download the Truecrypt source RPM and build it yourself.

    zypper remove wxWidgets

    Should do the job and install wxGTK for you. Note that this may break something else. So tread carefully and at your own risk, of course.

  4. #4

    Default Re: TrueCrypt fails

    Thanks, that did it.

  5. #5
    Join Date
    Jun 2008
    Location
    USA
    Posts
    150

    Default Re: TrueCrypt fails

    Have you tried to download the rpm directly from Truecrypt's website? I'm running openSUSE 11 and that's how I installed it and it works great.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •