Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: US-Intl layout, problem with one letter

  1. #1
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default US-Intl layout, problem with one letter

    Hi all.

    I am using English US, US International layout because I live in Brazil and I need portuguese characters, but cannot get used to ABNT2 keyboard layout. So, US Intl works for me.

    However, no matter what linux is (openSuse, Ubuntu, Fedora..) all has same problems
    (my current systems are suse 10.3 desktop, 11.0 laptop and ubuntu at work)

    Instead of writing "" it writes "ć"
    (key combination apostrophe+c)

    How to fix it?

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: US-Intl layout, problem with one letter

    Shouldn't you be using comma + c?

  3. #3

    Default Re: US-Intl layout, problem with one letter

    I use US-intl too for "" I use rightAlt + comma.
    Primary OS: openSUSE 11.1 + KDE4
    Secondary OS: openSUSE 11.1 + Gnome

    Tertiary OS: Windows 7 Ultimate Beta
    VirtualBox'ed OS: Mandriva 2009.1 Beta

  4. #4
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: US-Intl layout, problem with one letter

    Right Alt + Comma works.
    Comma is not a special key so comma+c does not work.

    OK, I didn't know for Right Alt + Comma. When I started using US-Intl it was on windows and there is apostrophe+c. I reckon it should be the same. I resolved the problem by installing ABNT making a quick-switch just because of that letter.

    Anyway, problem is now solved.. I shall use Right Alt + Comma from now on.

    Just out of curiosity, is there a way to make linux work as I want, I mean, regarding this key combination?

  5. #5
    Join Date
    Jun 2008
    Location
    Omaha, NE
    Posts
    526

    Default Re: US-Intl layout, problem with one letter

    You can configure input actions in KDE, but I'm not sure you can configure comma+c as a combination since neither is a "special" key.

  6. #6
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: US-Intl layout, problem with one letter

    Well, I will think on some workaround...

    Thanks

  7. #7
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: US-Intl layout, problem with one letter

    What I do for diacritics is enable the Compose key so that I have the standard compose sequences that Xorg knows about. In YaST > Hardware > Keyboard find the Menu is Compose checkbox and turn it on. Menu is the normally useless key next to the Windows key. Or use the Windows key for Compose. (And for good measure, if you hate the Caps Lock key like I do, turn on Caps Lock is additional Ctrl.)

    Now you can enter diacritics with 3 key sequences:

    Euro sign is Compose = C
    c cedilla is Compose , c

    and so forth. Here are all the supported Compose sequences:

    Compose key magic Cyberborean Chronicles

  8. #8
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: US-Intl layout, problem with one letter

    Thank you very much. I will try that

  9. #9
    peterson_espacoporto NNTP User

    Default Re: US-Intl layout, problem with one letter

    Hi,

    I tried to follow some of the instructions on the "cyberborean chronicles" link, but when I try to edit /usr/share/X11/locale/en_US.UTF-8 VIM tells me that is an illegal file name... I am logged as root and the file exists =S

    Also, I am used to type ' + c in order to type , with compose keys I will need to press compose key first? If this is how it works, is there a way to skip that compose-key-pressing part?

    I'd really appreciate some help, I'm quite lost =/ Thanks in advance!

  10. #10
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: US-Intl layout, problem with one letter

    I just gave up. There is no easy way to do it.
    Easier is to get used to "right ALT" + ","
    after a couple of days of irritation, I got used to it.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •