Results 1 to 6 of 6

Thread: Cups errors in log

  1. #1
    mindea NNTP User

    Default Cups errors in log

    My /var/log/warn is full of lines like below. New messages appear every 20 seconds or so.

    Jul 23 21:34:13 linux smbd[14216]: [2008/07/23 21:34:13, 0] printing/print_cups.c:cups_printer_fn(108)
    Jul 23 21:34:13 linux smbd[14216]: Unable to connect to CUPS server localhost - Connection refused

    I am running SAMBA, but not running CUPS on this server and don't plan to. How do I stop these messages?

    Thanks.

  2. #2
    PV NNTP User

    Default Re: Cups errors in log

    mindea wrote:

    >
    > My /var/log/warn is full of lines like below. New messages appear every
    > 20 seconds or so.
    >
    > Jul 23 21:34:13 linux smbd[14216]: [2008/07/23 21:34:13, 0]
    > printing/print_cups.c:cups_printer_fn(108)
    > Jul 23 21:34:13 linux smbd[14216]: Unable to connect to CUPS server
    > localhost - Connection refused
    >
    > I am running SAMBA, but not running CUPS on this server and don't plan
    > to. How do I stop these messages?


    Why?
    >
    > Thanks.
    >
    >

    Mindea;

    I assume that if you remove the references to cups printing in
    your /etc/samba/smb.conf this will go away. If you are not sure what I
    mean here, please post your smb.conf. To be honest, I've always been happy
    with CUPS and never tried to remove it.
    --
    P. V.

  3. #3
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: Cups errors in log

    PV wrote:

    > mindea wrote:
    >
    >>
    >> My /var/log/warn is full of lines like below. New messages appear every
    >> 20 seconds or so.
    >>
    >> Jul 23 21:34:13 linux smbd[14216]: [2008/07/23 21:34:13, 0]
    >> printing/print_cups.c:cups_printer_fn(108)
    >> Jul 23 21:34:13 linux smbd[14216]: Unable to connect to CUPS server
    >> localhost - Connection refused
    >>
    >> I am running SAMBA, but not running CUPS on this server and don't plan
    >> to. How do I stop these messages?

    >
    > Why?
    >>
    >> Thanks.
    >>
    >>

    > Mindea;
    >
    > I assume that if you remove the references to cups printing in
    > your /etc/samba/smb.conf this will go away. If you are not sure what I
    > mean here, please post your smb.conf. To be honest, I've always been
    > happy with CUPS and never tried to remove it.


    Kind of have to agree with PV, cups is useful, if only once in a quarter.

    The 'smb.conf' man page is helpful, you can change the printing system that
    samba is looking for by changing the 'printing = cups' line
    in /etc/samba/smb.conf (starts at around line 5550 in man page,
    type "5550g" to skip to it)

    printing = cups
    printing = bsd
    printing = lprng
    printing = sysv

    Of course, this will cause samba to go looking for THAT print system, and
    could result in more log entries.

    a drastic solution would be to have something listen on the cups port and
    answer the connections... but then you'd have to emulate the protocol.

    You could just install cups and forget about it. Myself, it works great, I
    have a main system with a printer on it, shared through samba and cups, my
    other linux systems automatically see it through their cups services and it
    shows up in print dialogs, while the windows machines see the samba share
    and can use it that way. kinda slick. And I didn't have to touch the
    linux boxes, they "just work". (love that part!)


    --
    L R Nix
    lornix@lornix.com

  4. #4
    PV NNTP User

    Default Re: Cups errors in log

    L R Nix wrote:

    > PV wrote:
    >
    >> mindea wrote:
    >>
    >>>
    >>> My /var/log/warn is full of lines like below. New messages appear every
    >>> 20 seconds or so.
    >>>
    >>> Jul 23 21:34:13 linux smbd[14216]: [2008/07/23 21:34:13, 0]
    >>> printing/print_cups.c:cups_printer_fn(108)
    >>> Jul 23 21:34:13 linux smbd[14216]: Unable to connect to CUPS server
    >>> localhost - Connection refused
    >>>
    >>> I am running SAMBA, but not running CUPS on this server and don't plan
    >>> to. How do I stop these messages?

    >>
    >> Why?
    >>>
    >>> Thanks.
    >>>
    >>>

    >> Mindea;
    >>
    >> I assume that if you remove the references to cups printing in
    >> your /etc/samba/smb.conf this will go away. If you are not sure what I
    >> mean here, please post your smb.conf. To be honest, I've always been
    >> happy with CUPS and never tried to remove it.

    >
    > Kind of have to agree with PV, cups is useful, if only once in a quarter.
    >
    > The 'smb.conf' man page is helpful, you can change the printing system
    > that samba is looking for by changing the 'printing = cups' line
    > in /etc/samba/smb.conf (starts at around line 5550 in man page,
    > type "5550g" to skip to it)
    >
    > printing = cups
    > printing = bsd
    > printing = lprng
    > printing = sysv
    >
    > Of course, this will cause samba to go looking for THAT print system, and
    > could result in more log entries.
    >
    > a drastic solution would be to have something listen on the cups port and
    > answer the connections... but then you'd have to emulate the protocol.
    >
    > You could just install cups and forget about it. Myself, it works great,
    > I have a main system with a printer on it, shared through samba and cups,
    > my other linux systems automatically see it through their cups services
    > and it shows up in print dialogs, while the windows machines see the samba
    > share
    > and can use it that way. kinda slick. And I didn't have to touch the
    > linux boxes, they "just work". (love that part!)
    >
    >

    To all;

    There is also printcap, but I think if you leave all empty there is no
    default. If I'm wrong, you can check this with "testparm -v"
    --
    P. V.
    "We have met the enemy an he is us" Pogo

  5. #5
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Cups errors in log

    AS mentioned by lornix/PV comment out all this stuff by putting a hash # at the beginning:
    # printing = cups
    # printcap name = cups
    # printcap cache time = 750
    # cups options = raw

    But also maybe do these two paras, or get Yast to do it by toggling them off in Yast --> Network services --> Samba server
    [printers]
    comment = All Printers
    path = /var/tmp
    printable = Yes
    create mask = 0600
    browseable = No
    [print$]
    comment = Printer Drivers
    path = /var/lib/samba/drivers
    write list = @ntadmin root
    force group = ntadmin
    create mask = 0664
    directory mask = 0775
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  6. #6
    mindea NNTP User

    Default Re: Cups errors in log

    Thanks for all the suggestions. My main goal was to eliminate the messages in the log, which as it turns out, is easily done by simply letting the CUPS service run idle. I was assuming the answer would be much more complicated. Silly me.

    Thanks again for all the input.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •