Results 1 to 7 of 7

Thread: System sounds stopped working after updating the system

  1. #1
    cloudbase NNTP User

    Default System sounds stopped working after updating the system

    Hello,

    I recently loaded OpenSuse 10.3 on my Dell Latitude D610 laptop and I have been very pleased with how smoothly things went. However, the system updater ran today, and now my system sounds don't seem to be working any more, but Flash is still working with sound on sites like Youtube.

    I checked the volume settings in the mixer. Master and PCM volume are both set at about 75% in the "yast/hardware/sounds/other" area. The test sound is also working. In "Sound Preferences", I can hear all the test sounds on the "Devices" tab. On the "Sounds" tab, I have "Enable ESD" and "Play System Sounds" checked, but no sounds play when I hit the "Play" button beside any of the items under "System Sounds".

    The System Sounds were working before, but I noticed that my login screen was silent the next time I started my machine after the update ran. I'm not exactly sure what all updated today because I didn't study the list very closely, but the system was updated a couple of days ago without any problems.

    I'm not terribly worried about the system sounds themselves, if that is all I have lost. I'm more worried about what happened, and what else will it affect? I'm hoping it is something simple that I am overlooking. Does anyone have any suggestions?

    Thanks in advance for your assistance.

    -cloudbase-

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,323
    Blog Entries
    15

    Default Re: System sounds stopped working after updating the system

    On Thu, 24 Jul 2008 01:46:03 GMT
    cloudbase <cloudbase@no-mx.forums.opensuse.org> wrote:

    >
    > Hello,
    >
    > I recently loaded OpenSuse 10.3 on my Dell Latitude D610 laptop and I
    > have been very pleased with how smoothly things went. However, the
    > system updater ran today, and now my system sounds don't seem to be
    > working any more, but Flash is still working with sound on sites like
    > Youtube.
    >
    > I checked the volume settings in the mixer. Master and PCM volume are
    > both set at about 75% in the "yast/hardware/sounds/other" area. The
    > test sound is also working. In "Sound Preferences", I can hear all
    > the test sounds on the "Devices" tab. On the "Sounds" tab, I have
    > "Enable ESD" and "Play System Sounds" checked, but no sounds play
    > when I hit the "Play" button beside any of the items under "System
    > Sounds".
    >
    > The System Sounds were working before, but I noticed that my login
    > screen was silent the next time I started my machine after the update
    > ran. I'm not exactly sure what all updated today because I didn't
    > study the list very closely, but the system was updated a couple of
    > days ago without any problems.
    >
    > I'm not terribly worried about the system sounds themselves, if that
    > is all I have lost. I'm more worried about what happened, and what
    > else will it affect? I'm hoping it is something simple that I am
    > overlooking. Does anyone have any suggestions?
    >
    > Thanks in advance for your assistance.
    >
    > -cloudbase-
    >
    >

    Hi
    You don't say what desktop you are running? But in the desktop
    control panel/personal settings there should be an option to enable
    sound server or enable the sound system.

    --
    Cheers Malcolm (Linux Counter #276890)
    SLED 10 SP2 i586 Kernel 2.6.16.60-0.25-default
    up 14:48, 1 user, load average: 0.07, 0.10, 0.22
    GPU GeForce Go 6600 TE/6200 TE Version: 173.14.09


  3. #3
    cloudbase NNTP User

    Default Re: System sounds stopped working after updating the system

    Sorry about that. I forgot to mention that I am using Gnome.

    Where do I need to look in order to make sure that my sound server is running? In "Sound Preferences" under the "Sounds" tab, there is a check in the box for "Enable software sound mixing (ESD)". Is that what I am looking for?

    Thanks again for your assistance.

    -cloudbase-

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,323
    Blog Entries
    15

    Default Re: System sounds stopped working after updating the system

    On Thu, 24 Jul 2008 03:36:03 GMT
    cloudbase <cloudbase@no-mx.forums.opensuse.org> wrote:

    >
    > Sorry about that. I forgot to mention that I am using Gnome.
    >
    > Where do I need to look in order to make sure that my sound server is
    > running? In "Sound Preferences" under the "Sounds" tab, there is a
    > check in the box for "Enable software sound mixing (ESD)". Is that
    > what I am looking for?
    >
    > Thanks again for your assistance.
    >
    > -cloudbase-
    >
    >

    Hi
    Yup that should be it, and also the 'enable system sounds' is checked.

    --
    Cheers Malcolm (Linux Counter #276890)
    SLED 10 SP2 i586 Kernel 2.6.16.60-0.25-default
    up 16:19, 1 user, load average: 0.69, 0.54, 0.47
    GPU GeForce Go 6600 TE/6200 TE Version: 173.14.09


  5. #5
    cloudbase NNTP User

    Default Re: System sounds stopped working after updating the system

    Hi,

    I double-checked it. Both boxes are checked, but I still don't have any System Sounds. All other audio seems to be working fine.

    Any other suggestions?

    Thanks again for your assistance.

    -cloudbase-

  6. #6
    cloudbase NNTP User

    Default Re: System sounds stopped working after updating the system

    Thanks for your assistance. Please consider this issue resolved. I'm not sure what changed, but it is working now.

    I logged in as root and system sounds worked. Then I logged back in under the user account and it works there now too.

    I am not sure what logging in as root had to do with it, but it seems to be fixed now.

    Thanks,

    -cloudbase-

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,323
    Blog Entries
    15

    Default Re: System sounds stopped working after updating the system

    On Fri, 25 Jul 2008 00:46:04 GMT
    cloudbase <cloudbase@no-mx.forums.opensuse.org> wrote:

    >
    > Thanks for your assistance. Please consider this issue resolved. I'm
    > not sure what changed, but it is working now.
    >
    > I logged in as root and system sounds worked. Then I logged back in
    > under the user account and it works there now too.
    >
    > I am not sure what logging in as root had to do with it, but it seems
    > to be fixed now.
    >
    > Thanks,
    >
    > -cloudbase-
    >
    >

    Hi
    Logging in as root may have created /dev/dsp or something similar. I
    always forget to check that it exists (or where ever your sound card is
    listed in the /dev area)

    --
    Cheers Malcolm (Linux Counter #276890)
    SLED 10 SP2 i586 Kernel 2.6.16.60-0.25-default
    up 13:40, 1 user, load average: 0.03, 0.14, 0.36
    GPU GeForce Go 6600 TE/6200 TE Version: 173.14.09


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •