Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Compiz enabled = no window borders

  1. #1

    Default Compiz enabled = no window borders

    Compiz was working flawlessly on this machine until very recently (I'm thinking an update broke it). Now enabling it with the compiz-fusion icon (which I now also use to turn it off) causes the window borders to disappear. Naturally the effects themselves also don't work. I do have Nvidia's drivers installed.

    I'm convinced this is a fairly simple issue as I remember reading posts about it before but as I'm sure you've already deduced...I am a noob.

  2. #2

    Default Re: Compiz enabled = no window borders

    Reinstalled nvidia's display driver (NVIDIA-Linux-x86-173.14.09-pkg1.run) after learning of a recent X11 update. However, the issue persists. GUI works with compiz running, just no window borders or actual effects.

  3. #3

    Default Re: Compiz enabled = no window borders

    It's a common problem with Nvidia cards I am afraid. I've run into this problem as well and fixed it by adding argb-glx-visuals.

    Code:
    nvidia-xconfig --add-argb-glx-visuals
    nvidia-xconfig -d 24
    Hope this works.

  4. #4

    Default Re: Compiz enabled = no window borders

    Nothing. Same result.

    Intersting how compiz was working flawlessly just a few days ago. This is why I assume this was caused by an update. Either way so far, no luck.

  5. #5
    Join Date
    Jun 2008
    Location
    Omaha, NE
    Posts
    526

    Default Re: Compiz enabled = no window borders

    Fusion-icon should also allow you to reload your window manager, change between kwin, emerald, etc.

  6. #6

    Default Re: Compiz enabled = no window borders

    I've experienced similar issues. The way I've been able to fix it is to totally uninstall the nvidia drivers from both repositories and using their installer downloaded from the website. I then reinstall using the installer from the website (following the instructions).

    I think what's happening is the driver is failing to load and compiz is getting rendered with software.

  7. #7
    Join Date
    Jun 2008
    Location
    Omaha, NE
    Posts
    526

    Default Re: Compiz enabled = no window borders

    You can tell if the Nvidia driver is loaded quite easily if the Nvidia logo comes up when you load Xorg.

    What I've run into with openSUSE is that the 1-click installer will install the Nvidia driver, but sometimes it doesn't change xorg.conf so it isn't loading the driver.

    I edit /etc/X11/xorg.conf and change driver="nvidia" and then I'm in business.

  8. #8

    Default Re: Compiz enabled = no window borders

    Quote Originally Posted by enderandrew View Post
    You can tell if the Nvidia driver is loaded quite easily if the Nvidia logo comes up when you load Xorg.

    What I've run into with openSUSE is that the 1-click installer will install the Nvidia driver, but sometimes it doesn't change xorg.conf so it isn't loading the driver.

    I edit /etc/X11/xorg.conf and change driver="nvidia" and then I'm in business.
    The logo does show when X is starting.

    The driver installed is the one from Nvidia's website and I did so by stopping X, using the "sh" command with the driver file as an argument which start an Nvidia setup shell, compiled a kernel, etc.

    I'm going to take a look at xorg.conf. For some reason I haven't done that yet.

  9. #9

    Default Re: Compiz enabled = no window borders

    I thought maybe nvidia's entry was missing or wrong, but here it is:
    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Thu Jun  5 00:10:21 PDT 2008
    
    # /.../
    # SaX generated X11 config file
    # Created on: 2008-07-14T23:07:27-0400.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    
    Section "ServerLayout"
        Identifier     "Layout[all]"
        Screen         "Screen[0]" 0 0
        InputDevice    "Keyboard[0]" "CoreKeyboard"
        InputDevice    "Mouse[1]" "CorePointer"
        InputDevice    "Mouse[3]" "SendCoreEvents"
        Option         "Clone" "off"
        Option         "Xinerama" "off"
    EndSection
    
    Section "Files"
        InputDevices      "/dev/gpmdata"
        InputDevices      "/dev/input/mice"
        FontPath        "/usr/share/fonts/misc:unscaled"
        FontPath        "/usr/share/fonts/local"
        FontPath        "/usr/share/fonts/75dpi:unscaled"
        FontPath        "/usr/share/fonts/100dpi:unscaled"
        FontPath        "/usr/share/fonts/Type1"
        FontPath        "/usr/share/fonts/URW"
        FontPath        "/usr/share/fonts/cyrillic"
        FontPath        "/usr/share/fonts/latin2/misc:unscaled"
        FontPath        "/usr/share/fonts/latin2/75dpi:unscaled"
        FontPath        "/usr/share/fonts/latin2/100dpi:unscaled"
        FontPath        "/usr/share/fonts/latin2/Type1"
        FontPath        "/usr/share/fonts/latin7/75dpi:unscaled"
        FontPath        "/usr/share/fonts/baekmuk:unscaled"
        FontPath        "/usr/share/fonts/japanese:unscaled"
        FontPath        "/usr/share/fonts/kwintv"
        FontPath        "/usr/share/fonts/truetype"
        FontPath        "/usr/share/fonts/uni:unscaled"
        FontPath        "/usr/share/fonts/CID"
        FontPath        "/usr/share/fonts/ucs/misc:unscaled"
        FontPath        "/usr/share/fonts/ucs/75dpi:unscaled"
        FontPath        "/usr/share/fonts/ucs/100dpi:unscaled"
        FontPath        "/usr/share/fonts/hellas/misc:unscaled"
        FontPath        "/usr/share/fonts/hellas/75dpi:unscaled"
        FontPath        "/usr/share/fonts/hellas/100dpi:unscaled"
        FontPath        "/usr/share/fonts/hellas/Type1"
        FontPath        "/usr/share/fonts/misc/sgi:unscaled"
        FontPath        "/usr/share/fonts/xtest"
        FontPath        "/opt/kde3/share/fonts"
    EndSection
    
    Section "Module"
        Load           "freetype"
        Load           "type1"
        Load           "dbe"
        Load           "glx"
        Load           "extmod"
    EndSection
    
    Section "ServerFlags"
        Option         "AllowMouseOpenFail" "on"
        Option         "ZapWarning" "on"
    EndSection
    
    Section "InputDevice"
        Identifier     "Keyboard[0]"
        Driver         "kbd"
        Option         "Protocol" "Standard"
        Option         "XkbLayout" "us"
        Option         "XkbModel" "microsoftpro"
        Option         "XkbRules" "xfree86"
    EndSection
    
    Section "InputDevice"
        Identifier     "Mouse[1]"
        Driver         "synaptics"
        Option         "Buttons" "5"
        Option         "Device" "/dev/input/mice"
        Option         "Emulate3Buttons" "on"
        Option         "HorizScrollDelta" "0"
        Option         "InputFashion" "Mouse"
        Option         "Name" "Synaptics;Touchpad"
        Option         "Protocol" "explorerps/2"
        Option         "SHMConfig" "on"
        Option         "Vendor" "Sysp"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        Identifier     "Mouse[3]"
        Driver         "mouse"
        Option         "Buttons" "5"
        Option         "Device" "/dev/input/mice"
        Option         "Name" "ImPS/2 Generic Wheel Mouse"
        Option         "Protocol" "explorerps/2"
        Option         "Vendor" "Sysp"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "Modes"
        Identifier         "Modes[0]"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor[0]"
        VendorName     "--> LCD"
        ModelName      "1280X800@60HZ"
        UseModes       "Modes[0]"
        DisplaySize     305    230
        HorizSync       30.0 - 52.0
        VertRefresh     50.0 - 60.0
        Option         "CalcAlgorithm" "XServerPool"
        Option         "DPMS"
        Option         "PreferredMode" "1280x800"
    EndSection
    
    Section "Device"
        Identifier     "Device[0]"
        Driver         "nvidia"
        VendorName     "NVidia"
        BoardName      "GeForce FX Go5200 32M/64M"
        Screen          0
    EndSection
    
    Section "Screen"
        Identifier     "Screen[0]"
        Device         "Device[0]"
        Monitor        "Monitor[0]"
        DefaultDepth    24
        Option         "AddARGBGLXVisuals" "True"
        SubSection     "Display"
            Depth       15
            Modes      "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
        EndSubSection
        SubSection     "Display"
            Depth       16
            Modes      "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
        EndSubSection
        SubSection     "Display"
            Depth       24
            Modes      "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
        EndSubSection
        SubSection     "Display"
            Depth       8
            Modes      "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
        EndSubSection
    EndSection
    
    Section "Extensions"
        Option         "Composite" "on"
    EndSection

  10. #10
    Join Date
    Jun 2008
    Location
    PA, USA
    Posts
    28

    Default Re: Compiz enabled = no window borders

    I had a similar issue after re-installing OpenSuSE 11. Here is how I resolved the situation. I realized that I can get Windows borders only with Emerald themes. Somehow the Emerald themes were not being used. In Compiz Settings Manager, to go Effects and click on Window Decorations. This will bring up the menu. In the Command box, type:

    emerald -replace.

    Once I did this, I was able to use Emerald themes with window borders. Hope this will help you.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •