Results 1 to 4 of 4

Thread: KNetworkManager always defaults to eth1

  1. #1

    Default KNetworkManager always defaults to eth1

    Hello everyone, I have OpenSUSE 10.3 and two network cards in my PC and when I reboot the computer the KNetworkManager always selects eth1 as the default connecting device. I cannot get online until I open KNetworkManager and select eth0. One network card is for an internal network and the other one is for the external network.

    Can someone please tell me how to select eth0 as the default card?

    thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,453

    Default Re: KNetworkManager always defaults to eth1


    >
    > Hello everyone, I have OpenSUSE 10.3 and two network cards in my PC and
    > when I reboot the computer the KNetworkManager always selects eth1 as
    > the default connecting device. I cannot get online until I open
    > KNetworkManager and select eth0. One network card is for an internal
    > network and the other one is for the external network.
    >
    > Can someone please tell me how to select eth0 as the default card?
    >
    > thanks
    >
    > This quote is experimental
    If you go to
    YaST>Network Devices>Network Settings>Overview>
    Highlight eth0 and look at the bottom does it say Started automatically at
    boot? I have seen this same behavior on my home system, but I ditched
    NetworkManager altogether on that machine. I'll fuss with my VM a bit to
    see if we can come up with a solution that isn't a real hack job if you
    want.


  3. #3

    Default Re: KNetworkManager always defaults to eth1

    Hi thanks for the reply. You know what I just read on the documentation on the left. It says that if you want to use multiple connections at onece use ifup. I switched over to ifup and that seems to do it.

    thanks

  4. #4
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,453

    Default Re: KNetworkManager always defaults to eth1

    Quote Originally Posted by karozans View Post
    Hi thanks for the reply. You know what I just read on the documentation on the left. It says that if you want to use multiple connections at onece use ifup. I switched over to ifup and that seems to do it.

    thanks
    Ha! If at first you don't succeed read the instructions. Oddly on my home machine NetworkManager kept saying I had a WiFi connection...which my PC does not have WiFi. Heh heh. One of the reasons I ditched it for ifup.
    Eventually you should be able to use KnetworkManager for all of
    your interfaces, but there are still instances where ifup works
    better. I think eventually knetworkmanager will be the superior of the two. It does have some slick features.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •