Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Intel 3945abg with Opensuse 11

  1. #1

    Default Intel 3945abg with Opensuse 11

    Hi all!

    I've done a fresh install of Opensuse 11 Kde4,and immediately i've found problems with my intel 3945abg wireless card and my WEP encrypted connection..simply i can't see it from my laptop

    i tried connecting from terminal with
    Code:
    iwconfig wlan0 essid myessid
    iwconfig wlan0 key myhexkey
    dhclient wlan0
    but nothing happened..

    then i tried compiling compat-wireless drivers from source! i was able to compile,install and load them,but my wireless card doesn't recognize anything yet.

    I've read about a lot of people that solved with these drivers,am I the only person in the world that can't solve this problem?? O_O

    any tips?

    P.S. I'm running kernel 2.6.25.11-0.1-default for i586 architecture.

    Cheers,Fabio

  2. #2
    Join Date
    Jul 2008
    Location
    Netherlands
    Posts
    26

    Default Re: Intel 3945abg with Opensuse 11

    I've been there too.

    google for "compat wireless" do everything they tell you to but do not type make unload.

    Just load the new drivers over the old ones. Your let won't work but it solved my isseus.

    Cheers, Thomas

  3. #3

    Default Re: Intel 3945abg with Opensuse 11

    as you can read above i've already downloaded,extracted,installed and loaded compat-wireless drivers following the instructions on linuxwireless.org (i did not run "make unload" but only "make load",like you did),but i can't have my card working!

  4. #4

    Default Re: Intel 3945abg with Opensuse 11

    I know this isn't a direct answer to your problem, but is there any way you could try changing your encryption to WPA? It's not like WEP is very secure anyway (Google "aircrack").

    Also, have you tried connecting via Network Manager by manually supplying it with your connection details, including WEP key?

  5. #5

    Default Re: Intel 3945abg with Opensuse 11

    I also tried via Network Manager to manually connect,but it doesn't works!
    now i can't change my encryption because my brother is unavailable and he's the only one to remember router's admin password! By the way I don't think it will works..my card doesn't recognize nothing,and i think this is not an encryption problem! thanks anyway!

  6. #6
    Join Date
    Jul 2008
    Location
    Netherlands
    Posts
    26

    Default Re: Intel 3945abg with Opensuse 11

    could you post the results of:

    dmesg | grep iwl3945

    and the nic part of

    lspci -v

  7. #7

    Default Re: Intel 3945abg with Opensuse 11

    P.S. i forgot to say that the card is recognized by the system,obviously!

    these are the results:

    Code:
    fabbio@linux-q9xd:~> dmesg | grep iwl3945
    iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26ks
    iwl3945: Copyright(c) 2003-2008 Intel Corporation
    iwl3945: Detected Intel Wireless WiFi Link 3945ABG
    iwl3945: Tunable channels: 13 802.11bg, 23 802.11a channels
    Code:
    linux-q9xd:/home/fabbio # lspci -v
    
    ......03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
            Subsystem: Intel Corporation Device 1001
            Flags: bus master, fast devsel, latency 0, IRQ 219
            Memory at fe1ff000 (32-bit, non-prefetchable) [size=4K]
            Capabilities: [c8] Power Management version 2
            Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable+
            Capabilities: [e0] Express Legacy Endpoint, MSI 00
            Kernel driver in use: iwl3945
            Kernel modules: iwl3945

  8. #8
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Intel 3945abg with Opensuse 11

    * itfsos,

    try and disable hw_scan.
    Open a console, become root.
    touch /etc/modprobe.d/iwl3945

    Edit the file and add
    alias wlan0 iwl3945
    options iwl3945 disable_hw_scan=1

    Reboot.

    Uwe

  9. #9

    Default Re: Intel 3945abg with Opensuse 11

    i tried but...nothing!

  10. #10
    mitch1976 NNTP User

    Default Re: Intel 3945abg with Opensuse 11

    I've done that
    try and disable hw_scan.
    Open a console, become root.
    touch /etc/modprobe.d/iwl3945

    Edit the file and add
    alias wlan0 iwl3945
    options iwl3945 disable_hw_scan=1


    And it recognises my wireless and scans!! Doesn't connect yet though but presumably that is because the router is set for WEP and not WPA ??

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •