Results 1 to 7 of 7

Thread: linuxbox as router

  1. #1

    Default linuxbox as router

    Hi,

    I need help, 'cause I cannot configure my new suse11 linux box.

    I have my ROUTER_PC (wih suse11) connected to a ADSL_ROUTER via eth0. It uses the DHCP protocol to start the eth0 interface.
    The ADSL_ROUTER returns addresses between 192.168.1.10 and 192.168.1.100.

    On my ROUTER_PC there is a wireless card. The interface is ath0 and is configured as master with fix ip address of 192.168.2.1

    Now I have a CLIENT_PC which connets to the ROUTER_PC using windows and wireless (with fix ip 192.168.2.2).

    How can I configure my ROUTER_PC to let the CLIENT_PC go in internet? I need some kind of IP forwarding ????
    possibly using yast2?

    PLEASE HELP,
    Dustin

  2. #2
    Join Date
    Jul 2008
    Location
    SPAIN
    Posts
    132

    Default Re: linuxbox as router

    Yes, you need to enable forwarding in the ROUTER_PC box.

    .Since the CLIENT_PC machine will go out to the internet via the ROUTER_PC, its default gateway should be set the the ip addres of the ROUTER_PC wifi nic, 192.168.2.1.

    .You should also probably has to add a route path in the ADSL device to make the traffic comming from the internet that is targeted to the subnet 192.168.2 get to its intended destination (where CLIENT_PC box is located).
    See your ADSL device manual for details.

    .On the other hand, the default gateway for the ROUTER_PC should be set to 192.168.1.1.

    In order to enable ip forwarding between your two subnets, you can do:

    yast -> Network Services -> Ip Forwarding:

    There you will have to type the default gateway (192.168.1.1) and enable the bottom option 'Enable Ip forwarding'.

    Ip forwarding can also be enabled by manually tweaking the /proc/sys/net/ipv4/ip_forward by echoing '1' to it.
    This only will last as far as the machine is up. To make that change permanent, modify the /etc/sysctl.conf file with the equivalent parameter name, or better yet, by
    setting IP_FORWARD="yes" in the /etc/sysconfig/sysctl.

    If you are using IPv6, you will also have to set IPV6_FORWARD="yes" in the same file.

    Dont forget to run SuSEconfig after changing and saving those settings.

    Hope this help.

  3. #3
    Join Date
    Jun 2008
    Location
    Queensland, Australia
    Posts
    125

    Default Re: linuxbox as router

    Alternatively, you can set up the firewall (and you need to, if you want to run Network Address Translation = NAT = masquerading).

    Configure your router PC like this:

    In Yast -> Security, select the Firewall.

    Set eth0 as External Zone, set ath0 as internal zone. (IF you choose the option Protect Firewall from Internal Zone, you might need to open any ports needed to access other services on the router PC).

    Make sure Masquerade is set ON.

    ON the client PC, make sure that the default gateway is set to the address of ath0 on the router PC. Dont forget to also set DNS addresses. Alternatively, you could configure a basic DHCP server on the router PC (Yast -> Network Services)

    If you haven't established wireless connection between the 2 PC's, you might need to set ath0 to ad hoc mode, or access point mode, or similar.

    Hope this helps.

    Paul

  4. #4

    Default Re: linuxbox as router

    Hi carboncore and prhunt,

    Thanks for your reply. I have some problem with the Atheros driver coming out of the box with the SUSE11. I cannot set the card to Master mode.
    As soon as I fix it I'll test the solutions....

    I never tought it would be so easy .... :-)

    THANKS A LOT,
    dustin

  5. #5

    Default Re: linuxbox as router

    Ciao,

    still problems. Windows does say "limited connectivity" and doesn't connect.

    I used the firewall setup, on the ROUTER_PC:
    - eth0 (external zone) connected to the ADSLROUTER
    - ath0 (internal zone, protect firewall for internal zone disabled)
    - mascherading is active
    - redirect-request-to-masqueraded-ip list is empty
    - dhcp server active on ath0 (addresses 192.168.2.10-100, dns 192.168.1.1)

    The CLIENT_PC can connect but cannot get the ip(from dhcp). If I set the ip manually .... it still doesn't work :-(



    Do you have any idea?

  6. #6
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: linuxbox as router

    dustinspace wrote:

    >
    > Ciao,
    >
    > still problems. Windows does say "limited connectivity" and doesn't
    > connect.
    >
    > I used the firewall setup, on the ROUTER_PC:
    > - eth0 (external zone) connected to the ADSLROUTER
    > - ath0 (internal zone, protect firewall for internal zone disabled)
    > - mascherading is active
    > - redirect-request-to-masqueraded-ip list is empty
    > - dhcp server active on ath0 (addresses 192.168.2.10-100, dns
    > 192.168.1.1)
    >
    > The CLIENT_PC can connect but cannot get the ip(from dhcp). If I set
    > the ip manually .... it still doesn't work :-(
    >
    >
    >
    > Do you have any idea?
    >
    >


    Are you using the stock ATH5K atheros driver, or the MadWifi driver?

    The newer OSS Ath5k driver is still a bit raw around the edges, and I don't
    think it supports master mode yet.

    Madwifi has very good Atheros drivers available. You need to blacklist
    ath5k to use Madwifi's driver.

    Here's a page with the links and more discussion on the atheros drivers from
    Madwifi

    http://en.opensuse.org/Atheros_madwifi

    There are likely various posts about it in the forms too, search for madwifi


    --
    L R Nix
    lornix@lornix.com

  7. #7

    Default Re: linuxbox as router

    Ciao lornix,

    thanks for the tip. I'll catch the madwifi driver, and I'll let you know.


    thanks,
    Dustin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •