I have been looking around at the forum and have found a lot of helpful posts but nothing has seemed to solved my problem. I think the biggest issue may come from the fact that I have opensuse 11.0 (x86_64) and I am trying to install:

VirtualBox-1.6.2_31466_openSUSE103-1.x86_64.rpm

... which is obviously the build from SUN's website for 10.3. However I did not see an rpm for 11.0 yet. (I want the binary so that I can use USB, etc).

The most helpful post I've found yet is:
Virtualbox Install Problem - openSUSE Forums

However after following this advice I still am having issues compiling. This is what is in /var/log/vbox-install.log:

"Makefile:154: *** Error: unable to find the include directory for your current Linux kernel. Specify KERN_INCL=<directory> and run Make again. Stop."

A few notes:

1. I have VirtualBox OSE installed and was able to load the kernel module vboxdrv with no issues.
2. I uninstalled but have kept the .VirtualBox directory in my home folder (to keep my machine, settings, etc). I don't think this is the problem but it may be relevant.
3. I have tried re-installing kernel-source and make but with no success.
4. I have tried KERN_INCL=/var/path/to/include but it didn't work.

I've also tried the commands in this post to load the old kernel module... but still no dice.

Virtualbox Kernel Module - Page 2 - openSUSE Forums

Any help is appreciated. Seems this is a common problem but I have not found a solution that works for me yet.