Results 1 to 2 of 2

Thread: Jailkit install problems

  1. #1
    brizzy NNTP User

    Default Jailkit install problems

    I tried to setup Jailkit on openSuSE 10.3 but there seems to be a problem with the "/etc/" file. How should I solve this?
    Jailkit - chroot jail utilities

    $ jk_init -j /home/sftproot jk_lsh
    Copying /etc/jailkit/jk_lsh.ini to /home/sftproot/etc/jailkit/jk_lsh.ini
    ldconfig: Can't open configuration file /etc/ No such file or directory

  2. #2
    camgomez NNTP User

    Default Re: Jailkit install problems

    Got same problem with CentOS and openSUSE. Here is how I solved it:
    Added a include section to /etc/jailkit/jk_init.ini:
    executables = /sbin/ldconfig
    regularfiles = /etc/
    Then in all include sections that included the file as a regularfile, I changed them like:

    # this section probably needs adjustment on 64bit systems
    # or non-Linux systems
    # regularfiles = /etc/nsswitch.conf /etc/
    comment = common files for all jails that need user/group information
    libraries = /lib/, /lib64/, /lib/libnss*.so.2, /lib64/libnss*.so.2
    regularfiles = /etc/nsswitch.conf
    includesections = ldconfig
    This seems to solve the issue.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts