Hi,

I am running openSUSE 10.3 x86_64 on a Compaq Presario Laptop and so far have used KDE System Guard as applet in the kicker without any problems. I am very often just suspending my system and today after booting it new the System Guard did not display the CPU and memory load anymore.

I had the same behavior on a different Computer running openSUSE 10.3 i586.

When starting the application KDE System Guard I am getting the error message: "Connection to localhost has been lost". It pops up as a new message box in intervals, so I have to hurry to close them all in order to be able to shut down the application again.

In addition to the standard repositories I have included KDE:Qt44. So I am running KDE 3.5.7 "release 72.9".

In /var/log/messages I am seeing this warning related to KDE System Guard:

Code:
Jul 22 11:19:39 StCloud ksysguard[22404]: *** WARNING *** The programme 'ksysguard' uses the Apple Bonjour compatiblity layer of Avahi.
Jul 22 11:19:39 StCloud ksysguard[22404]: *** WARNING *** Please fix your application to use the native API of Avahi!
Jul 22 11:19:39 StCloud ksysguard[22404]: *** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=ksysguard>
Does anyone know whether this compatibility layer could have something to do with that?

I followed the provided link and it says to set the variable $AVAHI_COMPAT_NOWARN to 1 in order to get rid of the warning. My question is now whether getting rid of the warning really solves the problem?

Thanks for your help.