Results 1 to 5 of 5

Thread: System update failure: 'can't provide file...'

  1. #1
    Join Date
    Jun 2008
    Location
    UK; deep south, far below Watford.
    Posts
    275

    Default System update failure: 'can't provide file...'

    I am getting repeated messages like this when my OS 11 system attempts to apply security updates. I would like to know how to handle such errors in future so that I don't have to keep asking for forum assistance.

    The 'More Details' are:

    Can't provide file './suse/i586/flac-1.2.1-43.1.i586.rpm' from repository 'openSUSE-DVD 11.0'

    Why is this package missing from the repository? Why doesn't the system search inside other repositories?

    Advice please!
    They said I wasn't fit to live with a pig; my brother stood up for me and said I was.

  2. #2

    Default Re: System update failure: 'can't provide file...'

    it is looking for the file from your opensuse dvd. you should point it to a different repo.

  3. #3
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: System update failure: 'can't provide file...'

    Do you have your OpenSUSE DVD in the CD-ROM drive?

    If not, and if you can, simply inserting the DVD should solve the problem.

    If you already have the DVD in, and the problem still occurs, then you may have to direct YaST to use a different repository to install the package. After searching on the OpenSUSE Software page, the package flac can be found in the openSUSE:11.0/Standard repository. You should have that repository installed by default, but if you want to check, open a terminal window and issue the command: zypper sl. That will output all the repositories you currently have installed. Check to see if a repository with the name openSUSE:11.0/Standard is there. If not, open YaST and go to the Software sections and click Software Repositories. Once this window loads, click the Add button and select Specific URL.... Enter into the URL:
    ...And name it something like OpenSUSE 11.0 Standard, just so you know which repository you are viewing without confusion. Once you save the changes, then try the update again.

    If neither of these options work for you, please tell us.

    Hope this helps!

    Folding@Home
    Help save lives with Folding@Home

  4. #4
    Join Date
    Jun 2008
    Location
    UK; deep south, far below Watford.
    Posts
    275

    Default Re: System update failure: 'can't provide file...'

    Thanks for this most helpful and easy to follow advice.

    I did have the DVD in the drive, because that's what I thought the system was looking for, but it makes no difference. The referenced repository does not appear in the ouptut from the zypper sl command, which surprises me as I would have expected this to be a default.

    Trying to add the required repository through Yast fails with the error message:

    "Unable to create repository from URL 'index of /distribution/11.0/repo/oss'. Url scheme is a required component. Try again?"

    I am unable to understand how to handle this subsequent error condition.

    This url would never have occurred to me in a million years and I don't understand why this repsoitory is not installed. This is a new 'vanilla' installation of OS 11 about 4 days old to which I have made no repository changes
    They said I wasn't fit to live with a pig; my brother stood up for me and said I was.

  5. #5
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: System update failure: 'can't provide file...'

    Sorry, the quote tag made the repository URL into a link.

    The correct repository is...

    Code:
    http://download.opensuse.org/distribution/11.0/repo/oss/

    Folding@Home
    Help save lives with Folding@Home

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •