Results 1 to 5 of 5

Thread: alt-intl Keyboard Laout Doesn't Work Right

  1. #1

    Default alt-intl Keyboard Laout Doesn't Work Right

    I'm using the us alt-intl keyboard layout on my openSUSE 11.0 install here, but I've noticed something odd. The layout should behavee like shown on this website, but it doesn't. I can get the accented characters normally, by pressing [apostrophe][letter]. but I can't get other letters like I should be able to. For example, I should be able to press [right alt][p] and get [], but instead I found that I have to press [right alt][shift][;], then press [p] to get that. Does openSUSE have some sort of alternative implementation of the alt layout, or am I missing something?

    Thanks,
    Dan

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,611

    Default Re: alt-intl Keyboard Laout Doesn't Work Right

    As far as I am aware, keyboard layouts are quite different on Linux. To get German accents, I have the German keyboard installed and switch to and from it as required. Alternatively, within KWord and OpenOffice you can Insert > Special Character.

    In KDE go to Control Centre (KDE3.5) or System Settings (KDE4).

  3. #3

    Default Re: alt-intl Keyboard Laout Doesn't Work Right

    I suppose that would be the problem. Is there a site that lists the keyboard map for the different layouts then? I don't mind a different setup necessarily as long as I can do the same things in one way or another.

    -Dan

  4. #4
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,611

    Default Re: alt-intl Keyboard Laout Doesn't Work Right

    I'm not aware of a site; I simply loaded them and created my own maps of the layouts.

    The main differences between the UK English and the German keyboards are that colon and semicolon are Shift-full stop and Shift-comma respectively; u-umlaut is next to P and the braces/square brackets are accessed by Alt-Gr over 7-0. o-umlaut and a-umlaut are next to L and apostrophe moves to Shift-#.

    Doppel-s is next to zero or Alt-Gr-s.

    I haven't bothered to learn every difference because it is so easy to click on the flag-icon to get back to my standard layout.

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: alt-intl Keyboard Laout Doesn't Work Right

    > The layout should behavee like shown on 'this website'
    > (http://www.usna.edu/LangStudy/US-Int...nalLayout.html)


    no, a Linux machine should _not_ behave that way because the top of that
    page says "_*Windows*_ United States-International Keyboard
    Layout"...which means, using a keyboard purchased in the USA (or maybe
    also Canada) AND using Microsoft Windows(tm)...and we know that Linux is
    not Windows <http://linux.oneandoneis2.org/LNW.htm>..

    if you purchase a keyboard in another country with country specific keys
    OR use a different operating system OR select a different country
    specific keyboard driver, that page is useless to you..

    sorry, i do NOT know where to find a similar page showing the keyboard
    mapping for using a United States-International Keyboard, using a
    US-English keyboard driver and Linux or openSuSE Linux in....perhaps
    google can help you find one..

    another way is to experiment and figure out what happens when you press
    what....and, write it down on your own keyboard map...(i had to do that
    once when using a standard USA keyboard with a danish driver...then i
    wrote the additional marks letters etc on the key with a fine pencil and
    covered that with clear tape..)

    --
    DenverD (Linux Counter 282315)
    A Texan in Denmark

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •