Results 1 to 6 of 6

Thread: AR242 Wlan card problem

  1. #1

    Unhappy AR242 Wlan card problem

    Greetings!

    I am a beginner in Linux, and recently changed to OpenSUSE from Kubuntu on my Asus F2HF notebook. My problem is that my Wlan what worked with Kubuntu, works not with OpenSUSE so far.

    It says that it is unable to configure it because "kernel device (eth0, wlan0) is not present." And suggest that this maybe caused by missing firmware. I tried to search firmware for my card without result. I tried to install all firmware package I found, without result.

    All I know about my wlan is the name YaST2 shows:
    AR242x 802.11abg Wireless PCI Adapter


    I am thankful for any help.

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: AR242 Wlan card problem

    Whenever you have a problem like this, you should open a terminal and enter the
    command

    dmesg | less

    This will let you see the messages that have been logged since bootup. If you
    don't know less, page up/down and the up/down arrow keys will move you through
    the listing. The space bar will get you a new page and q will quit. Look through
    the listing looking for messages that pertain to your wireless. If there is
    missing firmware, it will show up there.

    Larry

  3. #3
    xerxes22 NNTP User

    Default Re: AR242 Wlan card problem

    Hello, I'm new to openSUSE 11.0, installed it on my MSI notebook,
    and now everything works meanwhile except the
    AR242x802.11abg wlan.
    ok, I followed the instructions to install the madwifi-hal-0.10.5.6 driver I found on forum.ubuntuusers.de:

    wget http://snapshots.madwifi.org/madwifi...0080716.tar.gz
    tar xzf madwifi-hal-0.10.5.6-r3772-20080716.tar.gz
    cd madwifi-hal-0.10.5.6-r3772-20080716
    cd scripts
    sudo ./madwifi-unload
    sudo ./find-madwifi-modules.sh $(uname -r)
    cd ../
    make
    sudo make install
    echo ath_pci | sudo tee -a /etc/modules
    sudo modprobe ath_pci

    Problem: them make command produced the following output:
    Makefile.inc:91: *** KERNELCONF: /lib/modules/2.6.25.9-0.2-pae/build/.config does not exist.. Schluss.

    Can anybody help me please ?
    Last edited by xerxes22; 21-Jul-2008 at 19:56. Reason: forgot to add version-info

  4. #4
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: AR242 Wlan card problem

    @xerxes22
    You would be better starting your own topic. Your problem is different from the OP. Having your own topic would ensure it gets a response which should help

    Andy
    To be is to do = Immanuel Kant
    To do is to be = Descartes.
    Do be do be do = Frank Sinatra

    SuSE user since 7.0,Linux user since 1994

  5. #5

    Default Re: AR242 Wlan card problem

    Larry, thanks for trying help!

    I found nothing about my wlan card - I mean I found in the dmesg listing my ethernet , but simply no any mentioning of the wireless...
    The only interesting lines I found were these:

    ACPI: I/O resource 0000:00:1f.3 [0x400-0x41f] conflicts with ACPI region SMBO [0x400-0x40f]
    ACPI: Device needs an ACPI driver


    There was a suggestion in the list:
    "ACPI: If a device doesn't work, try "pci=routeirq". If it helps, post a report"

    I tried but it has no effect.

  6. #6

    Question Re: AR242 Wlan card problem

    I tried to search the net. I found that many other people had problems with this wlan card. Unfortunately it is designed for Windows...

    I found this site too (originally portugese):
    Translated version of http://ubuntuforum-br.org/index.php?topic=36669.0
    But I have no idea if it has any useful information, thought it is Ubuntu forum.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •