Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Help me get my external mic to work?

  1. #1

    Default Help me get my external mic to work?

    I'm running 11.0 x86_64. The Pulse Audio Volume control has only one input source, and that is the built-in microphone. The same is true for alsamixer. I need to add the external mic, or at a minimum, replace the internal mic with the external mic in the mixer. How do I do that?

    The computer is a Dell D820. Sound was working well under 10.3.

    Thanks!

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,550
    Blog Entries
    37

    Default Re: Help me get my external mic to work?

    Quote Originally Posted by JJMT View Post
    I'm running 11.0 x86_64. The Pulse Audio Volume control has only one input source, and that is the built-in microphone. The same is true for alsamixer. I need to add the external mic, or at a minimum, replace the internal mic with the external mic in the mixer. How do I do that?

    The computer is a Dell D820. Sound was working well under 10.3.

    Thanks!
    Typically the biggest mistake is one has their mixer misconfigured. Your post suggests you don't have the mixer options? Also, a screen dump of your desktop/mixer setting (and paste it to ImageShack® - Image Hosting ) would give us a better idea as to what you mean.

    With your Dell D820 connected to the internet can you run a diagnostic script that will post information on your laptop's hardware/software audio configuration to a pastebin site? Specifically, copy and paste the following line to a konosle:
    Code:
    wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa'
    When prompted for a password enter the root password. When it is complete it will give you a URL. Please paste that URL here.

    Also, please run the following commands in a konsole and paste their output here:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound


    With that information, I may be able to make a recommendation that will help.

  3. #3

    Default Re: Help me get my external mic to work?

    OK. The requested url is here:

    tsalsa.txt - nopaste.com (beta)

    Also:

    Code:
    rpm -qa | grep alsa
    alsa-plugins-1.0.16-57.1
    alsa-utils-1.0.16-35.1
    alsa-devel-1.0.16-39.1
    alsa-plugins-pulse-32bit-1.0.16-57.1
    alsa-oss-1.0.15-48.1
    alsa-1.0.16-39.1
    alsa-oss-32bit-1.0.15-48.1
    alsa-plugins-32bit-1.0.16-57.1
    alsa-plugins-pulse-1.0.16-57.1
    and
    Code:
    rpm -qa | grep pulse
    pulseaudio-0.9.10-26.3
    libpulsecore4-0.9.10-26.3
    libao-pulse-0.9.3-123.1
    libpulse-mainloop-glib0-0.9.10-26.3
    pulseaudio-esound-compat-0.9.10-26.3
    pulseaudio-utils-0.9.10-26.3
    pulseaudio-module-gconf-0.9.10-26.3
    gstreamer-0_10-pulse-0.9.7-42.pm.1
    libpulse0-32bit-0.9.10-26.3
    pulseaudio-module-lirc-0.9.10-26.3
    alsa-plugins-pulse-32bit-1.0.16-57.1
    libpulse-browse0-0.9.10-26.3
    pulseaudio-module-zeroconf-0.9.10-26.3
    xmms-pulse-0.9.4-0.pm.1
    libpulse0-0.9.10-26.3
    pulseaudio-module-bluetooth-0.9.10-26.3
    pulseaudio-module-x11-0.9.10-26.3
    alsa-plugins-pulse-1.0.16-57.1
    and

    Code:
    rpm -q libasound2
    libasound2-1.0.16-39.1
    and

    Code:
    uname -a
    Linux linux-rzvr 2.6.25.9-0.2-default #1 SMP 2008-06-28 00:00:07 +0200 x86_64 x86_64 x86_64 GNU/Linux
    and finally,

    Code:
    cat /etc/modprobe.d/sound
    
    options snd slots=snd-hda-intel
    options snd-hda-intel model=auto
    # u1Nb.Md5aHihV0PD:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel
    Hope this helps.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,550
    Blog Entries
    37

    Default Re: Help me get my external mic to work?

    Quote Originally Posted by JJMT View Post
    Thanks!! That saves me asking a lot of questions. It tells me your Dell 820 has a STAC9200.

    Quote Originally Posted by JJMT View Post
    [CODE]rpm -qa | grep alsa
    I don't see alsa-firmware installed. I don't know if it is needed, but it definitely does not hurt to install. Can you install it? (and then reboot).

    Quote Originally Posted by JJMT View Post
    Code:
    cat /etc/modprobe.d/sound
    
    options snd slots=snd-hda-intel
    options snd-hda-intel model=auto
    # u1Nb.Md5aHihV0PD:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel
    The value of "basic" in the /etc/modprobe.d/sound file is the old way, that one finds on all the laptop internet sites. But if one looks at the alsa documentation in the ALSA-Configuration.txt file, one finds:
    Code:
    	STAC9200
    	  ref		Reference board
    	  dell-d21	Dell (unknown)
    	  dell-d22	Dell (unknown)
    	  dell-d23	Dell (unknown)
    	  dell-m21	Dell Inspiron 630m, Dell Inspiron 640m
    	  dell-m22	Dell Latitude D620, Dell Latitude D820
    	  dell-m23	Dell XPS M1710, Dell Precision M90
    	  dell-m24	Dell Latitude 120L
    	  dell-m25	Dell Inspiron E1505n
    	  dell-m26	Dell Inspiron 1501
    	  dell-m27	Dell Inspiron E1705/9400
    	  gateway	Gateway laptops with EAPD control
    Which suggests to me that "basic" no longer exists for the STAC9200 and that "dell-m22" is the model option to use. So can you change your /etc/modprobe.d/sound file to:
    Code:
    options snd slots=snd-hda-intel
    options snd-hda-intel model=dell-m22
    # u1Nb.Md5aHihV0PD:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel
    and either reboot, or restart your sound with "rcalsasound restart" and check to see if your mixer has improved.

  5. #5

    Default Re: Help me get my external mic to work?

    OK. I now have:

    Code:
    rpm -qa | grep alsa
    alsa-plugins-1.0.16-57.1
    alsa-utils-1.0.16-35.1
    alsa-devel-1.0.16-39.1
    alsa-plugins-pulse-32bit-1.0.16-57.1
    alsa-oss-1.0.15-48.1
    alsa-1.0.16-39.1
    alsa-oss-32bit-1.0.15-48.1
    alsa-plugins-32bit-1.0.16-57.1
    alsa-firmware-1.0.16-24.1
    alsa-plugins-pulse-1.0.16-57.1
    and

    Code:
    cat /etc/modprobe.d/sound
    
    options snd slots=snd-hda-intel
    options snd-hda-intel model=dell-m22
    # u1Nb.Md5aHihV0PD:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel
    but I still have only one input source in both the pulse mixer and the alsa mixer.

    Any more ideas?

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,550
    Blog Entries
    37

    Default Re: Help me get my external mic to work?

    Quote Originally Posted by JJMT View Post
    I still have only one input source in both the pulse mixer and the alsa mixer.

    Any more ideas?
    How about what I asked in an earlier post? (so to have a better indication as to what you are seeing)?
    Quote Originally Posted by oldcpu View Post
    Typically the biggest mistake is one has their mixer misconfigured. Your post suggests you don't have the mixer options? Also, a screen dump of your desktop/mixer setting (and paste it to ImageShack - Image Hosting ) would give us a better idea as to what you mean.

  7. #7

    Default Re: Help me get my external mic to work?

    Quote Originally Posted by oldcpu View Post
    How about what I asked in an earlier post? (so to have a better indication as to what you are seeing)?
    Well, this is what I'm seeing:

    ImageShack - Hosting :: 56934464ya7.jpg

    I don't fully understand the question about whether I have mixer options or not.

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,550
    Blog Entries
    37

    Default Re: Help me get my external mic to work?

    Quote Originally Posted by JJMT View Post
    Well, this is what I'm seeing:
    ImageShack - Hosting :: 56934464ya7.jpg
    Interesting ... I have immediate access to two PCs, one with openSUSE-10.3(KDE-3.5.7) and one with openSUSE-11.0(KDE-3.5.9) and I don't have such a pulse audio mixer. Thats the first I've seen of it. I suspect it is for openSUSE-11.0 Gnome or KDE4 desktops.

    I assume you rebooted like I suggested? (after installing alsa-firmware and changing the model assignment in your /etc/modprobe.d/sound file).

    Pulse audio, like KDE4, is IMHO still relatively immature. It could be the lack of maturity of pulse audio in handling the case associated with your audio card is causing this .... Hence one approach would be to remove pulse audio! making a note of everything you removed. Then see if your alsa-mixer provides more options.

    I did a surf on the alsa web site for stac (yours is a stac9200) and came up with this: Search results - AlsaProject
    Code:
    Changes v1.0.16 v1.0.17 (325,143 bytes)
    292: : hda-codec - Add missing descriptions for STAC codec models
    which does not seem to relate you your problem. Still, you could always try to update your alsa to 1.0.17 and you can always revert to the older 1.0.16 if 1.0.17 does not work for you. There is guidance here:
    Alsa-update - openSUSE
    Note there are 6 zypper commands you would need to send. And note you need to restart your PC after updating alsa. I don't really hold much hope that will work, but I guess it doesn't hurt to try. Note the 2nd zypper command (that installs alsa, alsa-utils, alsa-firmware, ... etc) could have more alsa apps added to match what you currently have installed (ie to update all applicable). If you elect to keep pulse audio, you could also update pulse audio from that repos:
    Code:
    http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.0/
    ... note those are state of the art, cutting edge rpms, and hence prone to bugs, so pay attention to what you install so you can undo later if need be.

    The command "rpm -qa --last" can always help there (to see what was recently installed).

    I also note there are some pulse/pulse-audio updates available from the nominal OSS repos (and Main Update) repos that you may wish to try first, before you try anything!

  9. #9

    Default Re: Help me get my external mic to work?

    Yes, it is gnome. Guess I should have mentioned that before, eh?

    Yes, I have rebooted after every change.

    I'm a bit puzzled by the focus on alsa, as alsa has been working on this computer for several versions. Under SuSE 10.3, for example, the alsamixer had a combination of sliders and switches that worked just fine.

    The issue here seems to be pulse, and I simply don't know anything about pulse. But if alsa mixer is getting to the sound hardware through pulse (note: chip and sound card are listed as PulseAudio in alsamixer), then it seems that pulse isn't interfacing with the hardware correctly. I don't see how changing alsa is going to affect what I see in the "PulseAudio Volume Control".

    As (perhaps) confirmation, this is what pulse sees of the hardware:

    ImageShack - Hosting :: pulsecd3.jpg

    So it seems that the best bet is to remove pulse. I guess I'll think about it for a bit before I go that route......

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,550
    Blog Entries
    37

    Default Re: Help me get my external mic to work?

    Quote Originally Posted by JJMT View Post
    I'm a bit puzzled by the focus on alsa, as alsa has been working on this computer for several versions. Under SuSE 10.3, for example, the alsamixer had a combination of sliders and switches that worked just fine.

    The issue here seems to be pulse, and I simply don't know anything about pulse. But if alsa mixer is getting to the sound hardware through pulse (note: chip and sound card are listed as PulseAudio in alsamixer), then it seems that pulse isn't interfacing with the hardware correctly. I don't see how changing alsa is going to affect what I see in the "PulseAudio Volume Control".
    I wrote up my understanding of the audio concepts here in a wiki:
    Sound-concepts - openSUSE
    ... I'm hoping that will get corrected by those who know better. So either it is so far out to lunch its a hopeless case to update, or I'm not too far off.

    Reference your post, I don't think alsa is getting at audio via pulse. Its the other way around.

    My understanding is that Alsa provides hardware drivers and an API. But KDE and Gnome typically don't use the alsa API fully, but rather provide their own. KDE3 provides aRts which has an API that interfaces direct to alsa hardware drivers (mostly bypassing the alsa API), and Gnome provides ESD which has an API that interfaces to alsa hardware drivers (mostly bypassing the alsa API). ie they mostly ignore the alsa API. Some applications (such as xine and mplayer) can ignore ESD and aRts, and interface to the alsa hardware drivers. And other applications can ignore ESD and aRts and interface to the alsa API.

    So if that reads like anarchy, ... well ... it is

    Pulseaudio is intended to replace ESD in Gnome.

    The reason for PulseAudio is it adds features that Linux did not have before (but winXP and Vista, to a certain extent, had the features). The idea is to make Linux audio more competitive.

    But Pulse audio is buggy.

    If it were me, I would try in the order of a-to-c:
    a. updates on OSS / Main Update to pulse audio, and test sound/mic, then if that did not work;
    b. updates to pulse audio on the "cutting edge" repos I provided, together with alsa updates, then if that did not work,
    c. remove pulse audio (playing close attention to what I removed so I could install it again).

    Because I don't have pulse audio installed much in KDE-3.5.9, I can't provide specific guidance.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •