Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Updater & Yast = NO Updates? Yum = 100's of updates!

  1. #1

    Default Updater & Yast = NO Updates? Yum = 100's of updates!

    I have Opensuse 11 installed for at least 10 days now.
    The only update I had was after the initial setup when I allowed it my information and it added the update repos to my list.
    Since then, my updater applet which is set to check every 24 hours, never had an update! And I have KDE 4 (as well as 3.59 AND Gnome) installed!
    The queer thing is that today I decided to give my good old Redhat updater, Yum, a try. I installed Yum via YaST as well as the plugin to check the base only. Then #"yum update" and it found hundreds (if not more) of pkg's to update, but (luckily I think) it failed due to a missing dependency.

    Can anyone please advise as to what's going on?
    Thank you much.
    nat
    ps. here is a snapshot image of my repos.
    Picasa Web Albums - natG - Public Album-1

  2. #2

    Default Re: Updater & Yast = NO Updates? Yum = 100's of updates!

    Perhaps Yum is suggesting software updates from Pacman and videolan repositories, while the KDE4 (and KDE3) updater suggests only security patches and important updates that appear in the update repository. The gnome updater (packagekit) will likewise turn green showing software updates from 3rd party repositories but will turn orange for recommended updates and red if there are important security patches. You may configure the KDE updater to show 3rd party updates as well. To do this right click on the applet and select configure Applet. Now turn on the option that says: Show available upgrades when backend provides them. Now you should see some upgrade notification from the applet.

  3. #3
    Join Date
    Jan 2008
    Location
    Kenton, TN USA
    Posts
    1,023

    Default Re: Updater & Yast = NO Updates? Yum = 100's of updates!

    Thread moved to Applications
    opensuse.org.help.applications
    Last edited by kastorff; 20-Jul-2008 at 18:21.
    Keith Kastorff

  4. #4

    Default Re: Updater & Yast = NO Updates? Yum = 100's of updates!

    Perhaps Yum is suggesting software updates from Pacman and videolan repositories...
    I have the plugin "basearchonly" installed. Yum checks the base repo only.

    Guess what? Just now the kde updater (actually it sais "Opensuse 11 updater") applet announced that there is one new update, an update to the updater itself. After installing that, it complained and advised me to do a "zypper refresh", which I did.
    Now, the updater did indeed find updates, and installed them ok.
    So this seems ok.
    But... back to Yum. Besides the obvious question why is Yum finding so many things to update that the Suse/Kde updater is not, even after the aforementioned update via the new updater, yum is actually failing its own update due to problems in... YaST!!
    So, it seems that I have to fix YaST as well.
    On my next post in this thread I shall post the entire yum output.
    -nat

  5. #5

    Default Re: Updater & Yast = NO Updates? Yum = 100's of updates!

    Actually I'm having a problem posting the entire yum output due to this forum's message limit of 'only' 10,000 characters. So, I'll try snippets of the output.
    Code:
    phenom9600:~ # yum update
    Loaded plugins: basearchonly
    Setting up Update Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package gtk-vnc.i586 0:0.3.6-7 set to be updated
    ---> Package virt-manager.i586 0:0.5.3-31 set to be updated
    ---> Package freeglut.i586 0:060903-139 set to be updated
    ---> Package libgssglue1.i586 0:0.1-5 set to be updated
    ---> Package perl-gettext.i586 0:1.05-117 set to be updated
    ---> Package mlterm.i586 0:2.9.3.20071112-94 set to be updated
    ---> Package iputils.i586 0:ss021109-270 set to be updated
    ---> Package gnome-media.i586 0:2.23.3-9 set to be updated
    ---> Package libgtop.i586 0:2.23.2-5 set to be updated
    ---> Package kaffeine-lang.i586 0:0.8.7-5 set to be updated
    ---> Package grub.i586 0:0.97-134 set to be updated
    ---> Package cyrus-sasl.i586 0:2.1.22-146 set to be updated
    ---> Package libkcal2.i586 0:3.5.9-63 set to be updated
    ---> Package intlfnts.noarch 0:1.2.1-377 set to be updated
    ---> Package opensp.i586 0:1.5.2-71 set to be updated
    ---> Package yast2-apparmor.noarch 0:2.17.0-10 set to be updated
    ---> Package libwpd-0_8-8.i586 0:0.8.14-3 set to be updated
    ---> Package info.i586 0:4.12-5 set to be updated
    ---> Package OpenOffice_org-templates-labels-letter.noarch 0:1.0-18 set to be updated
    ---> Package xorg-x11-libXv.i586 0:7.3-56 set to be updated
    ---> Package yast2-qt.i586 0:2.17.4-4 set to be updated
    ---> Package ntp.i586 0:4.2.4p4-52 set to be updated
    ---> Package kdepim3.i586 0:3.5.9-63 set to be updated
    ---> Package libdjvulibre15.i586 0:3.5.20-58 set to be updated
    ---> Package finger.i586 0:1.3-123 set to be updated
    ---> Package libflashsupport.i586 0:000-76 set to be updated
    ---> Package yast2-control-center-qt.i586 0:2.16.2-18 set to be updated
    ---> Package cron.i586 0:4.1-177 set to be updated
    ---> Package libkonq5.i586 0:4.0.99-2 set to be updated
    ---> Package vcdimager.i586 0:0.7.23-137 set to be updated
    ---> Package sax2.i586 0:8.1-464 set to be updated
    ---> Package psmisc.i586 0:22.6-35 set to be updated
    ---> Package opensuse-codecs-installer.noarch 0:10.3.1-51 set to be updated
    ---> Package gnome-system-monitor.i586 0:2.23.3-11 set to be updated
    ---> Package vim-data.i586 0:7.1-135 set to be updated
    ---> Package perl-Bootloader.i586 0:0.4.64-3 set to be updated
    ---> Package liblazy1.i586 0:0.2-44 set to be updated
    ---> Package libquicktime.i586 0:1.0.3-5 set to be updated
    ---> Package libgnomesu-lang.i586 0:1.0.0-259 set to be updated
    ---> Package multisync-gui.i586 0:0.91.0-204 set to be updated
    ---> Package gnome-settings-daemon-lang.i586 0:2.23.4-9 set to be updated
    ---> Package libgnomeui-lang.i586 0:2.23.4-8 set to be updated
    ---> Package gle.i586 0:3.1.0-95 set to be updated
    ---> Package python-compizconfig.i586 0:0.7.6-12 set to be updated
    ---> Package gnutls.i586 0:2.2.2-24 set to be updated
    --> Processing Dependency: libopencdk.so.10 for package: gnutls
    ---> Package libakonadi4.i586 0:4.0.99-2 set to be updated
    ---> Package galago-sharp.noarch 0:0.5.0-251 set to be updated
    ---> Package sgml-skel.noarch 0:0.6-394 set to be updated
    ---> Package kde4-kgamma.i586 0:4.0.99-2 set to be updated
    ---> Package fontconfig.i586 0:2.4.2-95 set to be updated
    ---> Package fonts-config.noarch 0:20080121-31 set to be updated
    ---> Package libgthread-2_0-0.i586 0:2.17.2-4 set to be updated
    ---> Package digikamimageplugins-superimpose.i586 0:0.9.3-88 set to be updated
    ---> Package poppler-data.noarch 0:0.2.0-18 set to be updated
    ---> Package nautilus-sendto.i586 0:0.13.2-66 set to be updated
    ---> Package yast2-mail.noarch 0:2.16.6-15 set to be updated
    ---> Package yast2-bootloader.i586 0:2.17.3-3 set to be updated
    ---> Package libopensc2.i586 0:0.11.4-46 set to be updated
    ---> Package perl-File-Tail.i586 0:0.99.3-114 set to be updated
    ---> Package libpisock9.i586 0:0.12.2-121 set to be updated
    ---> Package bootcycle.i586 0:0.3-213 set to be updated
    ---> Package dasher.i586 0:4.9.0-8 set to be updated
    ---> Package nmap.i586 0:4.60-27 set to be updated
    ---> Package libsensors3.i586 0:2.10.6-24 set to be updated
    ---> Package perl-XML-Parser.i586 0:2.36-39 set to be updated
    ---> Package xterm.i586 0:235-20 set to be updated
    ---> Package kdebase4-nsplugin.i586 0:4.0.99-2 set to be updated
    ---> Package libqt4-sql.i586 0:4.4.0-23 set to be updated
    --> Processing Dependency: libcomphelp4gcc3.so for package: OpenOffice_org-gnome
    --> Processing Dependency: libcomphelp4gcc3.so for package: OpenOffice_org-kde
    --> Processing Dependency: libcomphelp4gcc3.so for package: OpenOffice_org-math
    --> Processing Dependency: libcomphelp4gcc3.so for package: OpenOffice_org-writer
    ...
    ...
    ---> Package netcat.i586 0:1.10-985 set to be updated
    ---> Package gnome-utils-lang.i586 0:2.20.0.1-127 set to be updated
    ---> Package libltdl-3.i586 0:1.5.26-28 set to be updated
    ---> Package avahi-lang.i586 0:0.6.23-2 set to be updated
    ---> Package libwnck-lang.i586 0:2.23.4-7 set to be updated
    ---> Package pulseaudio-module-zeroconf.i586 0:0.9.11-2 set to be updated
    ---> Package eog-lang.i586 0:2.23.4.1-10 set to be updated
    ---> Package vim.i586 0:7.1-135 set to be updated
    ---> Package alsa-plugins.i586 0:1.0.17-4 set to be updated
    ---> Package desktop-file-utils.i586 0:0.15-44 set to be updated
    ---> Package libMagickCore1.i586 0:6.4.0.4-27 set to be updated
    ---> Package enchant.i586 0:1.4.2-11 set to be updated
    ---> Package gnome-speech.i586 0:0.4.20-6 set to be updated
    ---> Package libkdepimlibs4.i586 0:4.0.99-2 set to be updated
    ---> Package dcraw.i586 0:1.401-17 set to be updated
    ---> Package filesystem.i586 0:11.0.42-9 set to be updated
    ---> Package libbonobo.i586 0:2.23.0-6 set to be updated
    ---> Package docbook_4.noarch 0:4.5-89 set to be updated
    ---> Package openssl.i586 0:0.9.8h-6 set to be updated
    ---> Package kde4-korganizer.i586 0:4.0.85-4 set to be updated
    ---> Package compizconfig-settings-manager.i586 0:0.7.6-13 set to be updated
    ---> Package gnome-panel-lang.i586 0:2.23.3-11 set to be updated
    ---> Package f-spot.i586 0:0.4.3.1-29 set to be updated
    ---> Package gtk2.i586 0:2.13.3-8 set to be updated
    ---> Package evolution-pilot.i586 0:2.23.4-11 set to be updated
    ---> Package yast2-hardware-detection.i586 0:2.16.1-58 set to be updated
    ---> Package binutils.i586 0:2.18.50.20080718-2 set to be updated
    ---> Package screen.i586 0:4.0.2-170 set to be updated
    ---> Package kdebase3.i586 0:3.5.9-76 set to be updated
    ---> Package mono-addins.noarch 0:0.3.1-45 set to be updated
    ---> Package xorg-x11-driver-video.i586 0:7.3-151 set to be updated
    ---> Package perl-spamassassin.i586 0:3.2.5-3 set to be updated
    ---> Package libgnome.i586 0:2.23.4-9 set to be updated
    ---> Package ulimit.noarch 0:1.1-252 set to be updated
    ---> Package syslog-ng.i586 0:1.6.12-79 set to be updated
    ---> Package mono-data-sqlite.i586 0:1.9.1-11 set to be updated
    ---> Package mpt-status.i586 0:1.2.0-145 set to be updated
    ---> Package samba-client.i586 0:3.2.0-28 set to be updated
    ---> Package libpoppler-qt4-3.i586 0:0.8.2-3 set to be updated
    ---> Package libraw1394-8.i586 0:1.3.0-20 set to be updated
    ---> Package libgail-gnome.i586 0:1.20.0-119 set to be updated
    ---> Package yp-tools.i586 0:2.9-119 set to be updated
    ---> Package dos2unix.i586 0:3.1-418 set to be updated
    ---> Package freefont.noarch 0:0.20080323-9 set to be updated
    ---> Package numlockx.i586 0:1.1-138 set to be updated
    ---> Package xorg-x11-libxkbfile.i586 0:7.3-55 set to be updated
    ---> Package apparmor-utils.noarch 0:2.3-19 set to be updated
    ---> Package yast2-update.i586 0:2.16.10-16 set to be updated
    ---> Package gftp.i586 0:2.0.18-214 set to be updated
    ---> Package libgalago.i586 0:0.5.2-121 set to be updated
    ---> Package pulseaudio-module-x11.i586 0:0.9.11-2 set to be updated
    ---> Package kio_beagle.i586 0:0.3.1-210 set to be updated
    ---> Package rsvg-view.i586 0:2.22.2-45 set to be updated
    ---> Package dbus-1-glib.i586 0:0.76-6 set to be updated
    ---> Package postfix.i586 0:2.5.1-36 set to be updated
    ---> Package pptp.i586 0:1.7.2-5 set to be updated
    ---> Package liboil.i586 0:0.3.14-24 set to be updated
    ---> Package samba-winbind.i586 0:3.2.0-28 set to be updated
    ---> Package kdebase4-workspace.i586 0:4.0.99-2 set to be updated
    --> Processing Dependency: libQtWebKit.so.4 for package: kdebase4-workspace
    ---> Package libjpeg.i586 0:6.2.0-857 set to be updated
    ---> Package perl-Digest-HMAC.i586 0:1.01-608 set to be updated
    ---> Package gettext-runtime.i586 0:0.17-45 set to be updated
    ---> Package kdebluetooth.i586 0:1.0_beta8-121 set to be updated
    ---> Package perl-IO-Socket-SSL.i586 0:1.13-35 set to be updated
    ---> Package gnome-pilot-lang.i586 0:2.0.16-41 set to be updated
    ---> Package iptables.i586 0:1.4.0-46 set to be updated
    ---> Package cabextract.i586 0:1.2-99 set to be updated
    ---> Package bluez-gnome-lang.i586 0:0.27-3 set to be updated
    ---> Package slang.i586 0:2.1.1-60 set to be updated
    ---> Package alsa-utils.i586 0:1.0.17-3 set to be updated
    ---> Package banshee-1-backend-platform-unix.i586 0:1.0.0-16 set to be updated
    ---> Package PolicyKit-gnome.i586 0:0.8-6 set to be updated
    ---> Package notification-daemon-lang.i586 0:0.3.7-149 set to be updated
    ---> Package kde4-kaddressbook.i586 0:4.0.85-4 set to be updated
    ---> Package libbz2-1.i586 0:1.0.5-18 set to be updated
    ---> Package beagle-firefox.i586 0:0.3.7-35 set to be updated
    ---> Package kdebase4-openSUSE-lang.i586 0:11.1-9 set to be updated
    More in next post....

  6. #6

    Default Re: Updater & Yast = NO Updates? Yum = 100's of updates!

    continued.... (Many portions snipped out.)
    Code:
    ---> Package mozilla-xulrunner190.i586 0:1.9.0-8 set to be updated
    ---> Package coreutils.i586 0:6.12-6 set to be updated
    ---> Package libieee1284.i586 0:0.2.11-4 set to be updated
    ---> Package planner-lang.i586 0:0.14.2-153 set to be updated
    ---> Package digikamimageplugins.i586 0:0.9.3-88 set to be updated
    ---> Package branding-openSUSE.noarch 0:11.0-18 set to be updated
    ---> Package yast2-ldap-client.noarch 0:2.17.1-2 set to be updated
    ---> Package opensuse-kde3user_en.noarch 0:11.0-13 set to be updated
    ---> Package audit.i586 0:1.7.4-5 set to be updated
    ---> Package ksymoops.i586 0:2.4.11-119 set to be updated
    ---> Package libidl.i586 0:0.8.10-32 set to be updated
    ---> Package blt.i586 0:2.4z-360 set to be updated
    ---> Package kio_iso.i586 0:1.90.0-46 set to be updated
    ---> Package libkdcraw3-lang.i586 0:0.1.4-18 set to be updated
    ---> Package libext2fs2.i586 0:1.41.0-2 set to be updated
    ---> Package libuuid1.i586 0:1.41.0-2 set to be updated
    ---> Package man-pages.noarch 0:2.79-20 set to be updated
    ---> Package ufraw.i586 0:0.13-56 set to be updated
    --> Processing Dependency: libexiv2.so.4 for package: ufraw
    ---> Package yast2-irda.noarch 0:2.16.1-36 set to be updated
    ---> Package gnome-mag.i586 0:0.15.0-58 set to be updated
    ---> Package shared-mime-info.i586 0:0.23-42 set to be updated
    ---> Package deskbar-applet.i586 0:2.23.4-11 set to be updated
    --> Processing Dependency: libgnome-desktop-2.so.7 for package: deskbar-applet
    ---> Package terminfo.i586 0:5.6-85 set to be updated
    ---> Package vinagre-lang.i586 0:2.23.4-10 set to be updated
    ---> Package fbset.i586 0:2.1-897 set to be updated
    ---> Package yast2-qt-pkg.i586 0:2.17.2-6 set to be updated
    ---> Package sax2-libsax.i586 0:8.1-464 set to be updated
    ---> Package kde4-keditbookmarks.i586 0:4.0.99-2 set to be updated
    ---> Package iso_ent.noarch 0:2000.11.03-783 set to be updated
    ---> Package joe.i586 0:3.5-107 set to be updated
    ---> Package skencil.i586 0:0.6.17-234 set to be updated
    ---> Package libgluezilla0.i586 0:1.9.1-28 set to be updated
    ---> Package expat.i586 0:2.0.1-67 set to be updated
    ---> Package xdg-menu.i586 0:0.2-171 set to be updated
    ---> Package bc.i586 0:1.06-874 set to be updated
    ---> Package libcap2.i586 0:2.10-2 set to be updated
    ---> Package liblua5_1.i586 0:5.1.3-27 set to be updated
    ---> Package desktop-data-openSUSE-extra-gnome.noarch 0:11.0.1-33 set to be updated
    ---> Package bundle-lang-kde-en.noarch 0:11.0-145 set to be updated
    ---> Package libzypp.i586 0:5.1.1-3 set to be updated
    ---> Package digikam-lang.i586 0:0.9.3-88 set to be updated
    ---> Package lsof.i586 0:4.79-14 set to be updated
    ---> Package gedit.i586 0:2.23.1-11 set to be updated
    ---> Package cairo.i586 0:1.6.4-6 set to be updated
    ---> Package yast2-pkg-bindings.i586 0:2.17.1-8 set to be updated
    ---> Package login.i586 0:3.36-8 set to be updated
    ---> Package libatk-1_0-0.i586 0:1.22.0-29 set to be updated
    ---> Package file-roller-lang.i586 0:2.23.3-11 set to be updated
    ---> Package libneon27.i586 0:0.28.2-23 set to be updated
    ---> Package kitchensync.i586 0:3.5.9-63 set to be updated
    ---> Package libcdio_cdda0.i586 0:0.80-6 set to be updated
    ---> Package bundle-lang-common-en.noarch 0:11.0-133 set to be updated
    ---> Package gnome-python-desktop.i586 0:2.23.0-10 set to be updated
    ---> Package speex.i586 0:1.1.99.3-33 set to be updated
    ---> Package gtk2-engines.i586 0:2.15.1-9 set to be updated
    ---> Package libxml2.i586 0:2.6.32-16 set to be updated
    ---> Package gconf-editor.i586 0:2.22.0-39 set to be updated
    ---> Package libattr.i586 0:2.4.39-45 set to be updated
    ---> Package awesfx.i586 0:0.5.1a-64 set to be updated
    ---> Package cracklib.i586 0:2.8.12-31 set to be updated
    ---> Package libGraphicsMagick1.i586 0:1.1.11-36 set to be updated
    ---> Package kdeutils3.i586 0:3.5.9-60 set to be updated
    ---> Package evolution-data-server.i586 0:2.23.4-8 set to be updated
    ---> Package OpenOffice_org-l10n-en-US.noarch 0:2.99.25-2 set to be updated
    ---> Package kdenetwork3.i586 0:3.5.9-47 set to be updated
    ---> Package sane-backends.i586 0:1.0.19-59 set to be updated
    ---> Package cheese.i586 0:2.23.4-11 set to be updated
    ---> Package libncurses5.i586 0:5.6-85 set to be updated
    ---> Package id3lib.i586 0:3.8.3-214 set to be updated
    ---> Package netcfg.noarch 0:11.0.42-4 set to be updated
    ---> Package totem-pl-parser-lang.i586 0:2.23.2-8 set to be updated
    ---> Package ncurses-utils.i586 0:5.6-85 set to be updated
    ---> Package libreiserfs.i586 0:0.3.0.5-121 set to be updated
    ---> Package yelp.i586 0:2.23.1-10 set to be updated
    ---> Package aspell.i586 0:0.60.5-90 set to be updated
    ---> Package ekiga-lang.i586 0:2.0.12-39 set to be updated
    ---> Package kdemultimedia3.i586 0:3.5.9-54 set to be updated
    ---> Package OpenOffice_org-l10n-he.noarch 0:2.99.25-2 set to be updated
    ---> Package xorg-x11-driver-input.i586 0:7.3-103 set to be updated
    ---> Package glibc.i686 0:2.8-22 set to be updated
    ---> Package tomboy.i586 0:0.10.2-17 set to be updated
    ---> Package libmpfr1.i586 0:2.3.1-7 set to be updated
    ---> Package translation-update.noarch 0:10.3-33 set to be updated
    ---> Package libavahi-client3.i586 0:0.6.23-2 set to be updated
    ---> Package dbus-1-x11.i586 0:1.2.1-23 set to be updated
    ---> Package hdparm.i586 0:8.6-22 set to be updated
    ---> Package cdk.i586 0:4.9.13-117 set to be updated
    ---> Package PackageKit.i586 0:0.2.1-30 set to be updated
    ---> Package pm-utils.i586 0:0.99.3.20070618-69 set to be updated
    ---> Package gnome-sharp2.i586 0:2.20.1-13 set to be updated
    ---> Package planner.i586 0:0.14.2-153 set to be updated
    ---> Package flac.i586 0:1.2.1-48 set to be updated
    ---> Package libavahi-glib1.i586 0:0.6.23-2 set to be updated
    ---> Package kdeaddons3-konqueror.i586 0:3.5.9-5 set to be updated
    ---> Package kde4-knewsticker.i586 0:4.0.99-2 set to be updated
    ---> Package galago-daemon.i586 0:0.5.1-118 set to be updated
    ---> Package dmraid.i586 0:1.0.0.rc14-68 set to be updated
    ---> Package util-linux.i586 0:2.14-7 set to be updated
    ---> Package dasher-lang.i586 0:4.9.0-8 set to be updated
    ---> Package arpwatch-ethercodes.noarch 0:2008.7.18-4 set to be updated
    ---> Package libredland0.i586 0:1.0.7-22 set to be updated
    ---> Package perl-PlRPC.i586 0:0.2019-61 set to be updated
    ---> Package libMagickWand1.i586 0:6.4.0.4-27 set to be updated
    ---> Package qt3.i586 0:3.3.8b-50 set to be updated
    ---> Package alacarte.i586 0:0.11.5-43 set to be updated
    ---> Package gnome-mount.i586 0:0.7-99 set to be updated
    ---> Package soprano.i586 0:2.0.98-26 set to be updated
    ---> Package kdelibs3-default-style.i586 0:3.5.9-57 set to be updated
    ---> Package cracklib-dict-full.i586 0:2.8.12-27 set to be updated
    ---> Package kpowersave.i586 0:0.7.3-109 set to be updated
    ---> Package OpenEXR.i586 0:1.6.1-53 set to be updated
    ---> Package clucene-core.i586 0:0.9.20-45 set to be updated
    ---> Package cups-libs.i586 0:1.3.7-34 set to be updated
    ---> Package ndesk-dbus-glib.noarch 0:0.4.1-6 set to be updated
    ---> Package python-orbit.i586 0:2.14.3-100 set to be updated
    ---> Package libsigc++2.i586 0:2.2.2-18 set to be updated
    ---> Package yast2-ldap.i586 0:2.17.0-10 set to be updated
    ---> Package konversation.i586 0:1.0.1-207 set to be updated
    ---> Package gnome-terminal.i586 0:2.23.4.2-3 set to be updated
    ---> Package gdm-lang.i586 0:2.20.4-42 set to be updated
    ---> Package pango.i586 0:1.21.3-7 set to be updated
    ---> Package evince-lang.i586 0:2.22.2-11 set to be updated
    ---> Package device-mapper.i586 0:1.02.26-6 set to be updated
    ---> Package dhcp.i586 0:3.0.6-93 set to be updated
    ---> Package OpenOffice_org-Quickstarter.i586 0:1.0-683 set to be updated
    ---> Package libgnomeprint-lang.i586 0:2.18.4-40 set to be updated

  7. #7
    Join Date
    Jun 2008
    Location
    Sarasota
    Posts
    301

    Default Re: Updater & Yast = NO Updates? Yum = 100's of updates!

    You took half the fun out of this for all of us, by not showing
    ALL the errors.

    [that buffer limitation is SUPPOSED to be a hint, so now I have
    to risk ridicule by posting this]

  8. #8

    Default Re: Updater & Yast = NO Updates? Yum = 100's of updates!

    And thankfully skipping to the end, where the errors are reported:
    Code:
    ---> Package yast2-gtk.i586 0:2.16.16-9 set to be updated
    --> Processing Dependency: libzypp.so.500 for package: yast2-gtk
    ---> Package gnome-desktop-sharp2.i586 0:2.20.1-41 set to be updated
    --> Processing Dependency: libtunepimp5 = 0.5.3-100.pm.9 for package: libtunepimp5-mp4
    --> Processing Dependency: libtunepimp5 = 0.5.3-100.pm.9 for package: libtunepimp5-mad
    ---> Package libzvbi0.i586 0:0.2.30-4 set to be updated
    ---> Package libspectre1.i586 0:0.2.0-4 set to be updated
    ---> Package libavahi-gobject0.i586 0:0.6.23-2 set to be updated
    ---> Package phonon.i586 0:4.1.83-12 set to be updated
    --> Processing Dependency: phonon-backend >= 4.1.83 for package: phonon
    ---> Package libldap-2_4-2.i586 0:2.4.10-8 set to be updated
    ---> Package OpenOffice_org.i586 0:2.99.25-2 set to be updated
    --> Processing Dependency: OpenOffice_org-branding >= 2.99 for package: OpenOffice_org
    ---> Package libgnome-desktop-2-7.i586 0:2.23.4-8 set to be updated
    --> Processing Dependency: libplasma.so.1 for package: kdebase4-workspace-plasmoids
    --> Processing Dependency: libplasma.so.1 for package: extragear-plasma
    ---> Package libopencdk10.i586 0:0.6.6-2 set to be updated
    --> Running transaction check
    ---> Package yast2-gtk.i586 0:2.16.16-9 set to be updated
    --> Processing Dependency: libzypp.so.500 for package: yast2-gtk
    ---> Package phonon-backend-gstreamer-0_10.i586 0:4.1.83-12 set to be updated
    --> Processing Dependency: libtunepimp5 = 0.5.3-100.pm.9 for package: libtunepimp5-mp4
    --> Processing Dependency: libtunepimp5 = 0.5.3-100.pm.9 for package: libtunepimp5-mad
    ---> Package OpenOffice_org-branding-upstream.i586 0:2.99.25-2 set to be updated
    --> Processing Dependency: libplasma.so.1 for package: kdebase4-workspace-plasmoids
    --> Processing Dependency: libplasma.so.1 for package: extragear-plasma
    --> Processing Conflict: yast2-add-on conflicts yast2-pkg-bindings < 2.17.2
    --> Finished Dependency Resolution
    yast2-gtk-2.16.16-9.i586 from opensuse has depsolving problems
      --> Missing Dependency: libzypp.so.500 is needed by package yast2-gtk-2.16.16-9.i586 (opensuse)
    libtunepimp5-mad-0.5.3-100.pm.9.i586 from installed has depsolving problems
      --> Missing Dependency: libtunepimp5 = 0.5.3-100.pm.9 is needed by package libtunepimp5-mad-0.5.3-100.pm.9.i586 (installed)
    libtunepimp5-mp4-0.5.3-100.pm.9.i586 from installed has depsolving problems
      --> Missing Dependency: libtunepimp5 = 0.5.3-100.pm.9 is needed by package libtunepimp5-mp4-0.5.3-100.pm.9.i586 (installed)
    yast2-add-on-2.17.1-3.noarch from opensuse has depsolving problems
      --> yast2-add-on conflicts with yast2-pkg-bindings
    kdebase4-workspace-plasmoids-4.0.1-71.2.i586 from installed has depsolving problems
      --> Missing Dependency: libplasma.so.1 is needed by package kdebase4-workspace-plasmoids-4.0.1-71.2.i586 (installed)
    extragear-plasma-4.0.1-67.1.i586 from installed has depsolving problems
      --> Missing Dependency: libplasma.so.1 is needed by package extragear-plasma-4.0.1-67.1.i586 (installed)
    Error: Missing Dependency: libtunepimp5 = 0.5.3-100.pm.9 is needed by package libtunepimp5-mad-0.5.3-100.pm.9.i586 (installed)
    Error: Missing Dependency: libzypp.so.500 is needed by package yast2-gtk-2.16.16-9.i586 (opensuse)
    Error: Missing Dependency: libplasma.so.1 is needed by package kdebase4-workspace-plasmoids-4.0.1-71.2.i586 (installed)
    Error: yast2-add-on conflicts with yast2-pkg-bindings
    Error: Missing Dependency: libplasma.so.1 is needed by package extragear-plasma-4.0.1-67.1.i586 (installed)
    Error: Missing Dependency: libtunepimp5 = 0.5.3-100.pm.9 is needed by package libtunepimp5-mp4-0.5.3-100.pm.9.i586 (installed)
    phenom9600:~ #
    So, its finding problems with YaST itself.
    So three questions.
    1. Is my updater applet really working?
    2. Is yum's assertion of YaST and other problems correct? How do I fix this and how can this happen in the first place.
    3. When resolved, should I let Yum actually do the update? If so, does this mean that the updater is NOT working?

    Confused a bit.
    -nat

  9. #9

    Default Re: Updater & Yast = NO Updates? Yum = 100's of updates!

    Quote Originally Posted by cookdav View Post
    You took half the fun out of this for all of us, by not showing
    ALL the errors.
    Hey! These are not errors! These are pkg's that yum sees the need to update, while YaST does not!
    um...errors ae posted in the post after that...

  10. #10

    Default Re: Updater & Yast = NO Updates? Yum = 100's of updates!

    "gnutls.i586 0:2.2.2-24" is an openSUSE Factory package. openSUSE 11.0 package is gnutls-2.2.2-17.1 and has never been updated.

    So... your yum has different repos than your libzypp (YaST), that's why behavior is different.

    Anyway, from the first screenshot. You have duplicated repos on libzypp, remove them.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •