Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: VNC problems

  1. #1

    Default VNC problems

    Good Day,
    I am trying to run RealVNC on OpenSuse LiveCD 11.0. I have the OS installed on my laptop. When I start vncserver I still cant connect with windows XP laptop.
    I checked the vnc log file and here are the errors I am getting:

    Sun Jul 20 13:28:15 2008
    vncext: VNC extension running!
    vncext: Listening for VNC connections on port 5910
    vncext: Listening for HTTP connections on port 5810
    vncext: created VNC server for screen 0
    error opening security policy file /usr/X11R6/lib/X11/xserver/SecurityPolicy
    Could not init font path element /usr/X11R6/lib/X11/fonts/misc/, removing from list!
    Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo/, removing from list!
    Could not init font path element /usr/X11R6/lib/X11/fonts/Type1/, removing fromlist!
    Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
    Could not init font path element /usr/X11R6/lib/X11/fonts/75dpi/, removing fromlist!
    Could not init font path element /usr/X11R6/lib/X11/fonts/100dpi/, removing from list!

    Fatal server error:
    could not open default font 'fixed'
    xsetroot: unable to open display 'mikey-linux:10'
    vncconfig: unable to open display "mikey-linux:10"
    xterm Xt error: Can't open display: mikey-linux:10
    twm: unable to open display "mikey-linux:10"

    Can anyone help?

    Thanks,

    Michael

  2. #2
    Join Date
    Jun 2008
    Location
    Brisbane, Australia
    Posts
    207

    Default Re: VNC problems

    windows xp does not use vnc. Try RDP (microsoft's remote desktop protocol). Using KDE? Try krdp.
    NVIDIA! Listen to your customers! We want Free drivers.
    Petition #1. Petition #2. Use your VOICE! Sign the petitions!

  3. #3

    Default Re: VNC problems

    I am using the windows version of RealVNC on the windows system.
    the issue I am having is the vncserver on the Linux side.

    M

  4. #4
    Join Date
    Jun 2008
    Location
    Brisbane, Australia
    Posts
    207

    Default Re: VNC problems

    Did you go to YAST and enable Remote Administration?
    NVIDIA! Listen to your customers! We want Free drivers.
    Petition #1. Petition #2. Use your VOICE! Sign the petitions!

  5. #5

    Default Re: VNC problems

    I just finished that process. It installed a couple packages, and here is the log file output. I still am not able to connect from realvnc viewer on my XP system.

    20/07/2008 15:01:37 Xvnc version X.org/xf4vnc custom version
    20/07/2008 15:01:37 Copyright (C) 2001-2004 Alan Hourihane.
    20/07/2008 15:01:37 Copyright (C) 2000-2004 Constantin Kaplinsky
    20/07/2008 15:01:37 Copyright (C) 1999 AT&T Laboratories Cambridge
    20/07/2008 15:01:37 All Rights Reserved.
    20/07/2008 15:01:37 See TightVNC: VNC-Based Free Remote Control Solution for information on TightVNC
    20/07/2008 15:01:37 See http://xf4vnc.sf.net for xf4vnc-specific information
    20/07/2008 15:01:37 Desktop name 'X' (mikey-linux:4)
    20/07/2008 15:01:37 Protocol versions supported: 3.7, 3.3
    20/07/2008 15:01:37 RGB format 8 8 8
    20/07/2008 15:01:37 Listening for VNC connections on TCP port 5904
    20/07/2008 15:01:37 Listening for HTTP connections on TCP port 5804
    20/07/2008 15:01:37 URL http://mikey-linux:5804
    Could not init font path element /usr/share/fonts/local, removing from list!
    Could not init font path element /usr/share/fonts/100dpi:unscaled, removing from list!
    Could not init font path element /usr/share/fonts/Type1, removing from list!
    Could not init font path element /usr/share/fonts/Speedo, removing from list!
    Could not init font path element /usr/share/fonts/uni, removing from list!
    Could not init font path element /usr/share/fonts/CID, removing from list!



    Thanks
    Michael

  6. #6
    Join Date
    Jun 2008
    Location
    Omaha, NE
    Posts
    526

    Default Re: VNC problems

    The openSUSE firewall is more than likely blocking VNC. I believe there is an option under Remote Administration in YaST to open a port in the firewall for VNC, but then you have to make sure the server is using that port.

    You can also just disable the firewall, but that may be overkill.

  7. #7

    Default Re: VNC problems

    ya thats the only thing I can think of. I was able to run vncviewer on the linux box, and connect to the server with out a problem. So I know the server is running. I need to find out which port to open. Do I need to use port forwarding on my router? Although that might open the port for the whole internet to access it, and I dont want to do that :-)

    Thanks for the help

    Michael

  8. #8

    Default Re: VNC problems

    Ok I just temporarily disabled the firewall and the XP system connected with out a problem. so I know its the firewall. Now I just need to figure out which port to open :-)

    M

  9. #9
    Join Date
    Jun 2008
    Location
    Omaha, NE
    Posts
    526

    Default Re: VNC problems

    Quote Originally Posted by mkernan View Post
    Ok I just temporarily disabled the firewall and the XP system connected with out a problem. so I know its the firewall. Now I just need to figure out which port to open :-)

    M
    From your first post:

    vncext: Listening for VNC connections on port 5910
    vncext: Listening for HTTP connections on port 5810

    You need to open these ports with openSUSE's firewall.

  10. #10
    Join Date
    Jul 2008
    Location
    USA
    Posts
    13

    Default Re: VNC problems

    windows xp does not use vnc. Try RDP (microsoft's remote desktop protocol). Using KDE? Try krdp.
    The above is not true at all. There are a number of excellent free VNC clients for alternate platforms. Personally, I prefer TightVNC or RealVNC.

    Any way, here is some more info that might help. Suse 11 runs "vino" for desktop sharing on port 5900 by default. To enable this, just to the control center and enable "Desktop Sharing". This Vino setup requires that you are actively logged on to the console first though.

    For most purposes, VNC is most valuable by supporting multiple remote sessions (where it is not required to be physically logged in to the console). OpenSuse 11 supports this type of VNC using processes on top of "Xvnc Server". To enable this, go to Yast and enable "Remote Administration". By default, Yast enables one VNC port, 5901, with a default 1024x768 16bit configuration. The problem is that there are tighvnc extensions running over Xvnc that most VNC clients don't support yet. Hence, you will probably need to adjust a few settings. Give it a try and see if your client supports 16 bit or not.

    If you client does not support the protocol at 16 bit, then open Yast/Network Services (xinet.d), then scroll down to VNC near the bottom. Edit the first session on 5901 and change the depth from 16 to 24. Feel free to change resolution while you are there if you like. Plus, you can enable VNC sessions 2 and 3 while you are there if you like (on ports 5902 and 5903 respectively). From Linux, you can access these Xvnc sessions with a syntax like:

    vncviewer myserver:1 (Screen 1 = 5901, 2 = 5902, etc)

    I hope this info helps.

    Regards

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •