Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: samba (smbd) is not installed or not in your path

  1. #1

    Default samba (smbd) is not installed or not in your path

    I can't get samba to work. In the tool gadmin-samba I get the error mentioned in the subject of this thread. Samba is installed and smbd is located in /usr/sbin/smbd. I do not have a clue why I can't make it run. In yast Systemservices (runlevel) I can start nmb and smb but when I activate smbfs it gives an error:

    /etc/init.d/smbfs start returned 6 (program is not configured)

    Also in yast I have selected samba-server and selected startup during boot and opened a port in firewall. This doesn't help though. Can someone help me with this issue? Thanks

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: samba (smbd) is not installed or not in your path

    Quote Originally Posted by suskewiet View Post
    I can't get samba to work. In the tool gadmin-samba I get the error mentioned in the subject of this thread. Samba is installed and smbd is located in /usr/sbin/smbd. I do not have a clue why I can't make it run. In yast Systemservices (runlevel) I can start nmb and smb but when I activate smbfs it gives an error:

    /etc/init.d/smbfs start returned 6 (program is not configured)

    Also in yast I have selected samba-server and selected startup during boot and opened a port in firewall. This doesn't help though. Can someone help me with this issue? Thanks
    please tell me what you wish to use smbfs for. And also which version of Suse are you using? (smbfs was replaced after Suse 10.1 I think).

    Are you just trying to set up a Samba server and share a directory out to the network?
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  3. #3

    Default Re: samba (smbd) is not installed or not in your path

    I just want to be able to pull in shares from windows pc to my opensuse machine and vice versa. Don't know if smbfs is necessary, I thought that was the cause of smbd not running... And if I try to start smbd it through swat (localhost:901) it just won't start. The only deamon starting is winbind...

    I'm using opensuse 11.0 64 bit gnome

  4. #4
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: samba (smbd) is not installed or not in your path

    OK. Smbfs was the driver for mounting network shares on other computers as mapped drives in Suse. Now it's cifs and neither relates to running the underlying Samab networking.

    To get Samba going goto Yast --> System --> system services (runlevels) --> expert mode. Set nmb and smb both to runlevels 3 and 5 and if necessary use start/stop/refresh button to flip them to Running=Yes

    Next inspect the samba configuration file smb.conf by running this in a console:
    cat /etc/samba/smb.conf

    You need these three lines in there for good browsing of the network in Nautilus:
    • workgroup = MSHOME
      (or instead of MSHOME -- whatever is the name of workgroup in the windows boxes exactly same on all)
    • netbios name = name_of_yr_choice
      (You can use the same name as you see in the command prompt in Gnome Terminal, or anything sensible you like)
    • name resolve order = bcast host lmhosts wins

    These can all be set with a text editor started like this from a console:
    gnomesu gedit /etc/samba/smb.conf
    or you can set them the hard way in Yast --> network services. Whatever you do stay clear of Windows Domain Membership. Set them in Samba Server under Identity:
    • Workgroup name
    • NOT A DC
    • NetBIOS hostname
    • Retrieve wins is BLANK
    • Advance settings --> expert global for "name resolve order ....."

    You've already set the firewall and the start at boot so leave those for now. Reboot openSUSE then reboot rhe windows machine then reboot Suse the reboot the windows machine, then cup of tea then browse the network.

    It may be necessary temporarily to turn off the firewall -- if it is, more to check
    It may also be necessary to install a boost to browsing called "local master browser" but we'll see
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  5. #5

    Default Re: samba (smbd) is not installed or not in your path

    Thanks for the reply!
    Unfortunately all the suggestions you make were already done. Except name resolve order where the order was different. Here is something strange going on though. In systemservices runlevel, when smb always shows up with yes*. The '*' meaning it should be running but is not. When I click activate it tells me it started succesfully and the '*' is gone. Then I click finish. I immediately open systemservices runlevel again and what is showing up next to smb: right yes* again... Very strange. And thus smbd is still not running...

  6. #6
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: samba (smbd) is not installed or not in your path

    Well that's a problem. Open runlevels editor again and switch to expert mode and set levels 3 and 5 and toggle to ON and click Finish. Then check again. Did it fix?
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  7. #7

    Default Re: samba (smbd) is not installed or not in your path

    Nope problem is the same, can turn it on and finish. But when I reopen runlevel editor it is off again. Noticed another thing: in runlevel expert mode I can select start/stop/refresh for a service. When I click start smb turns on correctly (but then again it is gone when I click finish). When I click refresh I get following message (translated to english manually so could be slightly different):

    /etc/init.d/smb status returned 1 (program is dead and the file /var/run pid is present):

    When I do the refresh right after the start, the message is the same and smb is immediately turned off again...

  8. #8
    PV NNTP User

    Default Re: samba (smbd) is not installed or not in your path

    suskewiet wrote:

    >
    > Nope problem is the same, can turn it on and finish. But when I reopen
    > runlevel editor it is off again. Noticed another thing: in runlevel
    > expert mode I can select start/stop/refresh for a service. When I click
    > start smb turns on correctly (but then again it is gone when I click
    > finish). When I click refresh I get following message (translated to
    > english manually so could be slightly different):
    >
    > /etc/init.d/smb status returned 1 (program is dead and the file
    > /var/run pid is present):
    >
    > When I do the refresh right after the start, the message is the same
    > and smb is immediately turned off again...
    >
    >

    Is there anything being recorded in the logs that reside in var/log/samba.
    particularly log.smbd? What do you see if you use the command: ps -C smbd
    in a console?

    --
    P. V.

  9. #9

    Default Re: samba (smbd) is not installed or not in your path

    log.smbd:

    [2008/06/26 21:06:07, 0] smbd/server.c:main(1208)
    smbd version 3.2.0rc1-22.1-1795-SUSE-SL11.0 started.
    Copyright Andrew Tridgell and the Samba Team 1992-2008
    [2008/06/26 21:07:45, 0] smbd/server.c:main(1208)
    smbd version 3.2.0rc1-22.1-1795-SUSE-SL11.0 started.
    Copyright Andrew Tridgell and the Samba Team 1992-2008
    [2008/06/26 21:10:06, 0] smbd/server.c:main(1208)
    smbd version 3.2.0rc1-22.1-1795-SUSE-SL11.0 started.
    Copyright Andrew Tridgell and the Samba Team 1992-2008
    ......

    samba.log:

    create_subnets: Unable to create any subnet from given interfaces. Is your interface line in smb.conf correct ?
    [2008/07/20 22:40:44, 0] nmbd/nmbd_subnetdb.c:create_subnets(277)
    create_subnets: Unable to create any subnet from given interfaces. Is your interface line in smb.conf correct ?
    [2008/07/20 22:40:49, 0] nmbd/nmbd_subnetdb.c:create_subnets(277)
    create_subnets: Unable to create any subnet from given interfaces. Is your interface line in smb.conf correct ?
    [2008/07/20 22:40:54, 0] nmbd/nmbd_subnetdb.c:create_subnets(277)
    create_subnets: Unable to create any subnet from given interfaces. Is your interface line in smb.conf correct ?
    [2008/07/20 22:40:59, 0] nmbd/nmbd_subnetdb.c:create_subnets(277)
    .......

    and ps -C smbd:
    PID TTY TIME CMD

    I don't see anything useful in the logs:s

  10. #10
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: samba (smbd) is not installed or not in your path

    Hmm... puzzled.

    Maybe you should check the software is all installed. I don't really know what's required in full, but I do have these rpms installed:
    libsmbclient0, samba, samba-client, yast2-samba-client, yast2-samba-server
    But you already have the last two and if you didn't have the other three then nothing would work, but check anyway.

    BTW, check that the file /usr/bin/smbd exists, because the error message says that it doesn't exist.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •