Results 1 to 8 of 8

Thread: I was connected to router but not internet, why?

  1. #1
    miltaij NNTP User

    Default I was connected to router but not internet, why?

    Previously it's work well but suddenly internet go down. I don't know why. It's a shared connection, and all other computer are using the same version (opensuse 11.0)and they can connect to internet. The weird thing is my computer can connect to the router (when I type the router IP, it can access to the router), but it just cannot connect to internet. How can it be? Does anybody have any idea?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: I was connected to router but not internet, why?

    Possible nameserver issue? Check the output of

    cat /etc/resolv.conf

  3. #3
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: I was connected to router but not internet, why?

    Probably a good idea at the same time to report also what you get from this command
    sudo /sbin/route
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  4. #4
    miltaij NNTP User

    Default Re: I was connected to router but not internet, why?

    This are the result, hopefully it can help.
    cat /etc/resolv.conf
    ### BEGIN INFO
    #
    #
    ### END INFO
    #
    search site


    sudo /sbin/route
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
    link-local * 255.255.0.0 U 0 0 0 eth0
    loopback * 255.0.0.0 U 0 0 0 lo

    ps: my router ip is 192.168.1.1

  5. #5
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: I was connected to router but not internet, why?

    The config of the network interface needs to be restored because it's gone.

    Set these in Yast --> network devices --> network settings.
    Routing --> default gateway --> 192.168.1.1
    Hostname/DNS --> set to: change hostname via dhcp + write to /etc/hosts + update dns via dhcp + hostname (same as command prompt) + domain name if applicable

    In overview --> Edit:
    general --> activate at boot time, firewall --> external zone
    Address --> dhcp

    That's about it.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  6. #6
    Join Date
    Jun 2008
    Location
    USA
    Posts
    1,451

    Default Re: I was connected to router but not internet, why?

    This is similar to a problem I am having, but I cannot use this solution.

    I have tried to use opensuse 11 in a windows environment and cannot surf the internet. Network manager shows I am connected to the wireless lan.

    This is happening at school and at a hotel with public wifi. I don't know the default gateway in either of these places. At school, a proxy is used and I have set Firefox with the proper info on the proxy. The hotel has no proxy. It does redirect to a TOS page before it will allow you to surf.

    If I load up Win XP, the public wifi works, including the redirect. It will not work in suse. The school network also works in Win XP.

    Any ideas?

  7. #7
    normfox NNTP User

    Default Re: I was connected to router but not internet, why?

    I did all of that, and it did add the line
    default 192.168.1.1 0.0.0.0 UG 0 0 0
    to route but resolve.conf did not change (even after a reboot). I logged into the router, grabbed the 3 nameservers, unchecked update DNS data via DHCP, and hand entered them into network settings. That did edit resolve.conf and get me on the web, but as soon as my ISP changes them I'm hosed. Any Ideas? Thanks

  8. #8
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: I was connected to router but not internet, why?

    Quote Originally Posted by normfox View Post
    I did all of that, and it did add the line
    default 192.168.1.1 0.0.0.0 UG 0 0 0
    to route but resolve.conf did not change (even after a reboot). I logged into the router, grabbed the 3 nameservers, unchecked update DNS data via DHCP, and hand entered them into network settings. That did edit resolve.conf and get me on the web, but as soon as my ISP changes them I'm hosed. Any Ideas? Thanks
    Possibly could work if you changed the name servers to opendns -- worked for me once when my ISP's servers went down. They are IIRC
    208.67.222.222
    208.67.220.220
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •