Results 1 to 8 of 8

Thread: OpenSUSE locks up at Login Screen

  1. #1

    Default OpenSUSE locks up at Login Screen

    New user to OpenSUSE. My goal was to run a dual-boot system and only use Windows when absolutely necessary. Well, the installation for SUSE went great but every time I arrive at the green login screen, everything locks up. I can move my mouse and whatnot but I am not able to log in. I have tried rebooting the machine but am still stuck with an locked-up login screen in return.

    Any ideas? I have plenty of hard disk space, 1 gig of memory and a 2.16 GHz Athlon 64-bit processor. I'm running KDE 3.4, previous version from 4.0.

    Partitioning was automatic during setup. I had reserved my whole hard drive for the Linux install.

  2. #2
    Join Date
    Jun 2008
    Location
    Cleveland USA
    Posts
    138

    Default Re: OpenSUSE locks up at Login Screen

    You mean kde 3.5 I hope, not 3.4. When the login screen locks up, can you hit Alt+F1 - if your keyboard is still working, it will take you to the console. If the keyboard is completely locked, then reboot and select the opensuse failsafe option at the boot menu. This will give you a non graphical boot screen.

    Once you're in the console, log in with root, then enter sax2 -r. Sax will pop up and configure your graphics card. Accept the default configuration if it looks good, then restart and you should be fine. Hope that works.
    Unintentionally left blank...

  3. #3

    Default Re: OpenSUSE locks up at Login Screen

    Quote Originally Posted by coomac View Post
    You mean kde 3.5 I hope, not 3.4. When the login screen locks up, can you hit Alt+F1 - if your keyboard is still working, it will take you to the console. If the keyboard is completely locked, then reboot and select the opensuse failsafe option at the boot menu. This will give you a non graphical boot screen.

    Once you're in the console, log in with root, then enter sax2 -r. Sax will pop up and configure your graphics card. Accept the default configuration if it looks good, then restart and you should be fine. Hope that works.
    Right, 3.5. I'll see if hitting Alt+F1 does the trick and log into the console. How do I log in with root? Do I just type in Root and enter my Root password?

  4. #4
    Kevin Nathan NNTP User

    Default Re: OpenSUSE locks up at Login Screen

    On Sun, 20 Jul 2008 01:06:04 GMT
    valoq <valoq@no-mx.forums.opensuse.org> wrote:

    >Right, 3.5. I'll see if hitting Alt+F1 does the trick and log into the
    >console. How do I log in with root? Do I just type in Root and enter
    >my Root password?


    Yes. But no capital letters in 'root' . . . :-)


    --
    Kevin Nathan (Arizona, USA)
    Linux is not a destination, it's a journey -- enjoy the trip!

    Linux 2.6.25.9-0.2-pae
    6:31pm up 5 days 21:43, 15 users, load average: 0.64, 1.06, 1.01


  5. #5

    Default Re: OpenSUSE locks up at Login Screen

    I stand back with what I said: My cursor disappears and everything completely locks up right as I begin typing my user name. Alt+F1 = no go.

    I can log in using (fail-safe) method ; however, changing my resolution to default - 1440X900- causes the system to lockup.

  6. #6
    Join Date
    Jun 2008
    Location
    Cleveland USA
    Posts
    138

    Default Re: OpenSUSE locks up at Login Screen

    In that case, just use the suggested configuration. You can fiddle with the sax settings after you get a working desktop. Once you have a working X server, you can pull up sax again by going into yast (find it in the kmenu under computer) > hardware > graphics card and monitor.

    Dunno what graphics card you're using, but it may be that the opensource driver for the card isn't quite jiving with the default resolution. You could try installing the proprietary driver for the card and see if it works better.

    Quickest way to do this would be to go into yast software manager (install software icon under the kmenu > computer), choose repositories > repository manager, then select Add > Community Repositories. The repos for both nvidia and ati can be found there.

    Choose the repository for your card and finish out of the repo manager. This will take you back to the software installer where you can search for either nvidia or fglrx (depending on your card) and install the corresponding driver. Reboot, just to be safe.

    You can pull up sax after that and check the default resolution.
    Unintentionally left blank...

  7. #7

    Default Re: OpenSUSE locks up at Login Screen

    Okay:

    Quickest way to do this would be to go into yast software manager (install software icon under the kmenu > computer), choose repositories > repository manager, then select Add > Community Repositories. The repos for both nvidia and ati can be found there.

    Which file do I download? I have an ATI Radeon X800- There are repositories for ATI "fglrx" driver kernel module.. uhm.. I haven't got a clue what any of this stuff is.

    Now what?

  8. #8

    Default Re: OpenSUSE locks up at Login Screen

    Not sure what I did but my resolution is fixed. Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •