Results 1 to 4 of 4

Thread: Making Opera default browser

  1. #1

    Default Making Opera default browser

    I've been trying to make Opera (9.52) my default web browser but have come up against brick walls. First, there is no option (in Opera) for making it the default. I changed the setting in the KDE Components section from firefox to opera but now it only halfway works. Clicking on a URL in KNode will open Opera. Clicking one in Thunderbird or Evolution opens Firefox. What do I need to change in order to get this thing working right? By the way, I'm using 11.0/32-bit, KDE 3.5. Thanks!

  2. #2
    google01103 NNTP User

    Default Re: Making Opera default browser

    zachsmith wrote:

    >
    > I've been trying to make Opera (9.52) my default web browser but have
    > come up against brick walls. First, there is no option (in Opera) for
    > making it the default. I changed the setting in the KDE Components
    > section from firefox to opera but now it only halfway works. Clicking
    > on a URL in KNode will open Opera. Clicking one in Thunderbird or
    > Evolution opens Firefox. What do I need to change in order to get this
    > thing working right? By the way, I'm using 11.0/32-bit, KDE 3.5.
    > Thanks!
    >
    >

    2 possibilities:
    a) t-bird is using the gnome defined browser, so change this in gnome's config manager (whatever it's called)
    b) there is a $BROWSER environmental variable, try changing it "export BROWSER=/usr/bin/opera"
    --
    Suse 11.0 x64, Kde 4.1beta (factory repo), Opera 9.x weekly

  3. #3
    ab@novell.com NNTP User

    Default Re: Making Opera default browser

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    It may also be worth adding a softlink from your user's ~/bin directory
    to opera with the name of 'mozilla' or 'firefox' or whatever most of
    your other apps have configured. So....:

    ln -s /usr/bin/opera ~/bin/firefox ~/bin/mozilla ~/bin/whateverElse

    Good luck.





    google01103 wrote:
    | zachsmith wrote:
    |
    |> I've been trying to make Opera (9.52) my default web browser but have
    |> come up against brick walls. First, there is no option (in Opera) for
    |> making it the default. I changed the setting in the KDE Components
    |> section from firefox to opera but now it only halfway works. Clicking
    |> on a URL in KNode will open Opera. Clicking one in Thunderbird or
    |> Evolution opens Firefox. What do I need to change in order to get this
    |> thing working right? By the way, I'm using 11.0/32-bit, KDE 3.5.
    |> Thanks!
    |>
    |>
    | 2 possibilities:
    | a) t-bird is using the gnome defined browser, so change this in
    gnome's config manager (whatever it's called)
    | b) there is a $BROWSER environmental variable, try changing it "export
    BROWSER=/usr/bin/opera"
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFIgoyI3s42bA80+9kRAtbsAJ46swzbZ9LTzb8kIV50qs32ISk3SQCghndL
    Roj0RwD+9VESAKxeuoiaoGQ=
    =dPCl
    -----END PGP SIGNATURE-----

  4. #4

    Default Re: Making Opera default browser

    It may also be worth adding a softlink from your user's ~/bin directory
    to opera with the name of 'mozilla' or 'firefox' or whatever most of
    your other apps have configured. So....:

    ln -s /usr/bin/opera ~/bin/firefox ~/bin/mozilla ~/bin/whateverElse

    Good luck.



    | 2 possibilities:
    | a) t-bird is using the gnome defined browser, so change this in
    gnome's config manager (whatever it's called)
    | b) there is a $BROWSER environmental variable, try changing it "export
    BROWSER=/usr/bin/opera"

    Got it working with possibility "a". A Gnome setting was using Firefox as the default. Changed it to opera and all is working like it should. Thanks for the suggestions!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •