I have configured my phone as a bluetooth modem using yast. With previous versions of network manager, the configured modem (modem0) would appear in the list of networks under the provider (T-Mobile), but the only options in NM 7 is to connect to either eth# or wlan#.

/etc/sysconfig/network contains ifcfg-modem0, but NM 7 doesn't show an option for modem0. I've tried creating a new wired and wireless connection and adding modem0 as the name, but no luck. Kinternet connects to the phone just fine, but I really don't like the idea of using two connection managers. Am I missing something here?