Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: SAMBA Not Sharing Folders

  1. #1

    Exclamation SAMBA Not Sharing Folders

    I am Running OpenSUSE 11.0 with all updates up to present. The implementation is GNOME with KDE4 as an option. I've set up a SAMBA server to share out three folders within my home directory: music, videos, photos (this is a home theater PC).

    When I configure the shares through Nautilus, all appears well. But, when I view the files through Konquerer, and try to configure them, I get this error:

    "Error running 'filesharelist.' Check if installed and in $PATH or /usr/sbin"

    If need be, I can get rid of KDE 4, as I'm not "married to it." In fact, I likely will. I'm not sure if the co-existence of KDE4 with GNOME is messing things up (with Samba and with other things) or if something else is going on.

    When I looked at the samba configuration file, it said that shares were disabled by YAST. My Samba is set up as the WORKGROUP workgroup and the server is set up as "not a domain controller." The netbios name I gave the machine is "media1." The machine gets its IP address via DHCP from my wireless router.

    Thank you.

  2. #2

    Default Re: SAMBA Not Sharing Folders

    Sorry...I should have posted the conf file and share files. Here they are:

    # smb.conf is the main Samba configuration file. You find a full commented
    # version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
    # samba-doc package is installed.
    # Date: 2008-06-06
    [global]
    workgroup = WORKGROUP
    printing = cups
    printcap name = cups
    printcap cache time = 750
    cups options = raw
    map to guest = Bad User
    include = /etc/samba/dhcp.conf
    logon path = \\%L\profiles\.msprofile
    logon home = \\%L\%U\.9xprofile
    logon drive = P:
    usershare allow guests = Yes
    add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
    domain logons = No
    domain master = No
    security = user
    netbios name = media1
    usershare max shares = 100
    name resolve order = bcast host lmhosts wins
    server string = ""
    [homes]
    comment = Home Directories
    valid users = %S, %D%w%S
    browseable = No
    read only = No
    inherit acls = Yes
    [profiles]
    comment = Network Profiles Service
    path = %H
    read only = No
    store dos attributes = Yes
    create mask = 0600
    directory mask = 0700
    [users]
    comment = All users
    path = /home
    read only = No
    inherit acls = Yes
    veto files = /aquota.user/groups/shares/
    [groups]
    comment = All groups
    path = /home/groups
    read only = No
    inherit acls = Yes
    [printers]
    comment = All Printers
    path = /var/tmp
    printable = Yes
    create mask = 0600
    browseable = No
    [print$]
    comment = Printer Drivers
    path = /var/lib/samba/drivers
    write list = @ntadmin root
    force group = ntadmin
    create mask = 0664
    directory mask = 0775

    ## Share disabled by YaST
    # [netlogon]
    # comment = Network Logon Service
    # path = /var/lib/samba/netlogon
    # write list = root

    [music]
    comment = HTPC Music Directory
    inherit acls = Yes
    path = /home/devitor/music/
    read only = No

    [photos]
    comment = HTPC Photo Directory
    inherit acls = Yes
    path = /home/devitor/photos/
    read only = No

    [videos]
    comment = HTPC Video Directory
    inherit acls = Yes
    path = /home/devitor/videos/
    read only = No
    And...here are the individual user share file contents:

    #VERSION 2
    path=/home/devitor/music
    comment=
    usershare_acl=S-1-1-0:F
    guest_ok=y

    #VERSION 2
    path=/home/devitor/photos
    comment=
    usershare_acl=S-1-1-0:F
    guest_ok=y

    #VERSION 2
    path=/home/devitor/videos
    comment=
    usershare_acl=S-1-1-0:F
    guest_ok=y

  3. #3
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: SAMBA Not Sharing Folders

    There's an executable program called filesharelist that lives at /usr/bin/filesharelist. Check it's there.

    Share disabled by Yast is OK because in Yast there's a button that you can click to toggle a share on or off --> you can see the result for netlogon. It should be toggled off, as it is, because it's associated with domain logons -- and you haven't got a domain server running. So it's OK.

    Also: you've created the media shares as two separate, distinct and independent forms; namely "usershares" and "classical shares". Usershares arrived in openSuse 10.2 and are often made in Nautilus with a right-click etc. That produces definition files like the ones you displayed under "And...here are the individual user share file contents". Classical shares are made in a different way, e.g. by editing definition paragraphs into the file smb.conf. You've actually or effectively done that as shown in the file smb.conf that you posted.

    The two types are alternatives. So I suggest you turn off one or the other. You can turn off the usershares with a r-click in Nautilus. OR (but don't do both) You can turn off the classical sghares with a r-click in Yast --> network services --> Samba server --> Highlight the share and click to "Toggle Status"
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  4. #4

    Default Re: SAMBA Not Sharing Folders

    Good morning,

    I shut off the sharing within YAST and left it on at the folder level (user level).

    I checked the directories and filesharelist is NOT there.

  5. #5
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: SAMBA Not Sharing Folders

    OK add these lines to [global] in smb.conf:
    usershare allow guests = yes
    usershare owner only = False
    usershare path = /var/lib/samba/usershares
    Tip: making and sharing folders on the Desktop doesn't work properly for Usershares.
    Tip: windows users might have trouble connecting unless they know the credentials of a user on Suse attached into the samba user database (but may be ok now because you have allowed guests now in [global])

    Regarding filesharelist -- if error goes away, forget it. Has it gone away?
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  6. #6

    Default Re: SAMBA Not Sharing Folders

    I rebuilt the machine first to GNOME alone, then re-formatted and went with KDE 3.5. Samba appears to work on KDE 3.5, (i.e. I'm not seeing errors), but my XP box does not see anything. I'm sharing out via Konquerer.

    The filesharelist file was not installed in the prior implementation. In my GNOME-only setup, it said KDE components were missing (after a complete reformat). I had other issues, so I re-re-formatted to this implementation.

    I'll pick this back up tomorrow.

  7. #7
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: SAMBA Not Sharing Folders

    I guess there's more than two ways to skin an orange.

    Good luck
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  8. #8

    Default Re: SAMBA Not Sharing Folders

    Long story short, I first built the machine with GNOME as the primary system and KDE4 as an alternate, but there were too many problems with both systems being there with elements accessible to one aother....which was why I had Samba shares set up in YAST, Nautilus and Konquerer starting out. My goal was to simplify. There were other things going on aside from Samba which impelled me to move with a rebuild.

    When I rebuilt to GNOME only on a complete HDD re-format, Samba gave an error message that there were KDE dependencies not being satisfied and that there were orphaned KDE files. The GNOME setup for some reason took very long to respond to my mouse clicks. I didn't bother troubleshooting. I rebuilt again to KDE 3.5.

    Back to Samba, I shut off the sharing from Konquerer and turned it back on via YAST. I set the folder permissions so anyone can view and modify. I still don't see the folders off my XP box. Filesharelist is now installed by virtue of KDE 3.5. I still don't see error messages like last night, but I don't see the shares either.

    Here is the smb.conf file as it is now:

    # smb.conf is the main Samba configuration file. You find a full commented
    # version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
    # samba-doc package is installed.
    # Date: 2008-06-06
    [global]
    workgroup = WORKGROUP
    printing = cups
    printcap name = cups
    printcap cache time = 750
    cups options = raw
    map to guest = Bad User
    include = /etc/samba/dhcp.conf
    logon path = \\%L\profiles\.msprofile
    logon home = \\%L\%U\.9xprofile
    logon drive = P:
    usershare allow guests = Yes
    add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
    domain logons = No
    domain master = No
    netbios name = MEDIA1
    security = user
    passdb backend = smbpasswd
    usershare max shares = 100

    [homes]
    comment = Home Directories
    valid users = %S, %D%w%S
    browseable = No
    read only = No
    inherit acls = Yes

    [users]
    comment = All users
    path = /home
    read only = No
    inherit acls = Yes
    veto files = /aquota.user/groups/shares/

    [groups]
    comment = All groups
    path = /home/groups
    read only = No
    inherit acls = Yes

    [printers]
    comment = All Printers
    path = /var/tmp
    printable = Yes
    create mask = 0600
    browseable = No

    [print$]
    comment = Printer Drivers
    path = /var/lib/samba/drivers
    write list = @ntadmin root
    force group = ntadmin
    create mask = 0664
    directory mask = 0775

    [music]
    comment = music files
    inherit acls = Yes
    path = /home/devitor/music/
    read only = No

    [photos]
    comment = Photos Directory
    inherit acls = Yes
    path = /home/devitor/photos/
    read only = No

    [videos]
    comment = Video Directory
    inherit acls = Yes
    path = /home/devitor/videos/
    read only = No
    I did not hand-tweak any settings this time. There is nothing I can see in here that is untoward. What I did notice though is that the samba server is set to poll for a WINS server by DHCP. I don't have a WINS server on my network.

  9. #9
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: SAMBA Not Sharing Folders

    If the wins server thing is still on, turn it off. A wins server is for large and complex networks -- not SOHO networks.

    I suggest you change a few things in [global] to allow the windows boxes clearer vision of Suse box. And slightly alter the shares.
    First of all make a backup of smb.conf before you change it.

    Then open the text file smb.conf located at /etc/samba/smb.conf in a superuser editor with this command in a console (assuming now KDE):
    kdesu kwrite /etc/samba/smb.conf
    and copy/paste the following corrected text over the old text:
    [global]
    workgroup = WORKGROUP
    netbios name = MEDIA1
    name resolve order = bcast host lmhosts wins
    server string = ""
    printing = cups
    printcap name = cups
    printcap cache time = 750
    cups options = raw
    use client driver = yes
    map to guest = Bad User
    local master = yes
    preferred master = yes
    os level = 65
    usershare allow guests = Yes
    usershare max shares = 100
    usershare owner only = False

    [music]
    comment = music files
    force user = devitor
    path = /home/devitor/music/
    read only = No

    [photos]
    comment = Photos Directory
    force user = devitor
    path = /home/devitor/photos/
    read only = No

    [videos]
    comment = Video Directory
    force user = devitor
    path = /home/devitor/videos/
    read only = No
    I have this concern -- the shares as structured will require the windows users to supply a username and a password. You will have to add a Samba user to the Samba user database on this Linux server and tell the clients the credentials. Did you mean to set it up that way?

    Alternatively, for guest access, add this line into the paragraphs for each of the three media shares:
    guest ok = yes
    Reboot Suse, then windows, then Suse, then windows. That booting forces a great deal of "getting to know you" around a network.

    Swerdna
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  10. #10

    Default Re: SAMBA Not Sharing Folders

    Swerdna,

    I removed the reference to WINS (I agree with you re: WINS...if I was running a Windows Server-based network, I'd have WINS setup there).

    I replaced my smb.conf with yours. I added the guest access. I don't want the XP box to be bothered with user names and passwords.

    I took the reboots. Still nothing.

    Now...I checked the XP box to make sure my firewall wasn't blocking anything.

    I can ping the machine on the wired network by IP address (wireless is a lost cause at this point...I thought I had that working, but it only lasted a day, then stopped -- see my wireless thread for the whole story).

    That's about it for now. I won't touch the SUSE box again until I hear back from you (Aside from the wireless and Samba, it otherwise works and I don't want to mess up a good thing).

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •