Results 1 to 2 of 2

Thread: Cannot Mute on Lenovo Y410

  1. #1

    Default Cannot Mute on Lenovo Y410

    I'm using OpenSUSE 11 on Lenovo Y410. Can you tell me why I can't mute the sound? Please give me the solution

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Cannot Mute on Lenovo Y410

    Quote Originally Posted by ba_tux View Post
    I'm using OpenSUSE 11 on Lenovo Y410. Can you tell me why I can't mute the sound? Please give me the solution
    Can you tell us more about the Lenovo?

    Unless you get lucky, the odds of anyone with the same laptop, running openSUSE, being able to give you an exact and up-to-date "solution" to your question (without further information), is IMHO unlikely. Alsa, which contains the most commonly used audio hardware drivers for linux, is in a constant state of flux. Hence what didn't work yesterday, might work today (and to a much lessor extent: visa versa).

    There was a thread here (in the SF archives) where a Lenovo Y410 user (with an ALC262 hardware audio codec) had the same problem:
    Sound Help - Lenovo Y410 - Ich8 - openSUSE Forums

    When I surf on your laptop I find this:
    Lenovo 3000 Y410 - Linux Laptop Wiki
    which states:
    Use the snd-hda-intel driver with model=sony-assamd (note that the microphone and headphone jacks won't work)
    I believe that is rather out of date.

    I notice 1.0.17 of alsa, in the ALSA-Configuration.txt file, has a new model assignment under the ALC-262 for the Lenovo 3000 Y410. Which means one needs to update to 1.0.17 of alsa, and then apply the model assignment model=lenovo-3000 in the correct syntax/location in ones /etc/modprobe.d/sound file. Its possible you have updated alsa and tried this. Its possible some help would be beneficial.

    I'm willing to try help you, but what would help me is if you first examined the openSUSE audio troubleshooting guide to get an idea as to what I could put you through:
    SDB:AudioTroubleshooting - openSUSE
    and then assuming that guide did not help you, post here the output of running a sound diagnostic script for your audio software/hardware. Specifically, with your laptop connected to the Internet, open an xterm/konsole and copy and paste the code below. When prompted for a password enter your root password.
    Code:
    wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa'
    That script, when complete, will give you a URL to a web page with information on your laptop's audio hardware/software configuration. Please post that URL here.

    Please also run the following in an xterm/konsole, one line at a time, and post here the output that gives you.
    rpm -qa grep | alsa
    rpm -qa grep | pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound


    Based on that I will help you:
    a. update your alsa applications to 1.0.17 and
    b. apply the correct model option assignement to your laptop's /etc/modprobe.d/sound file
    The above all makes the assumption that you can connect your laptop to the Internet.

    Good luck!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •