Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: openSUSE 11.0 - Howto configure for non-broadcast ESSID

  1. #1

    Default openSUSE 11.0 - Howto configure for non-broadcast ESSID

    My wireless network functions great as long the 'Broadcast ESSID' is enabled on the AP. This is a great security risk for me.
    There is no option in YAST2 --> Network Settings nor do I know what option(s) to add to either ath0.conf or wpa_supplicant.conf files.
    The network is functioning in WPA-PSK mode.
    Any help is greatly appreciated.

    Thanks,
    EZputter

  2. #2
    ab@novell.com NNTP User

    Default Re: openSUSE 11.0 - Howto configure for non-broadcast ESSID

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Have you tried using Network Manager? It makes this all fairly easy.

    Good luck.





    EZputter wrote:
    | My wireless network functions great as long the 'Broadcast ESSID' is
    | enabled on the AP. This is a great security risk for me.
    | There is no option in YAST2 --> Network Settings nor do I know what
    | option(s) to add to either ath0.conf or wpa_supplicant.conf files.
    | The network is functioning in WPA-PSK mode.
    | Any help is greatly appreciated.
    |
    | Thanks,
    | EZputter
    |
    |
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFIgSXv3s42bA80+9kRAtz2AJ49EgpZ44WpZApccAKcoPpnjLalBgCfY7Pi
    8vNstqxg9ZQVGzd3gVgdf0Y=
    =BQjv
    -----END PGP SIGNATURE-----

  3. #3
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: openSUSE 11.0 - Howto configure for non-broadcast ESSID

    EZputter wrote:
    > My wireless network functions great as long the 'Broadcast ESSID' is
    > enabled on the AP. This is a great security risk for me.
    > There is no option in YAST2 --> Network Settings nor do I know what
    > option(s) to add to either ath0.conf or wpa_supplicant.conf files.
    > The network is functioning in WPA-PSK mode.
    > Any help is greatly appreciated.


    Hiding the ESSID is _NOT_ a security feature. Anyone running wireshark will find
    your network and its hidden ESSID in short order. As long as your WPA-PSK
    passphrase is 20 characters or more, and is not in a dictionary, you are safe.
    All you do with a hidden ESSID is make it harder for you to connect.

    Larry

  4. #4

    Default Re: openSUSE 11.0 - Howto configure for non-broadcast ESSID

    I am very new to linux, so everything is eye opening for me.
    I use gnome and the preferred network configuration method (?) is through Yast2 'network settings'. Unfortunately, I can't find an option in Yast2 'network settings'to configure the wireless to find AP without the ESSID Broadcast, nor do I know what to add to 'ath0.conf' or 'wpa_supplicant.conf'.
    Oooh God -- PLEASE make my drives longer than my putts

  5. #5
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: openSUSE 11.0 - Howto configure for non-broadcast ESSID

    have you read the stickies at the start of this section ? especially the contribution from prhunt ? namely

    Scenario: You need to use WPA security for your wireless connection, and the access point has a hidden SSID.

    Problem: Your wlan won't associate with the access point even though your passphrase and all other config details are correct.

    Solution: As root, edit the wlan device configuration file and add the following two entries:

    WIRELESS_HIDDEN_SSID='yes'
    WIRELESS_AP_SCANMODE='2'

    This configuration is located in /etc/sysconfig/network/ifcfg-wlan0
    (or a similar file - it should be fairly obvious).


    Sources: wpa_supplicant docs.
    /etc/sysconfig/network/ifcfg.template
    Andy
    To be is to do = Immanuel Kant
    To do is to be = Descartes.
    Do be do be do = Frank Sinatra

    SuSE user since 7.0,Linux user since 1994

  6. #6
    Klaus Krtschil NNTP User

    Default Re: openSUSE 11.0 - Howto configure for non-broadcast ESSID

    deltaflyer44 schrieb:
    > have you read the stickies at the start of this section ? especially the
    > contribution from prhunt ? namely


    OT: I have read a couple of posts mentioning stickies. What are you
    talking about? My newsreader displays post sorted by time (newest first).

    Thanks
    Klaus
    --
    Linux User #54760

  7. #7

    Default Re: openSUSE 11.0 - Howto configure for non-broadcast ESSID

    Andy,
    Thank you for the response.
    Per your suggestion, this is what I did:
    1. Edited /etc/sysconfig/networks/ath0.conf (my wireless) & added:
    WIRELESS_HIDDEN_SSID='yes'
    WIRELESS_AP_SCANMODE='2'
    2. Disabled the AP's 'Broadcast ESSID'
    3. Restarted the AP (for safe measures)
    4. Restarted the laptop

    Results: Network Manager trys to connect to AP & AP's wireless light turns ON momentarily, but then Popup on the screen asks for passphrase. Supplying the passphrase results in the same cycle.

    Other Windows based laptops connect with no issues.

    Any other thoughts? My searching through the internet is taking me through the same scenarios.

    Thanks ...
    Oooh God -- PLEASE make my drives longer than my putts

  8. #8
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: openSUSE 11.0 - Howto configure for non-broadcast ESSID

    Quote Originally Posted by Klaus Krtschil View Post
    deltaflyer44 schrieb:
    > have you read the stickies at the start of this section ? especially the
    > contribution from prhunt ? namely


    OT: I have read a couple of posts mentioning stickies. What are you
    talking about? My newsreader displays post sorted by time (newest first).

    Thanks
    Klaus
    --
    Linux User #54760
    Stickies are information posts which appear at the start of the section. It is the very first post for that section

    Andy
    To be is to do = Immanuel Kant
    To do is to be = Descartes.
    Do be do be do = Frank Sinatra

    SuSE user since 7.0,Linux user since 1994

  9. #9
    Robert Smits NNTP User

    Default Re: openSUSE 11.0 - Howto configure for non-broadcast ESSID

    deltaflyer44 wrote:

    >
    >
    > Stickies are information posts which appear at the start of the
    > section. It is the very first post for that section
    >


    Whatever "stickies" are, they are useless for the half of us who participate
    in these discussions as nntp feeds. There are no "stickies" for us. If they
    are general faqs, perhaps they can be posted periodically, so the posts
    don't expire.
    --
    bob@rsmits.ca (Robert Smits, Ladysmith BC)

    "I'm not one of those who think Bill Gates is the devil. I simply suspect
    that if Microsoft ever met up with the devil, it wouldn't need an
    interpreter." - Nicholas Petreley


  10. #10
    Tilman Schmidt NNTP User

    Default Re: openSUSE 11.0 - Howto configure for non-broadcast ESSID

    deltaflyer44 schrieb:
    > Klaus Krtschil;1841903 Wrote:
    >>
    >> OT: I have read a couple of posts mentioning stickies. What are you
    >> talking about? My newsreader displays post sorted by time (newest
    >> first).

    >
    > Stickies are information posts which appear at the start of the
    > section. It is the very first post for that section


    The first post I see in this group is this:

    > From: choukai <choukai@no-mx.forums.opensuse.org>
    > Newsgroups: opensuse.org.help.network-internet.wireless
    > Subject: openSUSE 11.0 & RT2500pci wireless problems
    > Message-ID: <choukai.3bavw0@no-mx.forums.opensuse.org>
    > Date: Fri, 20 Jun 2008 11:06:04 GMT


    but I don't think that is one of those "stickies" you are talking
    about, and if I choose a different sort order for the group
    another one will be first. So how would I find or recognize them
    stickies in my newsreader?

    Thanks,
    Tilman

    --
    Tilman Schmidt
    Phoenix Software GmbH
    Bonn, Germany

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •