Results 1 to 7 of 7

Thread: Bootsplash not working... can anybody help?

  1. #1

    Default Bootsplash not working... can anybody help?

    Hi,

    I've recently "upgraded" to OpenSuSE 11.0 (upgraded as in format root partition, keep home). When I was performing the final hardware config, the installer crashed. No problem for me, I found my way round and reconfigured GRUB to work, I just had to add a vga option and then it was fine.

    However, when I choose to boot the OS from the boot menu it doesn't display the splash screen/loading bar; it just goes straight to the console text. Now I don't mind this, however my younger siblings may think that the computer has foobarred . Is there a way to restore the bootsplash themes?

    My /etc/sysconfig/bootsplash entry is: openSUSE

    All the bootsplash theme files are present in /etc/bootsplash.
    --
    Thanks in advance.

  2. #2

    Default Re: Bootsplash not working... can anybody help?

    you've got the opposite problem I do.

    I get the opensuse bootsplash and want to get rid of it.
    I've done everything I can, edited bootsplash, the boot/message, and splashy, yet can't get rid of the graphic...

  3. #3
    Join Date
    Jun 2008
    Location
    Cleveland USA
    Posts
    138

    Default Re: Bootsplash not working... can anybody help?

    To enable boot splash, run mkinitrd as root. Also, your /boot/grub/menu.lst should contain an entry for a vga resolution. For example, because I'm using a bootsplash that is 1024x768, my menu.lst contains:

    kernel /vmlinuz-2.6.26-18-default root=/dev/disk/by-id/scsi-SATA_ST9120821A_3PL0AVBB-part5 resume=/dev/sda3 splash=silent showopts vga=0x317

    I think the default bootsplash is 800x600, so the vga entry for that should be vga=0x314 iirc. If you want to change sizes, run mkinitrd -s 1024x768 (or insert whatever size you prefer). Just make sure you have the right vga entry in menu.lst.

    The mkinitrd result should contain an entry like so when it actually enables bootsplash:

    <snip>
    Bootsplash: openSUSE (1024x768)
    <snip>

    To get rid of the bootsplash, change the vga entry in menu.lst to vga=normal. It gives you the console without any fancy text. If you want the vga, but not the bootsplash, you have to remove the bootsplash entry from /etc/sysconfig/bootsplash. Change SPLASH="yes" to no.
    Unintentionally left blank...

  4. #4

    Default Re: Bootsplash not working... can anybody help?

    Thanks for the replies.

    However, I have already tried mkinitrd (as root), it gives me the correct output and I have specified the correct size (1024x768); likewise the GRUB vga entry is also correct. All the theme files are there in /etc/bootsplash/themes. I believe the problem may be in /etc/sysconfig.

    When I use the Yast2 GUI, it has "openSUSE" as the cuurent option whilst clicking default gives me a blank entry. On the other hand, when I look in /etc/sysconfig, there is no "themes" file which I believe should be present.

    Again, thank you for your reply; it was my fault for not mentioning that I had already tried your proposed solution.

  5. #5
    Join Date
    Dec 2008
    Location
    Seattle, WA
    Posts
    11

    Default Re: Bootsplash not working... can anybody help?

    Hopefully my reply is not coming too late for you. I saw your question the other night. I had the same problem. At least I was lucky to find the right note on the right page.

    Like you say I do everything as the gurus say, but it still doesn't work. Then I found this link:
    Custom splash screen - openSUSE
    Pay attention to: "(Small note: Display needs to be in 16bpp mode for the bootsplash to work, make sure grub options are set correctly)" That solved my problem. I had set a 24bpp vga= mode. Once I changed it to the corresponding 16bpp mode, the splash image popped.

    Here's a link that has the possible vga modes:
    VGA Boot modes to set screen resolution | USB Pen Drive Linux

    Good luck!

  6. #6

    Default Re: Bootsplash not working... can anybody help?

    Thanks fir all the replies, but nothing I do seems to work

    If any of you out there know how to enable bootsplash for SuSE 11 on older EEEpc with 800x480 res, please let me know.
    OpenSuSE 11.0 @ AMD 64 Dual Laptop. Make - HP Pavillion dv2000
    What's working - everything

  7. #7

    Default Re: Bootsplash not working... can anybody help?

    Sorry. I posted it in a wrog thrread. Sorry.
    OpenSuSE 11.0 @ AMD 64 Dual Laptop. Make - HP Pavillion dv2000
    What's working - everything

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •