Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: Can't mount ntfs USB external disk

  1. #11

    Default Re: Can't mount ntfs USB external disk

    How do i make it detect my usb?

  2. #12
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: Can't mount ntfs USB external disk

    Quote Originally Posted by soulblade118 View Post
    How do i make it detect my usb?
    How to detect? You find out why its not working.

    You could try rebooting, and then immediately after a reboot insert your USB device, and then immediately type:
    dmesg > dmesg.txt
    Then open the file "dmesg.txt" (that you just created) with a text editor, and paste the contents of that file on general pastebin - simplified internet collaboration, and submit the paste, and then post here the URL that the site gives you. (dmesg is too big to post directly here).

    You could also show us the interrupts your PC has with:
    cat /proc/interrupts

    There are also other debugging tools for a USB, but I've never had to use them, so I am not familiar with them.

    Maybe (and maybe not) with that information, one of the members watching this thread might have a solution to help you get this functioning.

  3. #13
    kvik369 NNTP User

    Default Re: Can't mount ntfs USB external disk

    Coming from a Linux newbie, I've had this problem also when I didn't remove it properly from my windows machine "first".
    1 - Reconnect to a windows machine
    2 - Make sure that you remove it properly
    3 - Reconnect to Linux box.
    worked for me - after that Linux recognized it automatically. (make sure you unmount from Linux)

  4. #14

    Default Re: Can't mount ntfs USB external disk

    wow that did the trick... thank you!! Why does that cause the USB drive failed to be recognized?

  5. #15
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,383
    Blog Entries
    1

    Default Re: Can't mount ntfs USB external disk

    The ntfs volume journal needs to be in a clean state before linux is able to mount it. Windows just provides a convenient way to do this. There is a basic ntfsfix utility that can do some simple housekeeping as well, but its abilities are limited.

  6. #16
    nikoslaz NNTP User

    Default Re: Can't mount ntfs USB external disk

    Hello,
    I have a problem mounting my usb hard disk too.
    First of all... I use Suse 11, kernel 2.6.25.11-0.1 and the external usb drive has only one NTFS partition containing data like docs and other precious stuff
    When I try to mount it I get the following msg:

    mount: wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so

    This is what I did exactly:

    linux-vl6v:~ # mount -t ntfs /dev/sdb1 /mnt/external
    mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
    missing codepage or helper program, or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so

    linux-vl6v:~ # dmesg | tail
    sd 3:0:0:0: [sdb] Mode Sense: 27 00 00 00
    sd 3:0:0:0: [sdb] Assuming drive cache: write through
    sdb: sdb1
    sd 3:0:0:0: [sdb] Attached SCSI disk
    sd 3:0:0:0: Attached scsi generic sg2 type 0
    usb-storage: device scan complete
    NTFS-fs error (device sdb1): parse_options(): Unrecognized mount option locale.
    NTFS-fs warning (device sdb1): parse_options(): Option utf8 is no longer supported, using option nls=utf8. Please use option nls=utf8 in the future and make sure utf8 is compiled either as a module or into the kernel.
    NTFS-fs error (device sdb1): parse_options(): Unrecognized mount option locale.
    NTFS-fs warning (device sdb1): parse_options(): Option utf8 is no longer supported, using option nls=utf8. Please use option nls=utf8 in the future and make sure utf8 is compiled either as a module or into the kernel.

    help???plz??

  7. #17
    GnuceLee NNTP User

    Default Re: Can't mount ntfs USB external disk

    To be able to mount external ntfs USB disks in read-write mode, you have to

    1. install package ntfs-config from the repo-oss
    2. as root issue the following command in terminal window:
    Code:
    ntfs-config
    a window will pop-up where you can select which external or internal drives you would like to mount in read or read-write mode.

  8. #18
    GnuceLee NNTP User

    Default Re: Can't mount ntfs USB external disk


    To be able to mount external ntfs USB disks in read-write mode, you have
    to

    1. install package -ntfs-config- from the -repo-oss-
    2. as root issue the following command in terminal window:
    Code:
    --------------------
    ntfs-config
    --------------------


    a window will pop-up where you can select which external or internal
    drives you would like to mount in read or read-write mode.


    --
    GnuceLee
    ------------------------------------------------------------------------
    GnuceLee's Profile: http://forums.opensuse.org/member.php?userid=17274
    View this thread: http://forums.opensuse.org/showthread.php?t=390333


  9. #19
    fixeyeson NNTP User

    Default Re: Can't mount ntfs USB external disk

    I have the same problems. I am newbie of Linux. Plz tell me more details how to install packet ntfs-config and what is repo-oss
    Thanks.

  10. #20
    fixeyeson NNTP User

    Default Re: Can't mount ntfs USB external disk


    I have the same problems. I am newbie of Linux. Plz tell me more details
    how to install packet ntfs-config and what is repo-oss
    Thanks.


    --
    fixeyeson
    ------------------------------------------------------------------------
    fixeyeson's Profile: http://forums.opensuse.org/member.php?userid=20058
    View this thread: http://forums.opensuse.org/showthread.php?t=390333


Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •