Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Sound funnies on Dell 1525

  1. #1

    Default Sound funnies on Dell 1525

    I have installed Suse 11 on my Dell 1525 laptop. It has an
    82801H (ICH8) soundcard. I'm running KDE 3.5. When I boot the
    computer I get no sound.

    If I log in as root and run:

    /etc/init.d/alasasound restart

    I then get sound (but ONLY from the headphone jacks - no sound
    out of the speakers.

    But if I log out as root and log in with my personal account,
    I no longer get sound (either from the speakers or from the
    headphones). I can only get sound while running as root.
    I tried running

    sudo /etc/init.d/alsasound restart

    from my account but I still get no sound.

    [When it works, the sound is also relatively weak, but I see
    from a previous post that this may require a LOT more
    information, so I'll hold off on that problem until this
    one is fixed.]

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Sound funnies on Dell 1525

    Quote Originally Posted by Larry1019 View Post
    I have installed Suse 11 on my Dell 1525 laptop. It has an 82801H (ICH8) soundcard. I'm running KDE 3.5. When I boot the
    computer I get no sound.

    If I log in as root and run:
    /etc/init.d/alasasound restart
    I then get sound (but ONLY from the headphone jacks - no sound out of the speakers.

    But if I log out as root and log in with my personal account, I no longer get sound (either from the speakers or from the headphones). I can only get sound while running as root. I tried running
    sudo /etc/init.d/alsasound restart

    from my account but I still get no sound.

    [When it works, the sound is also relatively weak, but I see from a previous post that this may require a LOT more information, so I'll hold off on that problem until this one is fixed.]
    Lots of things to try. I don't know which is best. To start, add your regular user to group audio per step-6 in this guide:
    SDB:AudioTroubleshooting - openSUSE How_To_Fix_a_Permissions_Problem
    Then log out, and log back in (probably easiest to reboot).

    Also, another command instead of:
    sudo /etc/init.d/alsasound restart
    is
    su -c 'rcalsasound restart'

    and if you still have funny sound behaviour, please run the following script in an xterm/konsole while your laptop is connected to the internet:
    Code:
    wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa'
    and when prompted for a password enter your root password. That will give you a URL when it is done. Paste the URL here.

    Also, in addition to that, please provide output of:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound

  3. #3

    Default Re: Sound funnies on Dell 1525

    I added me back to the audio group, but it seems to make
    no difference. I still need to be root to get any sound.

    The URL which came back from tsalsa is:

    tsalsa.txt - nopaste.com (beta)


    and the output you requested is:

    frodo:~ # rpm -qa |grep alsa
    alsa-1.0.16-39.1
    alsa-plugins-1.0.16-57.1
    alsa-oss-1.0.15-48.1
    alsa-utils-1.0.16-35.1

    frodo:~ # rpm -qa |grep pulse

    frodo:~ # rpm -q libasound2
    libasound2-1.0.16-39.1

    frodo:~ # uname -a
    Linux frodo 2.6.25.9-0.2-pae #1 SMP 2008-06-28 00:00:07 +0200 i686 i686 i386 GNU/Linux

    frodo:~ # cat /etc/modprobe.d/sound

    options snd slots=snd-hda-intel
    # u1Nb.VhUtPypIg0D:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel

  4. #4

    Default Re: Sound funnies on Dell 1525

    OOPS -- Let me try that URL again...

    tsalsa.txt - nopaste.com (beta)

  5. #5

    Default Re: Sound funnies on Dell 1525

    Or do I have to wrap it???

    HTML Code:
    http://nopaste.com/p/aS35hU0qS

    If this doesn't work, I think I need directions
    to post an internet address....

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Sound funnies on Dell 1525

    Quote Originally Posted by Larry1019 View Post
    frodo:~ # cat /etc/modprobe.d/sound

    Code:
    options snd slots=snd-hda-intel
    # u1Nb.VhUtPypIg0D:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    OK, then try this - change this file to:
    Code:
    options snd slots=snd-hda-intel
    options snd-hda-intel model=3stack
    # u1Nb.VhUtPypIg0D:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    and in a konsole with root permissions restart your alsa with rcalsasound restart

  7. #7

    Default Re: Sound funnies on Dell 1525

    OK -- Some progress. I can now get sound with my account.
    But there are still three remaining problems:

    1) I still have to restart alsasound when I first log in
    (either via etc/init.d/alsasound or via rcalsasound -- the
    two files are identical).

    2) I still get nothing from the speakers

    3) The sound is very weak. I have set the master/pcm sliders
    to their maximum in alsamixer AND in Kmix AND in whatever
    sound application I'm using. Am I missing a volume control
    somewhere? Is it possible that the sound is so weak that
    I'm just not hearing the speakers in (2)?

    I suppose these are in reverse order of importance to me. I
    would really like to fix (3). The sound quality from the
    speakers is very poor anyway, but they are useful sometimes.
    And lastly the first problem has a relatively easy workaround.

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Sound funnies on Dell 1525

    Quote Originally Posted by Larry1019 View Post
    OK -- Some progress. I can now get sound with my account.
    But there are still three remaining problems:

    1) I still have to restart alsasound when I first log in
    (either via etc/init.d/alsasound or via rcalsasound -- the
    two files are identical).
    This should not be necessary. But if it is, then simply put in /etc/init.d/boot.local the command (last line):
    rcalsasound restart

    ... as for the other problems, .... well .... it looks to me like you made changes, and felt it not necessary to pass on the information (or you tried custom compilations, and felt it not necessary to tell me), so I no longer know what configuration is on your PC, so I can't help anymore. At least not until you let me know what your configuration is again. For example, in reply to my "rpm -qa | grep alsa" request, you posted:
    Quote Originally Posted by Larry1019 View Post
    and the output you requested is:
    frodo:~ # rpm -qa |grep alsa
    alsa-1.0.16-39.1
    alsa-plugins-1.0.16-57.1
    alsa-oss-1.0.15-48.1
    alsa-utils-1.0.16-35.1
    But the tsalsa script output tsalsa.txt - nopaste.com (beta) you posted has:
    Code:
    Alsa driver: 1.0.17        
    dpkg path:           
    Alsa utils: 1.0.16
    The above two are inconsistent, and only make sense if you updated alsa in between, or if you did a custom compile of alsa and did not say anything.

    The configuration details are all interlinked. And a recommendation can be worthless if your configuration is different.

    I can't help with those unknowns. Its a waste of my time and yours.

    Sorry. Maybe someone else can help.

    Good Luck!

  9. #9

    Default Re: Sound funnies on Dell 1525

    I apologize. I had installed another version of alsa last week thinking that might help. It didn't. At some other point, I (thought) I removed it and reinstalled the distro version. I'm not certain when I did the reinstall relative to this thread. I thought it was before, but it might have been inadvertently done during. At this point, perhaps I should start over with the install (since it was a fresh install on a blank disk, that's not too difficult). At that point, should I still have problems I'll get back. But in any case, I thank you for your help so far.

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Sound funnies on Dell 1525

    Quote Originally Posted by Larry1019 View Post
    I had installed another version of alsa last week thinking that might help. It didn't. At some other point, I (thought) I removed it and reinstalled the distro version. I'm not certain when I did the reinstall relative to this thread. I thought it was before, but it might have been inadvertently done during. At this point, perhaps I should start over with the install (since it was a fresh install on a blank disk, that's not too difficult).
    I don't think the audio warrants a re-install, but perhaps you have other reasons?

    Installing an alsa update can be good, but in future I hope you advise when you change things, so that I don't make a recommendation that makes things worse? Thanks!

    Anyway, to get back on track with the sound, please re-run the following script in an xterm/konsole while your laptop is connected to the internet:
    Code:
    wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa'
    and when prompted for a password enter your root password. That will give you a URL when it is done. Paste the URL here.

    Also, in addition to that, please provide output of:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound


    I assume this is now different from what was posted previous.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •