Page 1 of 6 123 ... LastLast
Results 1 to 10 of 54

Thread: Grub load fail

  1. #1
    soul77 NNTP User

    Default Grub load fail

    I've installed opensuse 11 in my secondary hard disk (ide) and my xp running in primary hard disk (sata). Setup my bios to load my secondary hdd 1st, opensuse is running smoothly but i cant load my xp thru GRUB. If i want to load my xp... i've to change my bios. Then suddently my GRUB wont load my opensuse. I am a linux newbies... can anybody help me PLEASEEEE!!!

  2. #2
    Join Date
    Jun 2008

    Default Re: Grub load fail

    Is GRub not loading or does it comes with a error message ?
    You also can try to use the repair option of install media
    maybe Grub will load totally again and after that we can write few extra lines in the boot loader to boot windows Xp
    Last edited by dobby9; 18-Jul-2008 at 12:00. Reason: add information

  3. #3

    Default Re: Grub load fail

    The important question here is what happens during the Windows XP load sequence? Does it fail in Grub? Or does it attempt to start Windows and Windows itself won't boot?

    The most likely reason is the switching of disk boot order that you have done. If you switched the disk order BEFORE installing OpenSUSE, then it is likely that the disks aren't where Windows thinks they are at boot time. This would explain why you can boot Windows when you switch back to the old disk order, but not from Grub.

    If what I have been suggesting turns out to be the case, your best bet would be to switch the boot order back to the way Windows likes it and then install Grub in the MBR of the first SATA disk. There are a number of ways to do that; if you are unsure of how to do it, you might just reinstall, making sure that OpenSUSE is installed on the second disk and that the first disk is left alone (except for the MBR).

  4. #4

    Default Re: Grub load fail

    Or you might be able to fix the problem by adding the map command to /boot/grub/menu.lst. See the Grub manual for more information. (Since you have switched the boot order when running OpenSUSE, Windows is now installed on the second disk ... and Windows does not like that!)

  5. #5
    soul77 NNTP User

    Default Re: Grub load fail

    thanx for the reply,

    now my problem is i cant boot to my opensuse, grub said error missing operating system. i only can launch it thru the livecd.

  6. #6
    Join Date
    Jun 2008
    Atlanta, Georgia, USA

    Default Re: Grub load fail

    @soul77 -

    You are going to need to post back the output of, from root:

    fdisk -l
    cat /boot/grub/
    cat /boot/grub/menu.lst
    As suggested above, you have a misalignment somewhere between the bios boot sequence, where the boot loader is installed, the grub boot device alignment file (, or the grub boot menu (menu.lst). There are actually a number of ways to make this work, none difficult, but the controls all have to be consistent with one another.

    It is quite likely that you just need to boot from the pata drive (so set up this way in the bios) and "chainload" to the XP boot loader. That requires the "map" command because XP needs to think it is on the first drive in the sequence. The map command may not have been included in the openSUSE boot setup because at the time of the install, the bios boot sequence had the XP drive first. Post back the outputs above and we'll sort this out quickly.

  7. #7
    Join Date
    Jun 2008
    Houston, TX

    Default Re: Grub load fail

    I have the same problem as soul77, except that I have a dedicated LINUX machine that I upgraded from 103 to 11.0 and that cannot boot without the install DVD in ...

    Here is my fdisk -l result:
    suse:/home/vffavre # fdisk -l

    Disk /dev/sda: 120.0 GB, 120034123776 bytes
    240 heads, 63 sectors/track, 15505 cylinders
    Units = cylinders of 15120 * 512 = 7741440 bytes
    Disk identifier: 0xb2420d13

    Device Boot Start End Blocks Id System
    /dev/sda1 1 15505 117217768+ 83 Linux

    Disk /dev/sdb: 320.0 GB, 320072933376 bytes
    255 heads, 63 sectors/track, 38913 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x00041486

    Device Boot Start End Blocks Id System
    /dev/sdb1 1 262 2104483+ 82 Linux swap / Solaris
    /dev/sdb2 * 263 2873 20972857+ 83 Linux
    /dev/sdb3 2874 38913 289491300 83 Linux
    Here is my cat /boot/grub/
    (hd0) /dev/sda
    (hd1) /dev/sdb
    And my cat /boot/grub/menu.lst
    suse:/home/vffavre # cat /boot/grub/menu.lst
    # Modified by YaST2. Last modification on Tue Jun 24 21:21:12 CDT 2008
    default 0
    timeout 8
    gfxmenu (hd1,1)/boot/message
    ##YaST - activate

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 11.0
    root (hd1,1)
    kernel /boot/vmlinuz- root=/dev/sdb2 showopts resume=/dev/sdb1 splash=silent
    initrd /boot/initrd-

    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.0
    root (hd1,1)
    kernel /boot/vmlinuz- root=/dev/sdb2 showopts ide=nodma apm=off acpi=off noresume edd=off x11failsafe
    initrd /boot/initrd-
    I tried to install grub from the console using grub-install and from Yast putting it into the MBR but nothing works ...

    Please help.

  8. #8

    Default Re: Grub load fail

    I'm having the same problem with a very similar setup. Old hard disk sda has Windows and SuSE10.3 partitions on it, and I added a new disk sdb and installed 11.0 on it. Now the system boots to a Grub stage 1.5 error 25.

    Any help recovering would be much appreciated.

  9. #9

    Default Re: Grub load fail

    Ok, I'm now a step further. After a semi-random act of editing I booted my computer with the SuSE11 live CD and mounted the original hard disk sda to have a look at Grub's configuration files and then I edited

    linux> su
    linux> mount /dev/sda3 /mnt
    linux> vi /mnt/boot/grub/
    and added at the end of the file the line:
    (hd1)   /dev/sdb
    Then rebooted and bingo, it started back with SuSE10.0 again. From Yast I selected System -> Bootloader -> Other -> Propose and Merge which gave me a SuSE 11.0 menu entry from sdb1. Unfortunately this doesn't boot, but comes up with a Grub error 25 still. Thinking my luck may be in I tried 'grub-install /dev/sdb' but no change. It is now obvious that something is not correctly configured on this drive, but what?

    Any suggestions? Thanks in advance.

  10. #10

    Default Re: Grub load fail

    ksurf1, looks right.
    Did you install grub to /dev/sdb mbr?
    What disk is your Bios booting from?
    It is abhorrent the spiritual greed of those that knowing something, do not seek the transfer of such knowledge.

    Miguel de Unamuno - Writer (1864-1936)

Page 1 of 6 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts