Results 1 to 9 of 9

Thread: Tor + FoxyProxy

  1. #1
    Join Date
    Jul 2008
    Location
    Nanjing, China
    Posts
    78

    Default Tor + FoxyProxy

    I installed tor, but when I tried to run it:
    /etc/rc.d/tor start
    it complained that there was no /etc/tor/torrc
    I made this file, (copied from torrc.sample) and now it runs but FoxyProxy still refuses to work. It says that servers are taking too long to respond. I don't want to use privoxy, how can I get just tor working with FoxyProxy???

    Thanks!

  2. #2
    Join Date
    Jul 2008
    Location
    Nanjing, China
    Posts
    78

    Default Re: Tor + FoxyProxy

    Alright, got tor working (with no changes actually, it just decided to work this time). How can I add the tor daemon into the system startup? I searched for /etc/rc.local (what I'm used to) but that's non-existant in openSUSE. Any ideas?

  3. #3
    Join Date
    Jul 2008
    Location
    Nanjing, China
    Posts
    78

    Default Re: Tor + FoxyProxy

    Shameless bump.

  4. #4
    Join Date
    Jan 2008
    Location
    Kenton, TN USA
    Posts
    1,023

    Default Re: Tor + FoxyProxy

    Thread moved to Network/Internet
    opensuse.org.help.network-internet
    Last edited by kastorff; 23-Jul-2008 at 05:46.
    Keith Kastorff

  5. #5
    Join Date
    Jul 2008
    Location
    Nanjing, China
    Posts
    78

    Default Re: Tor + FoxyProxy

    I've been faked out sooo many times thinking I have a response to my thread when really I've just been told that the thread has been moved.

  6. #6

    Default Re: Tor + FoxyProxy

    Quote Originally Posted by cisforcojo View Post
    Alright, got tor working (with no changes actually, it just decided to work this time). How can I add the tor daemon into the system startup? I searched for /etc/rc.local (what I'm used to) but that's non-existant in openSUSE. Any ideas?
    Is this what you are looking for?

    "Control Center" -> "System" -> "Session Preferences" -> "Add"

  7. #7
    Join Date
    Jul 2008
    Location
    Nanjing, China
    Posts
    78

    Default Re: Tor + FoxyProxy

    Huh. Could be, I don't have that though, I've got System Services (Runlevel). That's the closest wording I have to 'Session Preferences'
    I have tor listed in the runlevel preferences but when I click 'Enable' it says that tor isn't running. I got it to work once like this but the Control Center crashed. Perhaps I just need to reboot but I just did an update and ~5 KDE packages couldn't be located so I'm scared to reboot/logout until I get em for fear that I have a broken system! One step at a time, one step at a time hehe

  8. #8

    Default Re: Tor + FoxyProxy

    Apologies, I should have checked whether you were using Gnome, which I am. I do not know where to look in KDE, but you should have something akin to "Session" somewhere?

  9. #9
    Join Date
    Jul 2008
    Location
    Nanjing, China
    Posts
    78

    Default Re: Tor + FoxyProxy

    No worries! I know how to do it in GNOME as well, it's fairly easy! hehe KDE, not so sure.

    Thanks for your help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •