Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Please help: Can't write/delete FAT (even with SuperUser)

  1. #1
    Join Date
    Jun 2008
    Location
    Bangalore, India
    Posts
    20

    Unhappy Please help: Can't write/delete FAT (even with SuperUser)

    I've been trying to write/delete to my FAT partition for about 2 weeks now and can't. Usually I use Konqueror, but I've also used SuperUser Dolphin, I've even opened a new Root account... but nothing allows me to write/delete to my FAT partition, nor can I even change permissions either (though I have read/write privileges as a user, though the OTHER group has only READ privileges).

    What is frustrating is that I think I was able to write/delete in my FAT partition when I installed openSUSE 11. But now I can't. I'm sure I messed up somewhere... but I'm not linux proficient enough to figure it out.

    I've been forum/google search like crazy but it seems that no one really has this problem or haven't reported it's solution that I know of.

    I use openSUSE 11 with a dual boot of Windows XP Home. My FAT partition is about 4.5 GB. I use KDE3.5 (though I also have KDE4 installed). My fstab details are:

    /dev/disk/by-id/scsi-SATA_TOSHIBA_MK8032G_56SN0413T-part6 swap swap defaults 0 0
    /dev/disk/by-id/scsi-SATA_TOSHIBA_MK8032G_56SN0413T-part7 / ext3 acl,user_xattr 1 1
    /dev/disk/by-id/scsi-SATA_TOSHIBA_MK8032G_56SN0413T-part8 /home ext3 acl,user_xattr 1 2
    /dev/disk/by-id/scsi-SATA_TOSHIBA_MK8032G_56SN0413T-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/scsi-SATA_TOSHIBA_MK8032G_56SN0413T-part2 /windows/D ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/scsi-SATA_TOSHIBA_MK8032G_56SN0413T-part5 /windows/E vfat user,users,gid=users,umask=0002,utf8=true 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    debugfs /sys/kernel/debug debugfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    I don't mind having only read privileges for my NTFS drive (though it would be nice to write). But I really need to be able to write to the FAT (vfat) partition.

    Please, please, do help. Thanks... in anticipation.
    Last edited by nayk92; 18-Jul-2008 at 00:00. Reason: more detail

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Please help: Can't write/delete FAT (even with SuperUser

    It looks correct in fstab

    Have you tried super user, then go to folder where drive is mounted
    right click - properties
    in permissions tab - drop down boxes, set all to read write
    Last edited by caf4926; 18-Jul-2008 at 00:06. Reason: typo
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Rome, Italy
    Posts
    248

    Default Re: Please help: Can't write/delete FAT (even with SuperUser

    Well i agree it is very strange that root cannot delete any file. So try to perform a scandisk in windows or in linux fsck'vfat on the partition.

  4. #4
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Please help: Can't write/delete FAT (even with SuperUser

    Try replacing this:
    /dev/disk/by-id/scsi-SATA_TOSHIBA_MK8032G_56SN0413T-part5 /windows/E vfat user,users,gid=users,umask=0002,utf8=true 0 0
    by this:
    /dev/sda5 /windows/E vfat users,gid=users,umask=0002,utf8=true 0 0
    So do that first then do this:
    The directory "E" in /windows/E. I suggest you change it's owner to root:users. Here's the routine to do that without getting at odds with the mounted drive:
    • Open a terminal and assume root privileges with command: su
    • Unmount the partition with command: umount /dev/sda5
    • Change ownership with command: chown -R root:users /windows/E
    • Change permissions with command: chmod 775 /windows/E
    • remount it with this command: mount -a
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  5. #5
    Join Date
    Jun 2008
    Location
    Bangalore, India
    Posts
    20

    Default Re: Please help: Can't write/delete FAT (even with SuperUser

    To Swerdna: Hey thank you so much for taking the time to reply. Your great reputation precedes you!

    I did what you said, (it does look neater), but it didn't work.

    I think my E drive was anyway owned by root... But I still followed those steps... but it's just the same... doesn't work, whether I use super user file manager or just plain browser.

    Any other suggestions??? (if you have the time)

  6. #6
    Join Date
    Jun 2008
    Location
    Bangalore, India
    Posts
    20

    Question Re: Please help: Can't write/delete FAT (even with SuperUser

    Quote Originally Posted by bcrisciotti View Post
    Well i agree it is very strange that root cannot delete any file. So try to perform a scandisk in windows or in linux fsck'vfat on the partition.
    Thanks for this suggestion... but when I went to the terminal and typed fsck'vfat all it did was change the command prompt to > and then I couldn't do anything else, even exit (I had to manually close). Am I missing a step?

  7. #7
    Join Date
    Jun 2008
    Location
    Bangalore, India
    Posts
    20

    Exclamation Re: Please help: Can't write/delete FAT (even with SuperUser

    Quote Originally Posted by caf4926 View Post
    It looks correct in fstab

    Have you tried super user, then go to folder where drive is mounted
    right click - properties
    in permissions tab - drop down boxes, set all to read write
    Thanks for your comment caf4926. I have tried super user and go to the mounted (windows/E for me)... and then try the permission tab.

    These are the settings of permissions:

    Owner: can view & Modify contents
    Group: can view & Modify contents
    Others: can view contents

    Owner is root
    and Group is user. (my login is part of group user).

    And when I try to change the settings to allow even "others" to view & modify contents it says:

    Cannot change permissions for windows/E

    Similarly it says cannot delete file... when I try to delete any file.

    Hope that gives you the appropriate details. Thanks again.

  8. #8
    Join Date
    Jun 2008
    Location
    Mangalore, Karnataka, India
    Posts
    146

    Default Re: Please help: Can't write/delete FAT (even with SuperUser

    Press Alt and F2

    Type
    kdesu kwrite
    and press ENTER

    Browse to your /etc/fstab

    Click on file-> Save as and save it as fstab.old

    Again click on file->Open and browse to /etc/fstab

    Delete everything and Paste this

    /dev/disk/by-id/scsi-SATA_TOSHIBA_MK8032G_56SN0413T-part6 swap swap defaults 0 0
    /dev/disk/by-id/scsi-SATA_TOSHIBA_MK8032G_56SN0413T-part7 / ext3 acl,user_xattr 1 1
    /dev/disk/by-id/scsi-SATA_TOSHIBA_MK8032G_56SN0413T-part8 /home ext3 acl,user_xattr 1 2
    /dev/disk/by-id/scsi-SATA_TOSHIBA_MK8032G_56SN0413T-part1 /windows/C ntfs-3g user,users,gid=users,umask=0002,locale=en_US.U TF-8 0 0
    /dev/disk/by-id/scsi-SATA_TOSHIBA_MK8032G_56SN0413T-part2 /windows/D ntfs-3g user,users,gid=users,umask=0002,locale=en_US.U TF-8 0 0
    /dev/disk/by-id/scsi-SATA_TOSHIBA_MK8032G_56SN0413T-part5 /windows/E vfat user,users,gid=users,umask=0002,utf8=true 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    debugfs /sys/kernel/debug debugfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    Reboot

    You should be now able to read and write to /windows C, D and E as a normal user.
    nucleuskore
    "The Future Is Open"
    http://www.neville.in
    http://www.linuxrocks.in

  9. #9
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Please help: Can't write/delete FAT (even with SuperUser

    Quote Originally Posted by caf4926 View Post
    It looks correct in fstab

    Have you tried super user, then go to folder where drive is mounted
    right click - properties
    in permissions tab - drop down boxes, set all to read write
    Just a tip: If you want to change the ownership of a directory that is the mount point for a partition, it will generally be ineffective unless you umount the partition first, and even then the final result when you mount it again depends on the options you choose for it in fstab, and different filesystems react differently to this tactic. It's all a bit confusing
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  10. #10
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Please help: Can't write/delete FAT (even with SuperUser

    Quote Originally Posted by doctorjohn2 View Post
    Press Alt and F2

    Type
    kdesu kwrite
    and press ENTER

    Browse to your /etc/fstab

    Click on file-> Save as and save it as fstab.old

    Again click on file->Open and browse to /etc/fstab

    Delete everything and Paste this



    Reboot

    You should be now able to read and write to /windows C, D and E as a normal user.
    Be careful here, maybe a typo. I think for this alphanumeric string:
    user,users,gid=users,umask=0002,locale=en_US.U TF-8 0 0
    you should close the gap between US.U and TF-8, so it's like this: US.UTF-8.
    And that's for both the lines with NTFS. Then I think doctorjohn2's ntfs mounts would work for partitions 2 and 5.
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •